Phonak Marvel 90 R Bluetooth Problem and Fix

#1

I recently got a pair of Marvel M90 R’s and at first was quite impressed with my new Samsung S10+. But after the first Samsung update I started having problems with phone conversations, I could hear the other party but they couldn’t hear me. I tried the Samsung forum with no luck even after being escalated to the Samsung “team”.
I finally contacted Phonak and they had some suggestions and the last one fixed my problem. I had my audiologist change the Bluetooth setting from Adaptive to Fixed and that seems to have fixed the problem. Phonak said they had experienced this with some IPhones. Anyway, since the Bluetooth adjustment phone calls have been working great. All other streaming features work great too.
Thanks Phonak

4 Likes

#2

Interesting. I remember Phonak pointing fingers at Apple, saying they (Phonak) had come up with a solution to Apple’s problem. (LOL - companies throwing sand at each other in the sandbox!) Look’s like Phonak’s “Fixed” bluetooth mode isn’t just applicable to Apple now. Glad you got this sorted out!

0 Likes

#3

Regardless who’s at fault or who fixes it, I’m happy everything is working on my hearing aids now.

1 Like

#4

I had the same problem with my Marvels and my S10+ phone. This solution worked for me as well. I changed the bluetooth bandwidth to Fixed in the Phonak Target fitting software, and the problem was solved!

0 Likes

#5

I also had the same issue with my S10, but since the S10 firmware update 4 (July) I have been able to use adaptive bandwidth again. It seems to be better quality with phone calls and more stable. Only been using for six days now but so far no glitches yet.

0 Likes

#6

I’ll try getting it switched back at my next appointment. Although it’s been working fine with the “fixed” setting.
Thanks for the info

0 Likes

#7

Verizon is my carrier, your carrier may not work the same. It’s a risk and a trip back to fix. I do my own programing so easy to switch back. My own experience is adaptive sounds better to me. From what I’ve read adaptive skips around the bluetooth channels to avoid interference.

0 Likes

#8

I guessed you did your own programming and can make changes quickly. I was wondering how you got the change done so quickly. Wish I knew more about programming and may look into that. I would like being able to “tweak” my aids.
Thanks for the post

0 Likes