Oticon's ConnectClip continually disconnecting

Hello everyone,

I have a huge problem with my ConnectClip since yesterday.
I’m using it with my MacBook Pro 2017 and my Oticon hearings (Real 1 miniRITE T, Firmware 1.0.1)
Basically I’m using it every single day, and now when I’m listening music my ConnectClip is continually disconnecting every 10s.

I try to reset the ConnectClip but this doesn’t fixed the problem, I tried to reset the PRAM/NVRAM and SMC of my MacBook, and nothing … (I can’t debugging the Bluetooth … when I’m trying to press Shift+Option+Bluetooth it’s doesn’t work)

Does my ConnectClip has a problem ? Can I do anything else to try to fixe the problem ?

Thank you in advance.

1 Like

I started having the same problem with my connect clip this week, luckily I have a backup clip that I am using now. I really expect it to start doing the same thing. I have the More1 aids and I use the clip to stream audio books from my Fire tablet. I have a email into my VA audiologist and also the Oticon rep for the VA. I am hoping it is only a firmware update issue. But there are a number of complaints about the issues with it here on this forum. I did a full reset of my connect clip and pairing again to the aids and tablet with no help. Not sure what it did to the clip. So your issue isn’t isolated.

You didn’t say which Oticon hearing aids you have? Is it the OPN? Or the More? Or the Real? The ConnectClip has been working very reliably with the OPN. The More and Real give users a lot of connection problems with the ConnectClip. You can do a search on this forum to find those threads and read up on it. Bottom line is that they’ve found the cure for the Real and released a firmware update with the fix very recently. The report from @darylm on the Real firmware fix is so far positive.

They have not been able to find a fix for the More yet. The temporary workaround is to revert the More back to firmware 1.3, but even so, it may work again reliably for a little while, and then it may go bad again, even for the 1.3 firmware. Another temporary workaround is to have your HCP clear out the pairing of the ConnectClip inside of the Genie 2 programming software. If you’re a DIY person then you can do it yourself. But again, that may fix it for a little while then the problem will likely recur again anyway.

Hi, I already mention it, they are REAL. I will check the report from @darylm thx.

Oops, sorry I missed that part (I read too fast sometimes). Then I think you should be good with the new firmware release for the Real.

But you think I have to update my HAs or the ConnectClip ?

I think you should update the Real firmware to 1.1.0 per the link below

As for the ConnectClip, you’re probably OK there and no need to update.

1 Like

I have the same issue with an iPhone. There are hundreds of connectivity problems with both android and Apple products. I’d like to be part of the solution. I’m going to start contacting Oticon to figure out who works in the Bluetooth department. It’s got to be a connecting to Bluetooth issue.

Do you know the latest version for the More aids.

@Nicolas When you say the ConnectClip disconnects every 10 seconds, do you mean that the audio drops out, then returns on its own? If so, this is a well known problem. Until recently, the only “fix” for this problem was to clear the pairings in the HAs, which requires the Genie 2 software and a Noahlink Wireless unit. This “fix” was only temporary.

However, I’ve been using the latest firmware with my Real HAs since it was released and I have not experienced the audio drop-out a single time, so I think there is no question it’s at least a major improvement, if not a conclusive fix. Time will tell if it’s a conclusive fix, but it’s looking that way.

I know that Oticon has been reverting people’s More back to 1.3 in an attempt to workaround the connection issue. So I’m guessing that the More is at least at version 1.4.x or something like that. Maybe @darylm can remember this detail because he’s has the most experience with this whole CC fiasco by far.

@cvkemp Sorry to hear you are having this problem, when you were seemingly unaffected before. If you’re experiencing the same audio drop-out problem that’s discussed in the other thread, resetting the ConnectClip doesn’t fix it. You have to also clear the pairings in the HAs which can only be done using Genie 2 and a Noahlink Wireless unit. I’m surprised that you were able to get your HAs to pair with another CC without first clearing the pairings in the HAs. I have two CCs and I found that the problem was the same in both. I don’t think the problem is the CC, but rather the HAs, but your situation could be different. Do your CCs have the same firmware?

@Volusiano In my case, when I had More HAs, I started with 1.3.0 but I only spent a short time at that version, not long enough to know if they worked reliably with the CC. When they were upgraded to 1.4.0, that broke the connectivity with the iPhone and I also started noticing the CC audio drop-outs. Even when the newer firmware versions were released to fix the MFi problem, they never worked properly with the CC. My HAs were downgraded to 1.3.0, but I found that the CC problem eventually appeared. So I do not think there is a version of More firmware that works properly. YMMV.

I think so as far as the cc firmware. They both are older cc that i have had since 2018

I just fixed my CC by following this following procedure to the letter. Just power cycling the aids from the rocker button doesn’t work, there is something about placing them in the charger that does the trick.

How to pair aids to connect clip

Oticon suggested pressing all three buttons and holding them…the light will turn white, then red. Then place the aids in the charger and turn the connect clip on and take the aids out of the charger. The connect clip will pulse yellow looking for the aids and then green when it finds them. Then they suggested to forget the pairing on the phone and re pair it through bluetooth. Once repaired they suggested to turn on the remote microphone (hold large button till the light turns pink). If the remote mic works with no problem and keeps the connection it rules out the connect clip being the problems and then we could assume its an aid problem. If the aids are connected to the phone and the connect clip is the two will fight and usually the aids will win so there is a known struggle but we can start by seeing if the connect clip is working

Yes this works

Well, I don’t know if the audio exactly drops out. Basically every 10s the bleu light flashs one time and then the orange light comes again. I feel more like it’s a bluetooth connection issue … I don’t know.

I’m very upset … ! It works for 4/5 weeks (my HAs are news too) and already it doesn’t work … (With the TV and my iPhone I don’t have any problem … but with my Mac … it goes wrong …).

Anyone haves the link for download the Genie 2 software ? Maybe I can update my ConnectClip … but I’m not sure it will fixe the problem …

It’s not just the Genie 2 software alone that will connect to your hearing aids automatically. You’ll have to spend around under $200 to purchase the NoahLink Wireless interface as well to connect your hearing aids to the software.

If you’re still keen on buying the hardware to get it done as well, then go to the DYI section of this forum and look through the threads there to request for a copy of the software.

Even then, the issue may be fixed for a short while until it recurs again. The more stable approach is to update your Real firmware like @darylm did.

1 Like

@cvkemp The procedure you referenced only clears the pairing in the CC. It does not clear the pairing in the HAs. The only way to do that is using Genie 2. I’m not aware if putting the HAs in the charger does anything else, beyond turning them off and on using the button, but it definitely does not clear the pairings. It’s very easy to verify that using Genie 2.

Really ? No :sob::sob::sob::sob::sob::sob:
I hope my audiologist could fix the problem definitely or change my ConnectClip …

As @Volusiano explained, the audiologist can update the firmware in the HAs. Unless you have something else going on, there is nothing wrong with the CC, but as I’ve explained before, YMMV.