Strange Phonak TV Connector problems

I have new phonak marvel m90 hearing aids. I’m trying to use the phonak tv connector to stream directly into my hearing aids. This connector worked with my previous phonak hearing aids and I was told this old tv connector would work with my new hearing aids. I use the optical audio out cable to connect the tv connector to my vizio tv which does not have a headphone jack. I stream programs (netflix, hulu etc.) through roku. When I plug in the tv connector the signal is no longer fast(?) enough to stream the program – lots of buffering and finally no signal. My audiologist called phonak and they said there was no way this was a problem with the hearing aids and/or the tv connector. There are times when the tv connector works – sometimes for most of the day and other times for only five minutes. There are so many pieces to this problem - hearing aids, tv connector, roku device, tv, internet service (spectrum, 100 mpbs as measured on my computer)…

Can anyone suggest a solution for this problem? Should I invest in a new style tv connector? Are there other devices I could use to stream directly into my hearing aids?

If the tv audio worked before I don’t see how that could be the problem. “When I plug in the tv connector the signal is no longer fast(?) enough to stream the program – lots of buffering and finally no signal.” So the video is buffering? Or just the audio?

Buffering is both. the video stops and the audio stops along with it.

Which aids did it work with?
The new Marvel aids use a different TV connector.

1 Like

My previous hearing aids were Phonak Audéo B70-Direct purchased in the second half of 2017 - same bte for profound hearing loss.

Thanks,
The B direct users the same tv connector. Yours probably doesn’t have the volume or on/off buttons on top of it.
The TV connector needs to be selected in Target for your aids too.
The Audeo aids are RIC aids.

I would almost bet this is not related to the hearing aids or tv connector. It is most likely an internet problem. When it is happening try disconnecting the audio cable from the tv. If that fixes it I will be surprised. If not try rebooting anything in the internet path including the tv. Remove power to be sure.

Good luck

2 Likes

If I unplug tv connector from the wall (power) the problem goes away immediately.

Strange! Can you use rca output instead of digital?

Is your TV set to PCM under the sound/digital audio out.

The TV connector operates in the 2.4 frequency range–the same as the most common wifi (wifi is also available at 5 frequency range).
If you use wifi for your roku and you are using the 2.4 frequency then you probably have interference. If your wifi supports the 5 frequency and the Roku also supports it then try changing the frequency. If that is not an option you can try specifying the wifi channel within the 2.4 frequency by changing settings in your router. You will need to experiment to find the channel that works best.
Microwave ovens also operate in the 2.4 frequency band and my microwave affects my KS 9s reception of the TV connector.
Most wireless phones also operate in the 2.4 frequency band to if you start changing things you may affect the operation of your wireless phone.
If interference is the problem you may be able to reduce the interference by moving the TV connector away from the Roku.

Don2: I do see a rca output on the tv. Can I get a connector that goes from headphone jack to rca?

Raudrive: I’m not sure what PCM means but I’ll look in the manual.

Bob999: You may have hit on something. I do have my router connected at 5GHz. I will change that connection and see what happens. Yes I microwave but I don’t use a wireless phone so maybe I’ll be ok.

thanks for all the suggestions. I’ll look into them. At this point I’ve given up on “understanding” the problem. Now I just want fix it.

1 Like

Yes you can get an adapter. That is what I use. Hope it helps.

With all the additional traffic on the internet, I am having buffering issues on my 200 Mbps Spectrum connection. Previously, I was streaming 4K video flawlessly. In the ladt week both Netflix and PriveVideo frequenrly stall.

I suggest you try reducing the video resolution to a lower setting. For example, switch from 1080p to 720p and see if it resolves your issues.

Good luck during these trying times.

Have you tried to plug your tv connector into another plug socket in another room using an extension cord? There is also the possibility that the power transformer of the TV connector is defective and interferes with the current for your TV. If possible you should try to use a different electric phase for both devices if you have 2- or 3-phase electricity at home as we have at my destination.

Raudrive, I changed the setting on the audio on the tv. The tv connector has been working all day! I don’t really understand what PCM means or why an audio setting caused so much trouble with the video. But I think your suggestion fixed it. Thanks a thousand times.

For the other posters, I tried many of your suggestions but the problems stubbornly hung on. Phonak actually came close to the answer. My audiologist dealt with them and they suggested I check the settings on my tv. While that was the answer it was too vague to be meaningful. There seems to be 100’s of settings. That’s what is great about this forum - answers from actual users. thanks to everyone

3 Likes

That’s great news. Glad that has worked for you.

Just helping you the way members have helped me.

1 Like

The tv connector works perfectly with my phonak m90s. If you have a roku remote where you can plugin an audio jack you can also allow the TV’s speakers to work at the same time. Pretty cool!

I think you can do that with most tv anyway. The audio out is line out not head phones. You can probably go into the setup on the tv and make a change if needed.