Smart3D App & New iPhone SE 2020 - Endless Loop Exiting Demo Mode

I’m in an endless loop in Demo Mode in the Smart3D app on my recent iPhone SE 2020.

I had troubles with the app, deleted it, downloaded it again, and now I am stuck in an endless loop. The app recognizes that I want to re-pair my HAs. I have the instructions. I click on the Demo mode X and exit to Demo mode. I attempt to switch off Demo, but I am in Demo so it reopens the demonstration again.

I’m beginning to regret every having bought ReSound hearing aids. They take way too much rebooting and reinstallation to make the ‘made for iPhone’ feature work. With every new release of the Smart3D app it becomes more difficult to make things work. Yet one more ‘cute’ feature like Demo Mode is added and enhanced and more maintenance is required.

What am I missing?

thanks,
baumgrenze

I’d uninstall the app once again. And be sure that you delete all cache and files. Then install again.

Thanks for the suggestion. I didn’t realize that Apple’s IOS has provisions for deleting the cache and files. I’ll research that and see if I can understand the way it is done.

Thanks,
baumgrenze

The first hit I found ( How to Clear Your Cache on an iPhone | Digital Trends) says this for 3d party apps:

"Next, you can clear cached data for apps other than Safari, which includes native and third-party apps. Essentially, this involves either deleting an app outright, or deleting an app to clear its data and then reinstalling it again. Either way, here’s what you have to do:

Step 1 : Go to Settings > General > iPhone Storage. Scroll down to the list of apps and tap on one that you want to clear.

Step 2 : Next, tap Delete App . Tap Delete App again to confirm.

Step 3 : If you want to reinstall the app (without the documents and data you’ve just deleted), go to the App Store and reinstall it.

Follow the above process for as many apps as you’d like to clear. Again, make sure you’re not clearing the cache of anything you actually would prefer to keep."

I believe this is what I did. The Smart3D app still opened in Demo and there is no exit that I can see.

thanks
baumgrenze

I think you have completely to disconnect your HA’s from Bluetooth, forget device then install Smart 3D app and pair your HA’s again. I had similar problem with my Quattro’s and iPhone SE2020 and my audi told me to do this if I ever encounter some problems with Smart 3D app.

Thank you, dmrtjes!

I did this and the app opened in Demo mode. I was not permitted to go to ‘normal’ mode.

My experience is like Yossarian’s , a Catch-22 pure and simple. In seeking ‘simplicity’ ReSound has created an app where the user and the software can no longer detect the difference between ‘make believe’ and reality.

I am also reminded of the works of Franz Kafka.

I will try tomorrow to connect with my audiologist.

Thanks again,
baumgrenze
Stay safe and stay healthy!

@baumgrenze I think I had this problem last year when I was running the iOS 13 beta. If I remember correctly, there should be buttons near the bottom of the screen to exit demo mode after installing the app. But these didn’t show up while I was on the iOS beta. I had to downgrade to iOS 12. Do you happen to be running the iOS 14 beta?

Thank you for your reply, narenkona

I am running IOS 13.7. I believe it ‘updates’ automatically.

You mention buttons near the bottom of the screen. I have the iPhone in a Otterbox Defender which covers a thin edge of the screen to protect it.

How close to the bottom of the screen? Mine does show Home, Status, My ReSound, and Demo in red with 2 bars below Demo and then the word ‘more.’

Is it time to put some images on Imgur and a link to them? A picture is worth many words. I don’t see a way to upload images.

thanks
baumgrenze

Let me look later today and see if I can make one of my old iphones get this issue… I don’t want to uninstall/reinstall the app on my current phone while in the ios 14 beta, in case I end up with the same problem!! … I’ll reach out again here after trying this in a few hours.
narenkona.

@baumgrenze, I tried this on my old iphone, and didn’t get what I originally had last year - Looking at it now, I think what was gone last year was that whole bottom row where you see home/status/my resound etc… So there was no way for me to get into the Demo / more section.
You seem to have another issue… I figured out how to upload images (little up arrow above the area where we input text… to the right of the double quote, and </> sign…

I did run through getting out of Demo mode though, and took some pics of it.

Click the Demo / More button and you should see the following:

Click the Demo Mode off and you should see:

Scroll to bottom, and then click Agree, and you will see either this screen if something is wrong…

Is this where you are getting into the loop? … I did a couple of things:
a. exit the app and go into settings, make sure Bluetooth is turned on
b. If Bluetooth is on, go into Settings, scroll down to the settings for Resound 3d app, and ensure that you are allowing the app to use bluetooth.
c. Go back into app… and hopefully you’ll see this:

If you do see that, then you should end up with:

And finally:

Hope this helps!!

1 Like

Thank you for persisting narenkona!

This does help a great deal!

I found that I could not distinguish the ‘fantasy’ of the the ‘Demo Mode’ and reality and I elected to Exit to Demo, which is in reality a vicious feedback loop.

It is so difficult for developers to see their ‘brain child’ from the perspective of the user, especially a community of users who are primarily significantly older than they are.

The loop has moved to Getting Connected, Please Pair Your Hearing Aids in Settings.

I cannot see how to shut down the Demo Mode. I guess I need clear, stepwise instructions as to how to accomplish this.

Thanks
baumgrenze

I am back once more tonight. I reread everything and decided to try again. Clearly the process, as documented, is stuck in “Found hearing aids” “Getting connected” the very last image documented step. I restarted the hearing aids several times. The final time I left them turned off for over a minute before I restarted them.

I had high hopes that an itinerant HA repair profession would show up and restore my wife’s 15 month old Phonak charger and explain clearly what I am doing wrong, or what is wrong with my system. His scheduler said he would stop by, but apparently a Covid-19 Catch 22 kept him from keeping an appointment he made with us without our being notified.

Not a good day, and now the sad news about RBG. She was a trooper!

thanks for all your work
baumgrenze

Who is still hoping someone can see why my HAs won’t connect.

I went to shut down the app and followed narenkona’s outline. I got further. After over an hour of each step failing and then working in Settings, I finally reached the ‘You’re Connected’ screen.
I went back to the app screen and it was still in Demo mode. When I clicked on the right corner X, my only option was to return Demo mode!
Clearly this does not need to be so complicated!
Thanks again,
baumgrenze

baumgrenze, I’ll try to do a step by step tomorrow morning my time (EST), to help you on this. Have you confirmed that in the iPhone settings / Accessibility / Hearing Devices, your hearing aids show up as connected under “MFI Hearing Devices” ? …

thanks, Narenkona

Hello narenkona,

Yes, I see that as the heading. At present they report as “Not Connected.”

I see we are both in the EST zone. I’m in Charlottesville, VA, an immigrant of 6 months from a 50-year-long sojourn on the ‘left coast’ in Palo Alto, CA.

You are very kind to persist with me. It is hard for an old-timer to make connections in a new place while we are in the ‘interesting times’ we are experiencing.

I will try to watch my inbox, but my Sunday schedule is filling up with 2 church zooms, here and in Palo Alto, and a brief get together with our daughter in the afternoon.

thanks
baumgrenze