Phonak Roger Bluetooth Issues

First off, what a wonderful forum! The members here are doing something right because every useful search result for Phonak support lands me here.

I’m wearing a new set of M90s - love them - but I’m having issues with them in conjunction with the two Roger devices I have on trial. Whenever I pair the Select or the Pen with any Bluetooth device my hearing aids start repeatedly playing the ‘program change’ chime. It’s like the HAs connect to the Roger device, then disconnect, then connect, then disconnect, and they keep doing that until I delete whatever Bluetooth device I just paired with the Select or Pen.

As this happens with both Roger devices I’m starting to think that the problem may lay with the hearing aids.

Anyone run across this previously?

I may be wayoff, but I don’t think you pair Roger devices to other devices. They don’t use Bluetooth, but some other proprietary method. Again, I may be missing something.

1 Like

Yes Alvin, I have had similar problems with the Roger Pen and the M90’ 13’s I thought it was at the time that my Roger Pen was a “duffer” as I bought it second hand and I thought it had malfunctioned! Now I am thinking after your post it may be something to do with the duel pairing? Perhaps you have to unpair all other pairings i’e phone and computer or whatever, in order for Roger Pen or Select to function properly… Just a guess though. Cheers Kev

Pair the Bluetooth device to the hearing aid, not the pen. RogerDirect doesn’t let you use Bluetooth on Roger pens. All other features of the pen works. Notably, Roger iN devices (the latest ones) don’t have Bluetooth in them.


Thank you for your reply, @MDB. You’re right! Roger does use a proprietary connection protocol between the device and the HAs. The devices I have have Bluetooth too for connecting to to stuff outside the Roger playground.

@Kev thank you for the idea. I’ve factory reset both the Pen and the Select a number of times - evidently that clears all of the paired devices from memory. Unfortunately no luck.

@focusandearnit - that makes sense as the problem I’m having appears to be systemic. Interestingly, both trial Roger devices I have include BT. The problem with using the M90 BT is its reliability. My HAs fail to connect consistently with my PC. Thus Teams, Skype, and my softphone will work upon initial pairing, but quickly lose connection. I’ve tried both BT 4.0 and 5.0.

1 Like

On the 1.1 pen there is a BT reset that is different from the 4 button reset. I believe that you just hold down the BT button for 10 seconds to clear all BT pairings.

1 Like

I have a pen with a focus receiver. To uncomnect all Bluetooth u need to make sure pen is on, the. Hold phone disconnecte for 10 sec and it will stop flashing intermittent blue. I dont know about the beeps

1 Like

Sorry, but what you’re looking to do is not possible. The only way for Bluetooth to work is to use the Bluetooth in the aid and not the pens.


I have talked to Phonak extensively about this VERY thing. My rationale had been that since Roger is proprietary FM and Bluetooth is a different animal. I could hook the Marvel hearing aids to a Roger device via the Roger FM and then the Bluetooth device could hook to the Roger device. I believe this WOULD work on non-Marvel hearing aids. Have you noticed that no new Roger skus support Bluetooth?

What I got when I tried was exactly the same…an endless loop of program change tones. Phonak could not give me the why of it.

I had Marvel M90s as well. See my other post about going back to Quattro. I do not wish to repeat myself.

1 Like

One thought though it’s too late for you would be to use Roger via telecoil (Roger MyLink). That probably would have worked for you since it takes RogerDirect out of the equation, allowing you to use the Bluetooth device you need for work (if memory serves). Before RogerDirect was enabled I used my Marvels with Roger devices via telecoil and it worked well, including Bluetooth via Roger. Alas, enjoy the Quattros.

1 Like

Thank you everyone for your feedback.

@efigalaxie, I read your thread - it’s like you live in my head. The M90s are my third set of Phonaks, and I was really hoping to be able to stop using speaker-phones and start enjoying private conversations again. Alas, it sounds like it’s not to be, at least not with the M90s.

I did crawl around the web last night looking for information about Roger SKUs, and you’re correct, the newest stuff has all dropped Bluetooth. ***note to Phonak - could your web resources BE more obtuse? For me the dream scenario was a portable BT 4.2 dongle paired & connected reliably with my hearing aids which would allow me to move seamlessly from PC to PC. #notsomuch

@focusandearnit - I’m going to try and gumby a solution with multiple TV connectors. I’m still bought into the Roger devices, they really work well as microphones, but they’re certainly not a connectivity solution.

@Psych1 and @Nikita, thank you so much for sharing your knowledge. I really appreciate people taking time out of their day to help a stranger!

I am curious about this statement. You do know you can have private telephone conversations using Bluetooth with the Audeo M aids?
That’s one of the wonderful things I see with the new Phonak aids.

1 Like

Thank you @ Raudrive, that feature is one of the reasons I moved to upgrade when I did.

However, in my experience so far there’s a significant gap between the promise and the delivery. To wit:

The promise: You can pair to your PC using Bluetooth, and use your hearing aids as a wireless headset for telephony.

The delivery: PC is successfully paired & connected. Had a great Teams meeting. 10 minutes later the hearing aids, while still showing as paired and connected, no longer work with Teams, Skype, or my softphone unless I remove and re-pair the hearing aids in Windows BT. Tried multiple BT cards and drivers, all have the same behavior.

Thus, the Bluetooth connection is not reliable enough to use at work.

I like these hearing aids. A lot. But for Phonak to market them as a tool suitable for reliable Bluetooth telephony is disengenuous.

I had never, not one time, had BT drop off with my M90s, and I use it a lot. You are doing something wrong.

I’m willing to concede that, @Psych1, but I can’t for the life of me think of what that may be. The process is of pairing is dead simple. The process of setting the HAs as the default device is dead simple.

Now, on the other hand, I’ve been told that I am dead simple … :smiley:

Out of curiosity, which devices are you connected to through your M90s?

Is your phone paired to the computer?

No, it isn’t.

Now I type stuff to fill up the 20 character requirement. LOL

1 Like

What devices do you have paired to your aids? Not connected, paired.

Currently just my PC, although there is some pairing associated with the MyPhonak app on my Android phone…

Your phone should be paired to your aids.
Try this for a while, take the my Phonak app off your phone. Try this for a few days and see what happens.