Phonak introduces Marvel platform and Audéo M hearing aids

phonak

#568

Just edited my post


#569

When you turn Bluetooth off on device A, and turn Bluetooth on on device B, you may have to select the hearing aid to connect to. In other words, on device B, turn on Bluetooth and select the device (hearing aid) to connect to.


#570

I will try to find the thread where this was confirmed. It is about the Marvel. There was a misunderstanding within Phonak.


#571

I’ve tried, but I JuST tried again. It doesn’t work for me. Here is the error message. BT off the other device and on this one. I got the error message when I tapped on R-Phonak. It searched for a while. My HA are on and right here.


#572

That would be awesome.


#573

On my Apples XS, XR, Ipad Pro 11" need to forget in the remote app then forget in the OS bluetooth. Next cycle HA’s off/on then bluetooth off and on in the phone! Start the discover process Right HA at OS then remote app (sometimes need to on/off the HA’s for app to pair).

now have three phones at over 3k just try to get direct streaming. All need some update/firmware to HELP the bluetooth paring/timing to get connection/paired. HA’s also.

Sending back the Resound Quantros as Jan update for android did not enable streaming.
See that they will have a Feb update (CES) that will add AI and maybe deliver streaming?

Hoping Phonak, Apple, Google provide updates !!!


#574

That looks like maybe they are still connected to the other device? What do you have to do to turn Bluetooth off on the unwanted device?

Here is one response to another thread. This person was turning off and on the hearing aid and that may be the easiest way to get them to connect. I think he still had to turn on/off Bluetooth on the devices to make sure the correct one was on.


#575

I go to settings and turn off BT or turn it to airplane mode. I also turned off my watch BT.

It does work by forgetting device and repairing. If the problem were another devices BT, why would that work?

Plus, I called Phonak BT helpline and she confirmed it is what I have to do… every time.

A couple people in this thread has said they don’t have to go through this rigmarole. But most of us do …


#576

I believe this user is indeed repairing each time because they said hey power off the HA


#577

My new normal now is turn off bluetooth on all and ON only for device using the remote app.

If you don’t need the remote app. HA’s work for phone call and TV streaming with out remote app…


#578

He’s not forgetting the device each time so it doesn’t appear he is pairing.


#579

So, can you switch streaming from one device to the other by just turning off BT for others and then on the desired device’s BT?


#580

Same guy, later clarification. Turning the hearing aids off and on (really just the control hearing aid) might be the quickest way but you should be able to select that device for connection.

If you pair device A, then turn Bluetooth off. Then pair device B, then turn Bluetooth off on device B, and then look at Bluetooth devices on device A, is the hearing aid on the list? What happens when you click it to connect (or however you connect)?


#581

I left out the step of turning Bluetooth back on, on device A when you go back to it, before you look at the list of devices on A.


#582

Neville confirmed that on Android he has multiple devices paired and switches between them but Android Bluetooth is obviously much easier to deal with.

Also, here is the guy confirming with Phonak.


#583

Ok so I already told you what happens above. But I just did all you said back to my other device. Yes it shows up and if I click on it I get the error.

Many of us have the same problem. Maybe I will call Phonak again…


#584

I just called the Bluetooth line. She said the many Apple users do indeed have to forget the device and repair. She said there have been a few reports of users who can just switch off and on the BT, depending on their devices. When I asked which devices are working for it, she replied that they don’t have consistent results.

Apparently the iphone10 is working for that, however we are hearing that phone calls aren’t working as the microphone stops working.

ETA: correction iphoneXS is having the phone call microphone issue.


#585

Try this.
Turn off both Marvels.
Go to the Phonak Remote app.
Click on the gear in the upper right of the screen.
Select “My Hearing Aids”
Select “My Devices”
Click on “Forget devices”
Once they have been “forgotten”, stay in the app.
Restart each HA
Then click on “select” when both HA’s are showing.
You now have a clean connection from your phone to the HA’s.
It appears that the Marvels do not do well when trying to restart the BT connection from iOS. Not sure why but with a clean connect, you may have better connectivity with other devices hence. I think that by going through iOS there may be some settings in the HA’s that either aren’t set or are not in sync. Not sure. But give it a try.


#586

The iPhone X works brilliantly in calls. I can’t say the same for the XS or XS Max as the mics drop out or even fail to come up when the call commences. This is the issue I’m pulling my hair out over. It is definitely an Apple issue.


#587

I have installed iOS 12.1.3 beta 3 (the latest beta) and the problem got worse on my XS. Now the mics do not engage at all when the call starts. Being that this is beta, the only recourse I have is to report it to the Apple iOS Beta team which I have done. I’m hoping they’re working on it.