Phonak introduces Marvel platform and Audéo M hearing aids

phonak

#548

Only 21 more days in my trial…doesn’t look like i will be keeping the marvels​:frowning::frowning:


#549

iOS 12.1.3 beta is out now…


#550

:pray:t2::pray:t2::pray:t2:
I am very hopeful


#551

I’m sorry to report that iOS 12.1.3 beta 3 has injected an even worse scenario in this issue. Under the previous versions the phone call would commence however, 20 seconds into the call the mics on the ha’s would cut off. Now with beta 3 the call commences however the mics are gone at the beginning of the call.
We continue to wait for a fix that works.


#552

Got a Amazon Paper White Kindle for Christmas with Audible trial.
Have paired / connected the Marvels and am listening to a book !
don’t need the bluetooth headset now :slight_smile:

Have not tried the Apple watch 4 (only GPS) for phone call’s, Iphone XR works great, just tap the HA and answer the phone talking thru the HA’s as phone is in my pocket.


#553

On my ASUS laptop BT 4.0 did not see HA’s
my wife’s HP Spectre x360 Convertible 13-ae0xx a first did not sse HA’s.
Then checked and updated BT driver = now WORK’s


#554

I’m wondering why it takes so long to switch? Maybe I can help.

You must turn off Bluetooth (go into airplane mode from swipe down or go to settings and toggle off Bluetooth, or power down device… do not just swipe and click on Bluetooth button, that doesn’t turn off BT Bluetooth connection)) of the one currently connected.

Now go to what you want to pair. Go to Bluetooth and forget device. Now turn off and on your Right HA (assuming that is the one that connects to device). Now choose it when it shows up.

Yes it is a hassle, but as long as I have both devices in hand, this takes less than 5min.

Now trying to get the remote App re-connected has been challenging for me.


#555

I don’t have to forget my aids to chase the device that I am connected to. All I have to do is momentarily disable the Bluetooth on the device I want to disconnect from. It works all the time for me.


#556

The amount of wear and tear on the right HA will be an awful lot if you have to open and close the battery door all the time.


#557

Are your switching between Apple devices if so, which devices are you using?

I definitely MUST forget the device and have it find the device again


#558

Yeah it is pretty ridiculous. Just wanted to help the person speed up the process.

Mine are rechargeable, so I have to hold down the bottom button for 4 seconds. Then hold it for 2 seconds to turn on again. It isn’t super easy to do, and is rather unpleasant. I really find myself staying connected to my iPhone most of the time.


#559

Or I can reset by plugging it into the charger. But then I would need to be near it.

I try to think about whether I want to switch devices when I take them out of the charger. Then I have 2-3 minutes in pairing mode.

Definitely a nuisance compared to my PhonakV90 with Compilot. But there was the nuisance of having a charged Compilot to clip on. And only 2 hr battery life.

I’m having no issue with battery life and streaming for hours each day with my new rechargeables


#560

Yes I have the iPhone 7plus, and IPad Air 2. I switch back and forth multiple times in a day’s time. I do also have the connect clip that I have paired to my MacBook and my Apple Watch.


#561

I think others have said you can stop and start connections. It is not necessary to unpair and repair. To pair to a second device you would have to turn off Bluetooth on the first device, first.

Then when two devices are paired you can connect to whichever one you want by stopping Bluetooth on one device first, then starting Bluetooth on the preferred device.

I don’t have these so I can’t verify.


#562

So you don’t have to put the hearing aids in pairing mode either? I definitely do! I called Phonak BLuetooth helpline and they confirmed it was necessary.

Mine are iPad Air 2 and iPhone 6splus.

My husband and son just got iPhone 8. I will have to test them.

Incidentally my iPad Air drops the Bluetooth frequently, but my phone never does.


#563

You would think that is how it works, but it does not. Not for me with my devices. I am stubborn, so trust me I have tried. Others also have reported the same, and Phonak confirmed over the phone.

I can only hope that they will put out firmware that will improve the situation


#564

I haven’t had much of an issue with either the iPhone or iPad. And I would find that the re-pairing would be a huge downer for me.
My Oticon OPN1s are paired to a TV connect, a connect clip, my iPhone and my iPad. I do not power on the connect clip until I need to use it with my MacBook or my Apple Watch. Moof the time they are connected to my iPhone, but there are times I do watch Netflix on my iPad so I will momentarily disable the Bluetooth on my iPhone so my aids connect to the iPad. Then when I am finished on my iPad then I momentarily disable the Bluetooth on my iPad


#565

Do you have Marvels?

I did not have this repairing issue with my Phonak V90 and Compilot air (which sounds like your connect clip).

The issue surrounds direct BT right to the HA


#566

I would try it. Apparently there was some miscommunication on their system. Others here have confirmed that they can stay paired and Bluetooth can be turned off and on to control the connections.


#567

I have. I just did. It didn’t work.

Who are these others that confirmed it? On this thread?

Again, that is all I needed to do with my V90s streaming through the Compilot air. I am familiar with how to do that and even tried again after hearing cvkemp say that they didn’t have to repair. But now it sounds like they are using Oticon with clip…