Phonak App & Smart Watches

Hi Folks,
I’ve been controlling my hearing aid’s using the “Phonak App” on my phone, but as my phone is quite big it can literally be a pain in the backside carrying it around all day. So what I decided to do is purchase a full android smart watch but for some reason I can only get the right aid to show up in the Bluetooth pairing and nothing at all shows up in the app it’s self. I just wondered if anyone has had the same problem and if so, did you get it sorted out and up and running OK.


Delete the pairings from the watch. Turn off the Bluetooth on your phone. Then reboot the aids and try to pair with your watch. Should work as expected after that. Assuming the BT implementation on the watch is standard.

Thanks for the info, I’ll give it a try.


No luck I’m afraid, still the same.


(1) What watch are you using?
(2) Are the hearing aids still paired correctly to each other (do they still adjust volume together, do they still connect to your phone normally)?

Hi and thanks for your help,
The watch is a KOSPET Prime 4G/LTE Smartwatch, the aids are still paired together and yes they still connect to my phone ok, the only thing I would say is the right aid is programmed to be slightly louder than the left but they are still paired together.


Have you tried taking the Phonak app off your phone then try the smart watch?
My Phonak aids always show the R aid only in whatever device is connected with Bluetooth. The default setting in the Phonak programming is set to the right aid. This can be changed if needed but only one aid will show connected in your Bluetooth devices.

Is the bluetooth in your smart watch BLE? I think the app uses BLE when controlling the aids. My older LG phone would connect with the aids a couple of times, but then fail after that. I tried a newer phone with a newer bluetooth implementation, and it seemed to work OK. I found the app to be worthless for me, and deleted it. I understand a lot of people do use and like it though. As they say, YMMV.

Thanks for your help, just tried what you recommended and still the same unfortunately.
I did notice on my galaxy A10s phone that the Bluetooth was showing both left and right aid.
I don’t really understand what the phone has to do with it, as the watch is a full android watch and as such I would have thought it would be a “stand-alone” as it has the phonak app on it.


The manufacturer website doesn’t give any Bluetooth specs, that I could find, but the chipset used in the watch does in fact support BTLE. Interestingly, it’s actually a phone in a watch form factor, not a smartwatch per se. It’s running an entry level phone chipset and a full version of Android 7.1.1.

Hi John, thanks for your input, I’m sorry I don’t really know what BLE is and how I would find out if it was or not.


Yes phobos512, That’s why I thought it was a stand-alone and didn’t need the phone.

When you unloaded the Phonak app from your phone, was the Bluetooth still on?
Get the phone totally out of the picture. Let the watch do everything to prove the watch.

That’s what I have been doing, I haven’t been using the phone, that’s why I purposely purchased this particular watch so I could do away with the phone altogether.


The Phonak M90 RT aids I have easily paired with my old Samsung S3 phone and now easily pair with my Samsung S9 phone.
These aids also easily pair with a pretty new iPad.
These aids are very flexible about connecting to Bluetooth devices.
Usually the problem is too many devices trying to connect.

Have you loaded the Phonak app on your watch?

Yes, about four times I think, I know sometimes I had problems with the app on my phone and found deleting the app and then reinstalling seemed to clear the problem but doing this on the watch makes no difference.


Just a thought. Try a different watch. Look at Amazon, Colmi is about $40USD. Nice watch. Good luck.


I also had the idea to buy full android watches, such as the Kospet Prime, Lemfo LEM12, etc. And I have already attempted to find out more on this forum.
The Bluetooth these watches mostly use (currently with the recent watches) seems to be a MT6739 bluetooth chipset (MT6739).
The specs according to the MTK website: Bluetooth Version: 4.2 (Low Energy).

I wonder whether 4.2 woul be ok, since Phonak temselves claim 4.2 is ok. But maybe it is also dependent on the Operating System on the watch?

I hope it will work

1 Like

Hi gsl,
Thanks for the info, I am not going to give up and I’m going to keep trying, there might be a firmware update out one day that will fix the problem. If I fix the problem before then, I’ll post it on the forum.
Thanks to everyone who chipped in with advice.
Here’s hoping.

Kev :slight_smile:

1 Like