myPhonak App Navigation Not Working

iPhone X (iOS 13.0)/Marvel 90’s

When I select the Navigation in the upper right corner of the myPhonak app 3.0, the screen greys and nothing comes up. The navigation list appears momentarily from the right sometimes and the grey area shows stripes or other movement. This all started after my audi did a firmware update.

After uninstalling and reinstalling the app several times, the problem persists.

I am unable to access the features.

Any help or suggestions is appreciated.



1 Like

Perhaps go back to iOS 12.4.1?

Thanks for the reply.

I may have to do that (if it’s possible).

I think as long as you had iOS 12 on it before, you can go back. If you had iOS 13 from day one, like on an iPhone 11 you might be stuck on 13. Here is a link on how to roll back the iOS providing you have had the older one installed before.

Ok. I am looking into that now. For some reason, my iPhone is not showing up in iTunes. I understand that downgrading to iOS 12 means the phone will be completely wiped. So I need to verify I have a good backup.

Your attention to my issue is appreciated.

Thank you.

It is worthwhile to check into it closely. I got blindsided by iTunes once, and now am much more careful with it.

Well after many futile attempts to get the navigation to work, I have gone back to the Phonak Remote app. Everything works as expected.

Has anyone else here experienced a failure to get the Navigation to work with the myPhonak app on an iPhone X with iOS 13.0? I was not able to downgrade to iOS 12.xx.

Thanks Sierra for trying to help…

1 Like

Version 13.1 may help. It is supposed to be available tomorrow morning pacific standard time – 9:00AM?

I have sent a message to Phonak customer support, asking them whether my problem is a known issue. I will update my phone with 13.1 and try myPhonak app again. Maybe it will work correctly with 13.1. In not, then back to the Phonak Remote app until either Phonak or Apple figure out what’s happening.

As far as I can tell, iOS 13.1 won’t fix that issue. I have been using 13.1 public beta for a while, and the screen does exactly what you report when I try and use the navigation drop-down menu in the top-right of the app. It’s not a major issue for me, as the other aspects seem to work very well (Bluetooth connection and switching between devices etc).

It may be, of course, that today’s 13.1 release also updates the current public beta, in which case there may be a fix. My guess is though, that the Phonak guys will need to update the app.

I’m running iOS 13 and experience these issues, however until Phonak updates their app- I was able to just tap the navigation items on the side in the small area that is shown, and I was able to get to what I need to make due. I couldn’t see what I was tapping, but I just went down the list until I got what I needed. A workaround for now. The myPhonak app is too good to let this stop me from using it with my Marvels.

Edit: wanted to note that the bulk of the app’s functionality isn’t accessed through that particular navigation menu, so it hasn’t been an inconvenience for me.

Seeing the same problem here. Marvel 90’s with myPhonak app, the navigation panel just greys out and you can see the navigation panel to the right, but when you try to drag it onscreen it disappears.

iOS 13.1 here.

The old Phonak Remote app does seem to work ok.

Same problem here, using iOS 13.1.1. I emailed Phonak, waiting for a reply.

Don´t know, if you have the same problem as me:

I use an android 9.0 phone with myPhonak.
Before i used Phonak Remote, an all worked as expected.
With myPhonak i never could activate the first of 3 manual programs of my M70 13T. I have not activated autosense, cause i wish to change by my feeling and not by automatic.

For testing I have now -activated- autosense in target and set it as start program.
As expected, myPhonak works now:
All programs can be activated and edited, but only if autosense is -not-

I mailed this ascertainment to sonova apps. Maybe they will correct this problem with one of next app-versions.


You have two wild cards in play at the same time: i.e., new firmware for your Audi AND the update to iOS 13.0 on your iPhone. You have, I assume, Car Play on the Audi?
So, you don’t really know which of these is responsible for your current problem.
Just as I use this site for my HA problems, I use anothe site for my car problems. I go to the Subaru Forester site…

…and search for solutions to things like the problem you posted here.
I suggest you google around for Audi sites, and NOT the official Audi site as they will post nothing negative about Audis whereas a site not associated with Audi will have lots of complaints, negative comments, and problems like the one you have posted.
So, try and figure out what is the source of your problem: the Audi ugrade of iOS 13.0. (BTW try to d/l iOS 13.1; who knows, that may fix the problem.

I think he means ‘audiologist’, not the car, Audi. And he means navigation around the app itself; i.e. the drop-down menu in the top right hand corner!

Ah, so. My bad. I should have caught the lower case “a” in audi. Plus his use of the word Navigation in the Subject line had me thinking about GPS, etc.
Also, when I go to the Apps Store on my iPhone I see two different apps: Phonak Remote (which I have installed on my iPhone XS Max; plus I see there are two different versions at the App Store) and My Phonak of which there is only one version.
Which does he have I wonder?

I think it’s the ‘My Phonak’ app. It essentially replaces the Remote app after the Marvel 2.0 firmware update, and allows user-adjustments of things like tone control, noise reduction, and the ability to create your own manual programmes. The drop down menu he refers to gives access to things like ‘My Hearing Aids’, where you can rename or delete these programmes, and create an account where you can have remote sessions with your audi. There are others, but I can’t remember them, as the menu doesn’t work now! :joy:

I think all this needs is an app update from Phonak. They are aware of the problem.

Today I downloaded the My which looks exactly like the with one exception: on one of the screens, at the bottom/right, there is the symbol with three vertical lines indicating sliders. Supposed to lead to more settings but with my Phonaks, nothing happens when I tap on them and so I went back to the, which is the one my audi had me load on my iPhone when I purchased my Marvels in Jan. this year.

myPhonak 3.0.1 has been released and the navigation menu now works on iOS 13!