It's a call to Costco's in the morning buzzing noise is back

#1

As a few know I’ve mentioned about a odd buzz noise that kept happening on the left hearing aid with my now nearly 2 week old phonak brio 3 it’s now perminant as of four hours ago despite trying a different battery brand and wax guard change I’ve tried my usual methods with no fix i.e removing battery and leaving it off for 5-10 minutes. Always seems to flare up when I’m sat just watching a TV show for the night. I’ve stopped wearing it for the night and recorded the noise on my phone so I can play it to my fitter.
I also got my husband to listen tonight by placing the receiver next to the mic and turning the volume up he even went what is heck is that buzzing noise? I doubled checked it wasn’t my phone by making a call just in case it was a T-coil setting might’ve suddenly kicked in that I didn’t know about and couldn’t even hear the other person. I’m calling Costco’s first thing it’s definitely not normal and I shouldn’t have to resort to leaving the aid out and off in the hopes the buzz will stop daily So as of right now I’m back to square one I’m stuck with one hearing aid again. Talk about annoying my right hearing aid works perfectly with absalutely no wierd random buzz issues. :expressionless:

0 Likes

#2

Sounds like that aid is failing/defective and needs replacement. Bummer. Will take about a week to repair. I’d just drop it off without an appointment as they should be happy with that and get it sent in. That worked for me and got the replacement in about a week.

0 Likes

#3

Great testing and documentation! Hopefully it’s a bad receiver and they’ll be able to switch it out. Otherwise I’m guessing it’s back to Phonak.

0 Likes

#4

Possibly they will give you a brand new set of aids and disregard the ones you have.

0 Likes

#5

@KenP big bummer because I love these hearing aids by on the above issue, I called my Costco’s this morning about the problem the receptionist has fitted me in tuesday at 7pm even she went ohh you’ve only had them 2 weeks that’s not right.

@MDB Thank you I posted what I did just in case anyone could see an area I may have missed. I checked again it’s been 24 hours nearly and still isnt working Tuesday can’t come fast enough don’t realise how quick I was adapting I feel a bit oargh being back to one aid.

0 Likes

#6

Hi. I have a slight buzzing sound in one my really old Oticon Deltas. I’ve checked everything. I’m beginning to think it is the receiver going bad. How can I tell? Thanks.

0 Likes

#7

I think the only way to know for sure is to switch it out for another one and see if that fixes the problem.

0 Likes