How can I stop phone calls from interrupting my streaming audio?

I know I must be one of the few (maybe only one) who doesn’t take calls in my hearing aids. For the most part I have “R-Phonak hearing aid” disconnected in BT. Calls do not come through my hearing aids.

However I do stream radio and music into my hearing aids and connect “R-Phonak hearing aid” manually when I want to stream. Is there a way I can stop phone calls coming through my hearing aids when I’m streaming radio or music?

iPhone XR and Phonak P90/312

My two thoughts are 1)Use a device besides your phone for streaming music or 2)Have all your calls go to voicemail when streaming music.

When you stream into your hearing aids disable the phone aspect. It should be in the app. If not use the phone settings to disable phone calls. The advice @mdb gave is very good too. Good luck.

2 Likes

Thanks for your replies. However I enjoy streaming radio via my iPhone and I don’t want to have to remember to re-enable phone calls or cancel voicemail. I don’t want phone calls via my hearing aids, unless on the rare occasion I choose to.

I’m trying to figure out why you let everything else come into your aids but phone calls

I am very happy taking calls using the phone speaker and mic.

Don’t mean to be flippant but I think you are in the situation of wanting a product to work differently than designed. I’ve been there too, but it didn’t change anything. Good luck.

4 Likes

Do you do this in public? I always try and keep my phone calls as private as possible when out and about.

1 Like

I don’t think there is a way in Target to enable BT music streaming and disable BT phone call streaming. They are one and the same.

With an iPhone and an MFi hearing aids you can set calls to never come through the aids, and media to automatically or always come through the aids, using Settings, Accessibility, Hearing Devices, Audio Routing.

3 Likes

That would have been too easy. Phonak P90 are not MFi hearing aids. I think they are native BT.

Well I like the fact that I can take phone calls hands free and can be steamed into both ears. Don’t know why I would want everyone to know I’m on the phone. Certainly don’t want to be seen using the phone while driving. I have to wear the hearing aids anyway so why not use the feature that comes with them that makes my life easier. My wife sometimes wears ear pods so she can stream and take phone calls inconspicuously. Now I can do that. Now I’m a real boy

2 Likes

If you turn on airplane mode, phonecalls won’t come through. Of course you’ll need to turn it back on when you’re done streaming music, but that’s simpler than re-enabling the bluetooth connections.

But if you are streaming music from the cloud turning on airplane mode will stop that. I regularly stream music from my Apple Music account that isn’t downloaded to the phone, and need to maintain an internet connection to stream the music.

1 Like

I agree totally. I cannot see a way of changing it.

“I know I must be one of the few (maybe only one) who doesn’t take calls in my hearing aids.”

I don’t. I also don’t stream, anything. Never have. Not in my hearing aids, not on my laptop. I am very tech challenged. I do not own a cell phone. I have never used blue tooth. You aren’t the only one who doesn’t take calls in the HAs. I have no clue how to even begin, with that sort of thing.

I don’t know if you could have it not go to the HA only when streaming however in the settings you can have the calls never automatically routed to the HA. Under accessibility, hearing aids then audio routing.

1 Like

I described that earlier, but Phonak aids aren’t Made for iPhone, and don’t support that feature.

1 Like

edit…never mind…I see you’re iphone… Sorry I’ve got nothing…

I’ll leave my original post as a refence to others that might find the thread
with android
go to settings
bluetooth
then scroll down looking for R-Phonak hearing aid (or whatever it’s named). It’ll have a little headphone icon beside it.
Click the gear beside it.
you should then see toggles to turn off/on phone calls, media audio, contact sharing… and perhaps other things depending on what you have installed… turn off the toggle for “phone calls”

1 Like

Darn, sorry missed that…