Anyone having issues with Apple MFi Hearing Aids?


#1

Just curious if anyone else is having issues with their Made for iPhone hearing aids since the upgrade to iOS 11.1? My Linx 3D hearing aids have been working flawlessly with my iPhone 7 Plus since I purchased these hearing aids a few months back. Last week I installed the iOS 11.1 security update before leaving on a business trip to Europe on Sunday night. When I landed at the airport in Amsterdam, the hearing aids wouldn’t connect to my iPhone. I figured the hearing aid batteries were low so I replaced them while I was waiting for my flight to Manchester. After restarting, the right hearing aid would connect but not the left one. Opening and closing the battery door multiple times generally resulted in one hearing aid connecting but not the other. Sometimes, neither hearing aid would connect. When I arrived in the UK (and for the 3 days that I was there) this problem persisted. Sometimes the hearing aids would connect just fine. Other times, one or none would connect. I tried quite a few things including forgetting and repairing the connection between the iPhone and the hearing aids multiple times. Nothing helped. At times, It almost felt like there was Bluetooth interference everywhere and the hearing aids were struggling to get a signal lock.

Last night I arrived back in Toronto and it seemed better. I noted that Apple had pushed out the iOS 11.1.1 update. I installed that and everything seems back to normal.

Anyone else? I think this is an Apple iOS issue but not sure.

Jordan


Manufacturer representatives
#2

No issues here with my ReSound Forte aids, which are the Costco version. I’m on 11.1.1 as of yesterday, and moved from an iPhone 8 Plus to an X.


#3

Most likely your iPhone just needed to be rebooted and the software update accomplished that for you.

If it happens again, do a hard reboot on your phone first.


#4

Yes, I am having issues with my Widex, and iOS 11.x. In the last three weeks I have both gotten a new iPhone and a new HA, but neither changed the issue. After much agitating, a Widex rep told me they were working with Apple, and to expect a software update this month that would address issues.

My issues:

  1. Initial difficulty in pairing
  2. Volume starting low then jumping up to what it should be
  3. Not remembering streaming volume setting between uses
  4. Rebooting HA after about 15 mins of streaming
  5. Delay in receiving initial incoming call ring tone.

#5

Yep. Your list of items is exactly what I am experiencing but I have a different brand of MFi hearing aids (Linx 3D). Apple announced that the iOS 11.1 update included a security patch to protect against the huge “Krack” wifi vulnerability that was announced mid-October. I’m wondering if they broke someone else in the process (i.e. the low power MFi protocol). If anyone else hears something, please let us know.

Jordan


#6

Sometimes i get that same problem with left hearing aid not connecting or vice versa, try simply turning Bluetooth off then back on again, sometimes it’s just simple things like this to get it working again.


#7

No problem for me with iPhone 7 Plus iOS 11.1 with either the OPN 1 or the Sonic Enchant 100.


#8

Like anything with software and interoperability, it can be hit or miss. Lot of variables involved.


#9

Yeah, I agree. I’m beginning to think that beside these common variables that we all have, perhaps the folks who still experience problems may have some kind of strong interference signals in their areas that’s playing havoc on their streaming, where there’s less interference for the lucky folks like us who don’t experience the problem anymore.


#10

I have the same issues at home, work, in the car traveling, and 400 miles away. I can eliminate that variable from my particular situation.


#11

Yeah, I think in your particular situation, the issue is probably that the Widex firmware has not been improved to be stable yet. I’ve read in the Signia Pure thread of people complaining about streaming connection issues with their iPhone, too. Perhaps their firmware is not stable in this regard either.

The OPN use to have these issues in firmware 2.0 and they weren’t resolved until firmware 4.0 was available (there was no FW 3.0). So hopefully at some point in the future, the remaining mfgs who still have these issues will get around to fixing them in a new firmware version.


#12

Yes, I have Oticon Nera 2 Pro HAs & they’ve been dropping the Bluetooth connection ever since I “upgraded” my iPhone 6S to v11.


#13

I have Resound and have problems with MFi - mostly one side drop outs during phone calls. I tried quitting the Resound app and restarting it and that seems to help. I just got the latest iPhone UG for my 7. and it has worked a few times, but I haven’t had a chance to use it much. 11.0 was the pits…

Oddly, playing music from the iPhone is OK- I think Apple has a bug in the audio routing for phone calls software, because of the way the phone switches to speaker then back to BT when the phone audio starts.


#14

Hi,
I have experienced most of the above issues with my Signia Pure 13BT for awhile now. I have had other issues with these HAs. I am going to be trying out OPNs. Looking forward to something more reliable. I didn’t know about iOS 11.1.1. I will update to that one on my iPhone 7. Maybe that will help with BT. I consistently get disconnected and going from say streaming music to phone call isn’t seamless. BT disconnects for no particular reason. Frustrating.


#15

Yes, It doesn’t matter where I am. My Audi suggested in may be location, but no matter where I am it happens randomly.


#16

I have 11.1 on a 7+. Have been testing the Resound 3D and have just gone back to my Linx 2 (no noticeable difference in performance between them so not worth upgrading). I get occasional connections dropping, but nothing like as bad as you have. Uninstalling and reinstalling the aids from the phone can help.


#17

I’ve used the Resound Forte 8 13 with an iPhone 6+ and upgraded to the 8+, iOS 11.1.1, no problems
The MFI hearing aids app has been around for more than 5 years and is stable. The only change I can think of in iOS 11 is the Bluetooth standard.


#18

I have Costco’s older KS6 which is the original Linx. I’ve never had a real problem with phone connection other than having to once reinstall when it would only pair to one aid at a time. My phone is the older 5s. That too may be a factor. Resound didn’t seem to have any teething pain from the start and that’s continued through various iOS upgrades.


#19

I think I may have solved the problem. I have both my iPhone and my iPad setup to connect to my Linx 3D hearing aids. It occurred to me that every time the issue pops up, I am sitting near my iPad. I think what may be happening is that both devices are trying to compete for the connection at the same time and that is why one or both ears won’t connect. They are dropping off to connect to the iPad. I’ve unpaired The hearing aids with the iPad and turned off Bluetooth on the iPad too in order to test this theory. This also explains why some people don’t have the issue.

The other interesting datapoint is that the iPhone had the iOS 11.1.1 update and the iPad did not.

Stay tuned…

Jordan


#20

I’m having rampant issues with my Oticon OPN 1 with iOS 11. Started with 11.0 and still persists with 11.1.

My issue isn’t with connectivity but rather with clicking sounds while streaming audio (music or phone calls). Apple has confirmed the problem with me and say they are investigating with no eTa.

For those that are having issues do you have other Bluetooth devices simultaneously connected to your phone like an Apple Watch, Fitbit, etc? I have 2 other devices and from research I’ve done, people suspect it’s due to that.

I would strongly encourage everyone that has an issue to write to accessibility@apple.com.