Resound LINX and iPhone X


#1

My Linx HA have worked brilliantly with my iphone 6S, but the upgrade to X was problematic from the beginning. Resound said they really did not support the X yet, but they gave my audi a workaround that kinda works. Problems include LONG delay in the pick up on the audio of a phone call, especially one I receive. Also, one side or the other tends to not come on for some reason then suddenly “finds” the connection and pops on–or not.

Anyone else experiencing this? Beware before you upgrade. AND, what’s the solution? Wait for Resound to catch up? Or buy the latest Linx?


#2

Go back to the 6S; that’s what I would do.


#3

Are you sure it’s related to the iPhone X and not the version of iOS? Do you have thyou same version of iOS on your iPhone 6S?

Reason I’m asking is because iOS 11 brought lots of audio problems for MFi hearing aids like yours. I’m having tons of problems with my Oticon OPN 1. If you search elsewhere on the forums you’ll see others have same issues no matter what make and model hearing aids.

For example: Anyone having issues with Apple MFi Hearing Aids?


#4

I upgraded to the X in early November. No problems with Resound II aids. Perhaps a longer delay in picking up, but nothing else. I did get the firmware on the aids ipdated in October which might help.


#5

I guess that is comforting to know that I am not alone. No, the X is different with 11.1.2 currently running. I hope there will be enough pressure to help with the problem. I was told that the latest Linx are better supported, but my HA are fabulous and no need to change let alone take on that expense. I am trying to tell my callers to be patient with the delay. More annoying is having one ear off and one on without a remedy. I also got the firmware updated, which was necessary to get connected at all. If anyone has the latest Linx I’d love to know if they are a big improvement or not.


#6

I’ve talked to Apple and Resound about this - Resound suggests unpairing, deleting the aids and re- paring them, but this didn’t seem to help me with my 7 and the latest iOS / Enzo. I have tried turning siri off, and that helped a little bit. I also tried not using the Resound Smart app, but that didn’t seem to have much affect. I have not tried removing the Smart app yet, to see if that fixes it. It seems to me to be an iOS MFi communication problem. iOS will randomly lose communication with one or both of the aids, and you won’t know it until a call comes in. Then it panics and switches back and forth or loses all together. I tried manually switching to speaker mode when this happens, in an effort to get the MFi com to pair up, but iOS balks at that. I am back to running Smart all the time, and watching it to see if and when it loses communication. But Resound believes it is iOS, and, as you found out, the firmware update doesn’t fix it… Apple did something to the MFi software code in the iOS upgrade to 11.

Complain here: accessibility@apple.com


#7

Great information! Will write apple!


#8

Did you ever get a real from Apple about this? I have the same issue, and it is very disruptive. Visits to the Apple Genius Bar and to the audiology have not resolved this. Mine are ReSound LS962


#9

I got a polite thanks for writing…no help. My issue is that it takes a LONG time for everything to link up and I have to tell the caller or person I am calling to hold on a second due to a problem on my end. My family now knows, but some people hang up. Plus one side seems to connect faster than the other. I wonder if it is better with the latest model and the Apple X.


#10

One option would be to add/trial the PhoneClip+. This would give a stronger signal and be less likely to have problems. It would also allow hand free operation. The phone clip has proven itself to be quite reliable.

One recent message about the MFi problem was traced to a defective phone (BT antenna) at an Apple store. You might also want to pursue that.


#11

Sorry, I really don’t know what a phone clip is. I have a Linx, one of the earlier models.


#12

The phone clip is a device that uses BT rather than BTLE (Low Energy) and will work with any phone that has Bluetooth. It is a clip on device that is used to connect to the hearing aids but then uses the old style BT to connect to the phone. It a black item that is about 1.5x3". With a standard BT transmitter, it can also be connected to other devices like a TV.


#13

I think people who bought MFi HAs deserve for them to function without an intermediary device. Surely that would be going backwards and against the very reason most people bought the Linx.


#14

Agreed, having firmware upgrades that affect the performance of the device in a bad way should be an absolute no-no, but it seems that hobbling products is not entirely frowned upon by Apple (like the do to their older phone batteries).

Write/lobby/petition/blog etc, 'cause that’s the primary way you’ll get a bigger company to listen and live up to their obligations.


#15

Any closure on this? I am thinking to upgrade from my 6s to an 8, 8 plus or an X. I use ReSound 3D, with the Smart 3D app.
Thanks.


#16

It was my understanding that IOs 11.x had largely eliminated the performance issues, but I’m happy to be corrected. My issue is that I probably don’t see enough ‘Power Users’ to see sufficient combinations of iPhone and IOs/HA to get a feel for the problem.

Where we’ve had issues and for most Android users, especially those with hands free needs, the Phone Clip+ is still my preferred option.


#17

I tested the ReSound 3D with my iphone X for a month. The app is great and there were NO PHONE ISSUES. I also tested the Starkey Halo and it had better sound in general. So I am waiting for the new version to come out next month to decide between them. I had an older Linx that was having trouble with the iphone X.


#18

I have the ReSound CL861-DRW purchased at Costco & experienced the Bluetooth delay receiving calls around the time I purchased an Iphone X on Black Friday.
I found this forum, called ReSound support today & they had me do a Reset of Network Settings on my phone and now i can hear incoming calls as soon as answered without delay.
They said the issue was due to IOS 11 & the reset is the fix.