Problem with Android Easy Line Remote app for KS10

I got the new Costo Ks-10 aids a couple of days ago. They help the hearing in my left ear a great deal, especially when I’m watching TV by bluetooth connection. I also love being able to talk on the phone with it in my pocket and the conversation coming into both ears! And I also seem to be saying “huh” a lot less.

But all is not perfect. Aside from the relatively trivial matter that they make my ears itch, the major problem relates to the fact that the Android app “Easy Line Remote” doesn’t work. It will seem to connect via bluetooth to my HAs but then within a few seconds reports an “Internal error” with a red exclamation mark. “We are sorry, something unexpected has happened. Please restart your hearing aids, reset your bluetooth connection and try again.” Which, of course, I’ve done a half a dozen times by now. Another screen reads, “We detected that touch sounds and/or screen lock sounds are enabled in the device settings of your smartphone. We highly recommend to manually disable those sounds as they can interfere with the app usage.” Really??? I turned off the touch and screen lock sounds and there was no change in the apps behavior upon re-installation and reconnection via Bluetooth to the aids.

I hate to return the aids because of this problem (and because it’s another 2-hour drive each way), but I would like to be able to control the audio and engage the noise reduction features (for restaurants) via the phone app. The aids I tried briefly a few months ago had no problem with this. I reported the problem to Phonak, but they didn’t respond at all. I’m guessing that’s because I bought them from Costco under the Kirkland name.

I’ll also add that the fitter at Costo called someone for tech support when I was getting the HAs. He couldn’t make he app work either. His tech support person told him that the store’s IP folks needed to make some changes to the store’s settings. I now know that that was a bunch of hooey. I wanted the app to work so that I could connect remotely to the fitter for support, but I was there well beyond the appointment’s allotted time. I left tired of messing with it and annoyed and exasperated that it didn’t work. I remain annoyed and exasperated.

Note: I actually made a video of the whole process on my phone. Here’s a link to it:

Well if nothing else you remove the itching with a product called miracell. You can get it on amazon

You have checked all of this? . . .

Re your second issue (phone sounds), first page of User Guide has:

“Some phones have touch sounds or keypad tones, which could simulate a streaming to the hearing aid. Go to your phone settings, select sounds and make sure that all touch sounds and keypad tones are deactivated.”

On first issue, was Location Services activated while initially setting up the app? And was there the required connection to the internet when that was done, too? (Your Costco tech’s problem and the IT support response suggest this is possible.)

I don’t know if this will work for you, but try using the myPhonak app. It works well with the KS9s, don’t know why it wouldn’t also work with the KS10s, but perhaps I’m wrong. I use the Android version.

I don’t know the nuances between the two Phonak apps, but myPhonak provides a fair amount of functionality…


I turned off the sounds the warning label indicated should be turned off. What else I’m supposed to turn off, I don’t have a clue. See the video link I appended to my original posting.

Do you have ‘location’ switched on on your phone, which I believe is also necessary for the app?.

I have regular problems with the app and have found that putting the HA back in the charging box for a minute or so somehow makes it reconnect, although if I turn on and off using the buttons it doesn’t work. It is a mystery.

But are you sure that the initial app installation and pairing were done correctly (my last paragraph)?

Do not confuse your two issues. The unwanted sounds issue is entirely different to what appears to be a connectivity-related issue.

Edit: So I looked at the video, no more indications there. However, connectivity issues are not uncommon. From my read of the doc’m and your post re the Costco tech’s problems with the app, you should consult with your tech about the installation. If s/he wasn’t successful installing it, you won’t be successful using it. You can try the myPhonak alternative; if you do though, don’t be surprised if you encounter a conflict between it and what you have, or that its initial setup also has prerequisites.

Good luck.

Didn’t work for me using the Apple version, w/KS10’s.
Did pair them to an iPad just to see if they would since they stress phone. Next up, Macbook.

I’d try starting fresh. Uninstall app. Unpair hearing aids from phone. Redo process. I’m assuming when you tried other hearing aids that you used same phone? (making sure it’s not phone incompatibility) If none of that works, yeah, you need to schedule an appointment and return to Costco.

I went to pick up my new 10’s at Costco - they could not get my phone connected correctly. While I was there, they spend a lot of time and even called tech support. I do not know whether it was Phonak support are not. There was virtually no wait time to reach support. They ran into all sorts of trials and tests for about half an hour and nothing worked to complete the connection with the phone. So they had to send them back. Costco called couple weeks later and this time my new AIDS were set to go five minutes! They’ve been working fine ever since past seven weeks. I have no way of knowing whether these are the original AIDS or new ones.

If you’re curious if these are new aids or not, Costco could likely tell you. If you’re not curious, it doesn’t really matter.