[post deleted]

Also, FYI, my version that worked is v1.6.1;

1 Like

halo mr. and halo everyone
I have a Vista hearing aid. son of unitron and fitting program named VISTA

please share with me if you have VISTA fitting sofware.



@Blue, Many Thanks for this.
Welcome to the forum!!
Works like a charm.

1 Like

Hello and thanks for the Downloader. However I am getting a “module not found” after I click on a selection of HA software. What am I doing wrong? I put Python and the Universal files all in one folder.

1 Like

No don’t simply download Python. Install Python.

I extracted all files. Python IS installed. I ran it to test and it prompts with a command line. When I execute the “Start” batch file I get the proper menu. When I press for any of the menu selections it links to the Python screen and gives me the error message that you can only get if you are in Python which is “ModuleNotFound”. I have tried the Universal Hearing Aid Software Downloader on 2 different computers. I have Python Ver 3.11 on both. Anybody else could suggest a solution?


Yes what software are you after, check your PM.

Can you please post/DM me the full ModuleNotFound error please?

When I first installed and ran this software in Windows 10 (checking off “add python.exe to path”, using the latest Python version), it did not work. I got an error message 'python’ is not recognized as an internal or external command… Searching on that error message did not provide any useful answers - just “add python to path”, which had already been done - I checked that it had been successfully added.

But, when in doubt, reboot! or in my case, logoff and logon again. Why is this info not included anywhere, as obviously Windows does not use new environmental variables until you refresh them by at least a logoff/logon or reboot? This error message could really stump a less tech-savvy person than myself, so maybe you could address it in your instructions?


Thanks for that! Maybe we can get @Blue to add Reboot to the instructions.

1 Like

Thank you so much for putting this together. I’ve successfully downloaded the Widex Compass files.

I’ve got two problems:

  1. The setup is interrupted and fails after creating the Widex folder, creating the icon and putting in all the files.
  2. Looking at the log files, it also seems like files are associated to Compass 4.4, not Compass 5.

Any ideas?

Hang on, I will have a look.

I have Widex Moments. Maybe Compass 4.4 is the latest version for them? I had that installed and unfortunately uninstalled it thinking this version was better at v5. :pensive:

1 Like

Latest is 4.4, V5 is other Widex software not for the moment.

Reboot your PC and if still having problems you’ll need to re download the software.

Thank you for the information about v5.

Great community, everybody has always been fantastic.

Looks like a problem with Phonak servers, try downloading it again

It has been added to the instructions now

Thanks for your feedback!

hello, can you make the Signia Connexx 8.5 software or similar version available? I need to connect an older database, for a Signia Pure 7 px, it doesn’t have it in the Connexx 9.8 version that it has in its Software Downloader. I wait

Sadly, my software cannot currently download previous Signia versions. However, does 9.8 really not have the capability to impot older databases?

The specific-older-versions are more likely to be saved by individuals and shared using the community share procedure. Check your DM/PMs.