Phonak/unitron first green then solid red seems wire from circle board to battery is cut off?

today I tried to fix my unitron blu, it is said to almost same as phonak for some parts.
when on charge, it is first green then solid red.
on truefit ,it shows battery is full but it is dead immediately outside charge.
I want to replace battery folling threads on this forum.
after I opend it, i tested the battery voltage is about 2.5v , I believe this voltage should be able to be charged and should not cause solid red,
then i parallel a 18650 to the lir7854(the plastic cover for the 7854 now just opened a liitle, not all), and now the voltage is about 3.9v.this voltage is enough to power up the HA.
I tried to push the button to switch on the HA, but no luck.
So I guess maybe the battery is not connected to the circle board anymore, the reason the fitting software said fully charge is because there is no battery there?
maybe I dont have to go to next step.
before this I tried to reset the HA on software,no luck.

Anyone else has successful story about replacing the battery for first green then solid red phonk/untron HA?

OK,as said before , i connected the 18650 to the lir7854 directly.
So I charged it with the 18650 for three hours, now the lir7854’s voltage is 3.8v, it is proved to be in good condition.
But, still not possible to power on . and when I put it on charge , still first green and then solid green.
So I think what i guessed before is right , the wire from circle board to battery is cut off or the circle board has problem.

Yeah it’s a known problem these Sonova models, the battery can be DIY but for experienced only, it’s a bit of a hassle.
See here for how one member Didi it.

Hi tenkan,
thanks for your help but maybe i didn’t express well since english not very good.
The story is ,Yes I did want to replace the battery, but then I found out it is not battery problem, it should be the circle board or the wire from battery to the board is not connected.
I don’t know if all first green then solid red is the same, and would like to know if any one in this conditon successfuly recovery the HA by replacing battery.