Phonak TV Connector

Is this device only for Tv? I am trying to use on my laptop with analog(jack cable), but doesn’t working.

“The Phonak TV Connector supports two different audio cable inputs: Optical (Toslink) or Analog (3.5 mm jack) to connect to any audio source such as a TV, PC or HiFi system.”
I don’t know what I am doing wrong, I paired with the HA and no sound at all. Bluetooth is working fine.

It should work on pc or tv, check your volume settings of pc maybe or if phone has 3.5mm jack try from your phone

1 Like

I tried on my phone too, it is not working. When I am watching a video, the LED light is green, which means the audio is on, but still nothing sound from the device.

I had to set our TV up with PCM audio out setting, not Dolby digital.
This was found under menu, sound, digital audio out.
Your computer may need this too.

2 Likes

I’m using the Phonak TV connector with my Kirkland 9s and so far it is working very well. I initially set it up directly to my TV and successfully used both the optical link and the RCA-mini jacks. However, I had both assigned to other functions. I was able to plug it into the RCA-mini jack on my soundbar and it is working great. I use the TV’s USB for power, rather than the USB plug, so the wiring is all nicely hidden, and the device only comes on when the TV is on.

The only thing that I don’t like is that if my wife is watching a TV program, I get the sound streaming in my ears. I have to turn off the device if I don’t want the sound. I wish there was a way to ‘de-select it’ from my aids instead.

But, to answer the original question, I think you could use the TV connector with any sound source that has a mini-jack output.

1 Like

Some of this may sound trivial but this is how I debug:

Simon95, what kind of HA’s do you have. The Phonak TV Connector only works with Phonak Marvel and Audeo B series.

I don’t want to sound condescending, but are you sure you’re using the analog cable? Just leaving no stone unturned. Make sure it has silver or gold metal ends.

Next, I like the idea of testing with a phone. Do you have a headphone you can plug in to make sure you have audio coming out of the phone?

Do you have the volume on the phone turned up to a reasonable level? I like to use 75-80%.

Finally, do you have another 3.5mm audio cable that you can substitute, in case the connecting cable is bad?

Your audiologist should be able to confirm that the HA’s are set up properly.

Where did you get the TV Connector? If all else fails you should return it.

2 Likes

I was stupid, I didn’t know I have to turn on Tv program on myphonak app, and it’s working fine now. Sound is very good! Thanks all, for the your time!

3 Likes

What aids do you have?
Aids should be paired with the TV Connector I believe. No need for phone.

1 Like

You can try pressing the button on the TV streamer AGAIN. It should turn into a blue winking light. At the same time, your Phonak aids should give you the musical TONE that it is pairing with the streamer.

TIP from one with TWO TV Streamers: you have to actually hit that button EVERY time you switch from one of the TV Streamers to the other. Only if you use a single TV Streamer do the aids know you’re paired and want to stream from the device that streamer is connected to.

My daily ritual is: First thing in the morning, press the button on the streamer connected to my MacBook Pro (and of course make sure laptop volume is ON). At night I press the button on the streamer connected to my TV and watch a movie or show. Next morning … repeat!

If all else fails, return to your audi and make that person MAKE IT WORK for ya! Too often, we’re sent packing, a few hundred $ poorer with a gaggle of devices that we’re supposed to figure out how to hook them up, pair, stream and the nuances thereof.

OOPS! I no sooner posted this when I saw the following post and your own resolution. Good job! :slight_smile:

2 Likes

I am ‘technologically challenged’ and always have the A-ha! moment when I figure out my silly mistakes too. Just last night I was having problems streaming a movie to the tv and after 45 minutes of fussing with the settings, turning everything off and back on, updating the app, it turns out… I hadn’t turned on the WiFi. :expressionless: Glad you got it working!

1 Like

Hmm, insteresting. I have Marvel 70 312

Are you doing long press on volume up to select it? Probably a stupid question; no offense intended.

1 Like

Wow it worked! I don’t even need phone to do that, I did twice long press, and switched to tv program. Thanks! :slight_smile:

Strange, Simon. I have Marvel M70-R’s (rechargeables) and I never have to do a manual switch. My TV streaming starts automatically.

Tell me, do you usually run in a manual program? Like one-long-press mode?

If the HA’s are in Autosense program mode, they should switch onto the TV connector signal automatically. Ask your audi. Maybe the settings are strange.

I asked my audiologist right now, she said it’s manual program, not in the Autosense. She can change to automatic detection If I would like to, but it’s fine to me. :slight_smile:

1 Like

I’ve got my TV Connector on my PC. It’s set up to be automatic in AutoSense OS 3.0. I don’t have to manually change anything, it just works.