Phonak Marvel M-90R charging problems

I’ve been enjoying my M-90Rs for 6 months but in the past month they started exhibiting problems when recharging. Occasionally one or the other HA would show a solid red light and not charge. The problem usually resolved itself when I removed and reinserted the HA a few times. I checked the contacts but they are not dirty. The problem began exhibiting with more frequency (a couple times a week), so I tried a 2nd charger and power supply, but it still occurred. 2 days ago we updated the HA firmware, hoping that would solve things. They both charged fine the first night. But last night, both HAs failed to charge, and now the problem persists no matter how many times I reset them. They blink yellow for 5-10 minutes but then turn solid red again. The charge is currently at 25%-30%. I’m now bringing them in to my audi so he can send them in to Phonak for repair or replacement.

Has anyone else experienced this?

Yep, my wife had the same problem with her M-70R’s. My Audi replaced the charging base and the problem went away.

So far the only time I’ve had an issue along those lines is when they didn’t have good contact. I got mine nearly one year ago on New Year’s Eve (day).

There’s a firmware update for recent charging issues.

1 Like

I performed the firmware update and it didn’t help at all.

I cleaned the contacts with q-tip and alcohol, but that didn’t help either.

The problem exhibited with multiple charging units, so it was definitely the HAs not the charger. I returned them to audi yesterday for repair, and now I have a loaner pair. The loaners work fine with my chargers.

So odd that both HAs would fail like that at the same time…

Sorry to hear you are having problems with your rechargeable aids.
Hopefully the repaired or replaced aids will fix the issue for good.

I had a problem a while back with my Phonak Marvel M-90Rs not charging. My Audio advised the following -

There was an issue a while back with the plugs for some of the chargers where it wasn’t charging both devices. If it happens again then take the USB out of the wall plug and plug it in to your computer to charge. If it resumes charging then it is likely an issue with the adapter plug.

Thanks for this suggestion. However, the problem exhibited with multiple adaptors as well as multiple charging cases. And the replacement units are charging perfectly with that same charger and adaptor.

The good news is: it is covered under warranty, and my audi provided me with temporary replacements so it’s all good. I love the M-90R’s. The recharging experience has been mostly great until this glitch.

I’ll post here if there are any updates.

–rex

4 Likes

I have had many problems charging my Phonak Audeo M90 hearing aids. The only time I did not have a problem was when I was in Germany for 5 weeks and did not use the AC adapter, but I plugged the charging cord directly into an 6 port USB charging device. I never had a problem with charging. When I returned to the US, I had the same unreliable charging problems using the AC adapter. Finally I eliminated the AC adapter, and I plugged the cord directly into a USB connection for charging. This solved the whole charging problem.

I too had gone through the software updates, and the cleaning tips. That did not help. I thought I was simply unable to put the hearing aids into the charger properly.

Phonak supplied me with a faulty AC adapter.

When I visit my audiologist, I will request a replacement.

Such a simple solution to such an aggravating problem.