Phonak Audeo M90-312T a couple of issues

My M90’s that I bought second hand are generally doing great for the most part. I bought them as backups to my KS9’s but I’m using them instead of the KS9’s since I like the programming better. There are a few things going on that I don’t understand.

  1. When I boot up the right side aid it makes a soft ticking noise at about 4 beats per second for around half a minute. Then the ticking fades out and everything is normal.

  2. MyPhonak will not pair with the M90’s. It will find both of them but won’t pair. I’ve removed the pairing for my KS-9’s, uninstalled the MyPhonak app, rebooted the phone, re-installed the app and it still won’t pair. Otherwise everything works normally with my phone (Pixel 6a).

  3. When the member described how tcoils will connect with the magnetic field present with headphones I went looking for a tcoil program in Target. I didn’t find anything. Does this mean that the tcoils work automatically when there is a signal present? My M90’s sound great with my Sennheiser wireless phones so I’m wondering if this is due to the tcoils.

Edit: I found the tcoil program

TIA for any info!

My TCoil in Target on my M70 and P70 is known as Public Telecoil.

I know some of the Audeo range does not include the Telecoil feature.

If you’re not got the Telecoil program then you’re not using it as it’s not automatic.

Target recognizes my aids as M90-312T. I wonder why the telecoil program isn’t showing up?

How do you mean not showing up, it’s a separate program to activate and should be in the drop down menu.

I just found it in the dropdown under additional programs.

Fantastic, you’ll be good to go then.

Yes, thanks.

I’ve tried it with the mic turned off to verify the tcoils were working. Now I need to decide which program I like better for listening to music. As is the tcoil program seems brighter than my music program.

I’m having problems changing programs with the buttons on the aids. I have to grab the aid between my thumb and first finger to get enough pressure on the button for it to work.

I finally got the myPhonak app to pair by changing my 1 day old batteries.

1 Like

Yeah that’s good, so it was the old “use fully charged battery” before trying, glad it worked out.

1 Like


I have Phonak Audeo Paradise P90R’s. My schedule is 7:00 am to about 11:00 pm. I usually have about 15 % battery left. I don’t stream, and only run the automatic program. I’ve had to charge my hearing aids sometimes through the day; usually after I get home, before dinner.

Point is the battery capacity is “just enough” for me. If I streamed it wouldn’t be good enough.

My aids use #312 batteries. I had put new batteries in one day before trying to get myPhonak to pair. Evidently the reduction in voltage for one days use was enough to mess up the pairing. When I replaced the batteries the pairing went thru.

All that being said I’m not sure it was worth the effort. So far I like the music program better than the tcoil program for listening to music so the ease of changing programs may not have much value. I’ll leave everything set up the way it is now to give it a chance.

1 Like