Phonak app LE bluetooth behavior

HAs -Phonak Audeo P90-R RIC, myPhonak up-to-date, iPhone 12 Mini, iOS 16.3.1 up-to-date

When I open the myPhonak app it connects the Classic bluetooth and the two LE bluetooth devices promptly. If I open another app (effectively putting myPhonak in the background) within about 50 seconds the two LE bluetooth devices are disconnected. When I bring myPhonak back up, it tries to reconnect the two LE bluetooth devices but never succeeds. The app is then effectively disabled. I cannot use it to adjust the volume, manually change programs, etc.

I can totally close the myPhonak app, then restart it. Now it connects the Classic bluetooth and the two LE bluetooth devices promptly. Then proceeds through the steps described above. The Classic bluetooth seems to work just fine throughout LE disconnects, restarting etc.

I have read through all the Phonak troubleshooting tips I could find, deleted the myPhonak app, totally shut down my iPhone, rebooted the phone, reloaded the myPhonak app several times. So far nothing has changed this behavior. My audiologist retested my hearing a week ago and loaded new settings to my HAs. Is there a setting in Target that could produce this problem?

I have sent this question to Phonak support. Thought I would post it here also.


MyPhonak worked perfectly until the latest MyPhonak App update earlier this week. The iOS 16.3.1 update required the unpair, then delete the app “dance” but once completed fixed the goofy inconsistencies I was having.

However, once the most recent MyPhonak App update finished I have noticed the same things you describe.

My fix is simply to load the App whenever I need something changed, then immediately close and shutdown the App until the next time it’s needed.

Audeo P90RT with iPhone 13 Pro

1 Like

Exactly my situation. Updated the Phonak app and could only connect once.

Now I open, adjust, then exit to home and swipe up in the app switcher to remove it for next time.

On the upside, the first time it connects is much faster now.


Thanks for the reply. I can probably rule out my visit to the audiologist having anything to do with the problem.
I came up with the same fix as you. Kind of inconvenient though.

I heard back from a Phonak person. He is passing this problem info along to their development team.
In addition he had the following suggestion:
"When you do have this issue one thing that may help and avoid closing the app…

Click on a button other than Home at the bottom of the app. Then go back to Home.

This may allow it to reconnect quicker."

I tried this once and it worked. Actually superfast connection this one time.


Merci, je vais essayer, j’ai aussi le même problème. Il faut fermer puis réouvrir l’application… Pénible !

Thank you, I will try, I also have the same problem. You have to close and reopen the application… Painful!

1 Like

So they’ve finally acknowledged there’s an issue!! I reported this to them on the same day the myPhonak app update was sent out. Of course they made it feel like it was all my fault.

Let’s hope a fix is forthcoming soon.

1 Like

Confirming that this works! When you reopen the app click on the heart symbol to switch to the health app for just a second, then click on the “home” button to immediately switch back and it should reconnect!

1 Like