Oticon OPN S1 Firmware Update

I use the Noah Wireless programmer but to update the firmware you need a wired connection. I’m using the Hi-Pro programmer for that update. What cables are required for this update?

I have a CS44 cable with a flex connect strip and it connects to the aids but when I try to update the firmware it says that programming device not found. Any ideas or suggestions? Thanks,

Have you made sure that the choice of programming device has been selected in your Genie 2 software?

yes I have. Still same message.

I too have a Noahlink Wireless and the HiPro with Phonak Target.
Not sure what to tell you now.
Did both devices function properly before?

If you use an old serial HiPro it will not be found if the main Genie program is running. One of the guys said a serial port can not be shared. Reboot the computer, then without starting Genie start the firmware Update program directly.

2 Likes

I usually need to shut down the Target software and restart it when switching programming devices.

Awesome. Thanks so much! I’ve tried I don’t know how many configurations and spent hours trying to update the firmware. This worked!!!

1 Like

I’ve been able to update all my OPN S1’s except one of them. Says instrument not found. Weird because I was able to update the firmware on 6 others. Any ideas what might cause this just one to not respond? Firmware is not the latest version. I know that by opening the aid thru NoahLink. Thanks!

So are you able to connect it and program, or nothing at all?

I can connect it and program it using NoahLink wireless. Can’t update firmware thru NoahLink tho even using cables.

Can you program that aid with HiPro and cables?

No. Just with the NoahLink wireless.

Ok, so that aid does not connect using cables.
Sure sounds like a connect issue with that particular aid.

Can you reset to factory settings and then try the update, I know some brands even allow you to roll back to a previous version of the firmware.

Tried it using NoahLink wireless and there’s no option for a reset in Genie 2 that I know of.