Noahlink Wireless not connecting to Oticon Opns

Starting a new thread for this. This may go slowly because of the time difference.

The different language (for human interfacing) should not be a problem. Are you sure that you are running Genie 2 and not the older Genie? They are two different .exe/executable files. See this post.

From the User Guide,

  1. Performing a wireless fitting can sometimes be challenged due to number of factors related to equipment setup, and the physical layout of the fitting environment.

    Place Noahlink Wireless on the table with a clear line-of-sight to the hearing instruments, which should be within a range of 10 feet (3 metres).

    Avoid placing the Noahlink Wireless in a USB hub with other USB devices (e.g. Bluetooth dongle), as this can decrease the efficiency of the Noahlink Wireless.

    When fitting hearing instruments inside a sound booth place the Noahlink Wireless inside or close to the booth.

    It is recommended not to use USB cables between the Noahlink Wireless and the PC exceeding a length of 10 feet (3 metres).

Always open/close the battery door to connect
When connecting the hearing instruments to the fitting software make sure to always bring the hearing instruments into “Fitting mode” by rebooting them. This is done by opening and closing the battery door of the hearing instrument one time.
By doing so it is possible for the fitting software to discover and communicate with the hearing instruments.
Note: If a hearing instrument is accidently put into flight mode where all wireless operation is disabled, just open and close the battery door again. After 10 seconds wireless operation is resumed. Keep the battery door closed for an additional 15 seconds after wireless operation has been resumed before opening and closing the battery door again. Opening and closing the battery door within 15 seconds will put the hearing instrument into flight mode again.
For more information about Flight Mode please refer to the relevant wireless hearing instrument user guide.
After having completed the fitting make sure to open and close the battery door to reboot the instruments saving all settings

User Manual here.

1 Like

One of the Opn updates was specifically to overcome wireless programming glitches.

If your Opns are not on V5.0, potentially you’re hitting one of these glitches.

You’ll need a hipro, leads, flex-strips, and a copy of Genie 2 to run the upgrade.


Thanks all for the wonderful feedback!

Running Genie 2 SP1 with Noahlink Wireless updated to latest firmware. Tried connecting literary with both HAs hanging over the Noahlink. Next step is to upgrade my HAs with firmware v.5 as bongo recommend.

Previously, we used the FittingLink 3 dongle - the Oticon firmware deivce - to program my HAs. So that could also a potential hick-up. My iPhone still connects seamlessly with the OPNs, but I also know it’s a different Bluetooth standard from the programmer.

Has anyone else tried the Noahlink Wireless with OPNs? No probs at all?

Will keep you posted!

Yes, Oticon Opn’s via Noahlink Wireless works well for me.

Please do. I have just bought an Airlink 2 on eBay and will receive it next week. Will be trying it with my new Opns after I upgrade firmware (if needed).

Its all good after the update to firmware v5.


Tidy. Glad it worked for you.

1 Like

Hi everybody!
I still have the same problem with no connection to my Opn updated to 5 version.
Genie 2 updated.
Does anybody know what the problem it can be?

Are the hearing aids branded as Oticon Opn or maybe a re-brand like this Selectic Poseidon 12 miniRITE?

As Oticon Opn 1.
To be honest I’ve even never heard about second one before.

I don’t know if it’s matter. I have only one HA (right side).

No, it should be able to connect to 1 or 2.

Do you have the Noahlink Wireless branded device or the ReSound Airlink 2 branded device? They are both the same device but the ReSound Airlink 2 version needs a Firmware update applied to the device to turn it into a Noahlink Wireless device capable of connecting to non-ReSound hearing aids.

Completely sure I have the Noahlink Wireless since it detected as its in Genie 2.

So many countries, so many re-brands; Let’s double check?
On the battery door of your hearing aid (in tiny, tiny letters) it says;
The above Oticon Opn1 hearing aids have had the hearing aid Firmware update to v5 using a Hi-Pro and cables because Oticon Opn Firmware updates cannot be done wirelessly.

Place the hearing aids a few inches away from Noahlink Wireless after opening/closing the battery doors. Your wireless programming device says Noahlink Wireless like the one on the right, correct?

HA - see the photo below.

Also, I know that it was recognized as Oticon Opn when I went to my audi.

Programming device - can’t make a photo, but yes, the same as on the right.

So I do place it near the device after opening/closing the battery doors. And nothing is going on.

Noahlink is just blinking with green colour and that’s all.
Noahlink connected directly to usb on motherboard, not a hub.
iPhone and Opn are unpaired.
Genie 2 is updated.
Noahlink has the latest version.
I don’t have wifi or something else could block the signal.

And… I’m so confused because I know it should be so easy, but no…

Yes, my NLW lights blink green when trying to detect hearing aids. Tried these?


  1. Genie 2 /Preferences / Edit preferences / Programming Device / Detect
  2. Genie 2 / Select a client
  3. Genie 2 / Family / Detect

The same version as mine.

And this is why I’m asking about 2 devices. I can see only the window where it’s trying to find my HA, and there are two sides, right and left, at one row.
I thought, maybe I should choose just one, but don’t know how to do it.
Anyway it doesn’t matter since you said it should connect to 1 HA.

Okay… I got it.

Then don’t any idea what’s wrong…