Newbie - MyPhonak App changes not holding

I’ve searched for an answer in hopes I could find without asking, but…

I’m a newbie with HA’s and only had them for a week. I have the Marvel M90-R RIC on both sides and the improvement has been good with not a lot of adjustment issues. Still tickle, but I’m getting used to it.

When I go to the MyPhonak app and make an adjustment, I can hear the change and fine tune things to be comfortable, but when the phone goes to sleep or I close the app, the sound reverts to the initial settings. Is there a way to keep those settings active until I physically change them again or change programs?

New and Confused…

Thanks,
Greg

Yes, this can be a bit annoying. There are three kinds of programs in the Marvels. One set is programmed in by the audiologist in the software, and you can select them via long presses on your HAs. These would be things like “speech in noise”, “music”, “t-coil”. I’m pretty sure you can fiddle with these in the myPhonak app, and the changes will stay put, but I could be wrong. I’ve not investigated very carefully.

Then, there’s another set you can reach only by selecting them in the myPhonak app. You can fiddle with these, but they won’t stay put if your phone goes to sleep. At least that’s the case with mine.

Then, there is a third set of programs which are only for special occasions, such as being connected to a Roger device, or streaming audio from one’s cell phone. Those programs only show up on the myPhonak app when you’re actually using them, i.e. connected to a Roger or streaming from your mobile device. You can fiddle those programs, and they will stay put so long as you’re still connected to the Roger or cell phone, or whatever.

It’s confusing.

Thanks for the explanations…so much to still learn, but I’m only a week into this.

I sure wish the MyPhonak app would keep the adjustments once the phone goes to sleep, that seems to make it kind of worthless for lack of a better term.

Thanks,
Greg

I just a reply from my inquiry to Phonak and have tried their suggestion. I did have the phone making a sound when I turned it off, but no keyboard sounds. I’m cautiously optimistic. I assume when I get a text or phone notice it will revert to the AutoSense mode, but at least it might act the way I wanted in between.


Good afternoon, Greg-

Thank you for contacting Phonak with your inquiry. We believe some phone features may be causing this. Phones are set up to make a tone when the screen is touched. When the app is closed, the phone makes a tone and sends this tone to the hearing aids. This causes the hearing aids to switch into the BT streaming program. Once the hearing aids recognize there is no sound coming from the phone, they will switch to AutoSense. To keep this from happening, we recommend turning off all lock sounds, touch tones, and raise to wake. This is the same case for receiving a phone call. The phone call switches the hearing aids into the BT phone streaming program. When the call is finished, the hearing aid will switch from BT phone to AutoSense. Please let us know if you have further questions.

Best Regards,
Phonak

1 Like

Me too.

I understand why it might need to change program to sound a phone bleep in your ear. I’m less sure why it loses the setting when it loses the phone (does my ear belong to me or the phone??).

But after that it SHOULD go back to the setting you had before the bleep. At least that should be an option. In My Humble but High-Price Opinion.

And while they have the thinking-cap on… why can’t it process the microphone AND a streamed bleep at the same time, each with best effect? This is less than my high school PA system, which could mike a teacher AND play the Anthem together or sequentially.

You should call phonak or go back and discuss it with your audiologist

Hi Greg,

You may have figured it out by now, but if not, the way I got to work with my iPhone was to engage the little button on the side to put the phone in silent mode. After I enabled that, I can switch from Autosense to Restaurant or whatever and it will hold until I change it. Works like a champ!

Hi John,

Thanks for that idea. I seem to doing okay by making sure notifications are off so I don’t get a tone. I’ll try the silence switch since I usually turn that to silent when I go to a restaurant…assuming I ever get to go to one again :slight_smile:

I had the same problem with new KS9’s. The audi at Costco called Phonak for help. The Phonak person pulled up info on my Pixel 3a XL and walked my audi thru a bunch of changes that seem to have totally fixed the problem.