New hearing aid (Jabra Pro 20) experience

I got my first hearing aids at Costco this Saturday. I had done an inordianate amount of Googling and
found this forum to be a welcome source of informed opinion and facts which helped a lot. So describing my experience here - in case it can help someone else. I bought the Jabra Enhance Pro 20 with MRI&E and got the closed domes. The fitting lasted about 30-40 minutes and went smoothly. I did ask for open domes (based on feedback here) but the audiologist convinced me to try the closed ones first as that was recommended by the program.

First experiences. While all sounds were much louder, unlike the sample unit I had tested earlier, it did not seem that I could hear everyone at Costco speaking. Many new sounds, carts screeching, dings, clinks of putting things down etc. Not scary just unfamiliar. On the drive home - I kept hearing a rattle from my car. Problem was I could not figure out if this was something new I was hearing or I had just
ignored this earlier. In fact that feeling turned out to be a very common one.

At home it was pretty different. Sounds from faucets, even walking up the stairs were startlingly loud. I am guessing that in the noisy Costco environment the HAs had muted other sounds somewhat.

Was eager to check how I fared with TV - was a mixed experience. I think did not benefit much when watching a movie. On the other hand the news were much better. Previously I would understand about 50-60% of what was said - rest I guessed or just ignored. With the aids I would say I understood >90% of the words.

The important test was at work - the main reason I got the HAs. This was a resounding success. We have daily meetings and I would maybe get about 60% of the conversation and with technical discussions it is not always possible to guess correctly. While the meeting environment was far from challenging, with HA my comprehension was 100%.

The Android Jabra App. I am not too impressed with it. It has the basics and a very useful on-off toggle. It is finicky with bluetooth. If disconnected - takes multiple attempts and switching the HA on/off to connect again. Streaming works and while it is clear does not sound nice especially for music. There are also issues when on the phone - it fades in and out. I found it much easier to switch off the streaming in a phone call.
Another niggle - it seems streaming does not kick in right away. For example when starting a playback of a sentence on the phone, the first word(s) is unintelligible. But if you replay it is fine.
Still learning to put on the aids efficiently. I think the domes are a bit too tight will go back for smaller ones.
Also everything others have mentioned - being able to hearing birds, flowing water, steps, etc. is accurate.

Apologies for the long-winded post - but hoping someone will find this useful.
PS. One question. The reset option in the app, does that reset the programming to factory defaults or just to what the audiologist setup at the store?


I got my Jabra Pro 20s on Saturday as well. I have been keeping them in all day long. I’ve had a lot of the same experiences as you have, including with the app. I’m getting used to my voice however and that feels more comforting. Some of the sounds are still loud but they’re getting better. I have the equalizer in sound enhancer in all programs set to six base, three mid, and zero high, sort of like my audiogram. Lol. When I press reset it puts everything back to neutral on the EQ as is based on the fitting.

I did not initially get fit with M&RIE. I want to try switching to that when I go back for my REM in a few weeks. I also want to try switching from open dome to tulip dome. I’m hoping to get more base response better directionality and maybe a better sound when using the inner microphone on phone calls.

This morning the app kept connecting and disconnecting connecting and disconnecting. I then noticed in “active in the background” that the app had been running for 11 hours. I stopped that and things worked better… for now. If you go to the three bars in the bottom left of your screen you can see all the running apps. At the top left there there’s some words that say active in the background. Click on that and you’ll see which ones are running. You can stop the ones you don’t want. I’m going to try paying attention to that.

While streaming, the sounds on YouTube and Spotify / Pandora are all lovely with no hearing aid sounds, just clarity. I use the “:musical_note: and TV” program (the default name is music) I’ve not tried a live TV at this point. But streaming with the phone call is like talking with my hearing aid sounds.

I’ve had difficulties switching between streaming and not streaming. When I turn on music it does not always switch to streaming, so no sound is heard. When I got a phone call last night there was no sound until I turned off Bluetooth and went to speakerphone. During that call however I went into my Bluetooth setting and turned off LE audio, wondering if that would take me into ASHA. It did not, it just disconnected the hearing aids. When I turned LE Audio back on my Bluetooth started working with the phone. Later switching back and forth from music and YouTube worked as well till I went to bed. It still seems to be working this morning. I will try the LE Audio Switch again when problems occur.

Overall I really like the hearing aids. But the Bluetooth / app issues are frustrating. I’m still trying to work through them. Hope that helps.

1 Like

@ssb, a couple questions.
What type of closed domes do you have? Tulip? Power? Something else?
You mentioned an on-off toggle in the app. Where is it? What does it do? I do not see it in mine. Pressing my left HA for 2 seconds is supposed to toggle streaming but I have not been able to get it to work and it does not make a beep like the other button may be an HA issue.

By the toggle I meant the icon to the left of the volume sliders on the home screen. This switches off the hearing aids altogether. You can control left and right separately too if needed.
I was hoping there would be an option to disable streaming only (not connectivity) but the app does not have it. Instead I am able to switch off the streaming to HA in my phone dialer app.
My domes are not power domes, that I know. I do not think they are tulip domes either if the pictures on the net are accurate so must be regular closed ones?

You folks seem to be Android users. On the iPhone, there is the “Control Center,” and in the Control Center, you can have a widget that allows you to choose where your audio output goes. If you don’t want the audio sent to your HAs, you can send it to your phone or another audio device paired to your phone, like a BT speaker (or even your vehicle!). As far as streaming itself goes, you have to shut off or pause the source. On the iPhone, AFAIK, if the source is “on,” it will want to send the audio somewhere. And it’s usually not too hard to find the source in the “app switcher,” of which Android has the equivalent, IIRC.