Naída CI M90 + Naída Link M with TaoTronics BT Adapter not working

Hi all, I’ve got one new Cochlear Implantant on one side. Before, I had HA from Phonak on both side. For calling and streaming on Laptop and TV I have used my Compilot. My old both Phonak HA with Compilot was a wonderful solution, because I had paired and connected my Compilot with several devices and use this devices at the same time without any issues.

Now, with my new Cochlear Implantat M90 from Advanced Bionics I also got the new HA Marvel Link from Phonak. I never was frustrated like before. What I’ve learned it, that I only can connect to one device and only paired two devices at the same time.

I’m working as a Manager and have a lot of calls every day, sometimes Skype on my MacBook and sometimes on my Android phone. To disconnect from one device and to connect to another device is time consuming and not really user friendly.

Nevertheless, I also want to connect to my TaoTronics Bluetooth Adapter (TaoTronics Bluetooth Adapter Transmitter Receiver 2 in 1 Bluetooth 5.0) to watch YouTube to train my hearing with Cochlear Implantat. When I got my new Phonak Marvel Link HA, I have connected my HA and CI to my TaoTronics (before only my Android phone was connected and I’ve learned to disconnect to pair with another device), It did not work right away, after a few attempts then it worked.

Next day I try to connect my HA and CI with TaoTronics and somehow it no longer worked. Weird and frustrating. I have then disconnected all my devices, it didn’t work. So I started to unpair my HA and CI from all devices I have paired. But it not possible to connect my HA and CI to TaoTronics anymore, even though it worked before.

I’ve checked my TaoTronics by pairing my Compilot again with TaoTronics. It works! So I don’t understand why I can’t pair my new Marvel Link HA and M90 CI with TaoTronics. I have search the whole Internet for a solution, but didn’t find a solution. Even Phonak Support was not willing to solve the problem, they only refer to their Phonak TV Connector for which I have to 200 extra bucks.

Is there someone who know what to do to connect to my TaoTronics BT adapter? Is there any steps I’ve missed? And maybe have an idea why I could paired and connected first time and afterwards is not possible anymore? Thank you very much for your support.

I believe this is a mistake. The Compilot is not part of this new CI and hearing aid. Do not pair with it.

Let us know.

Hi Raudrive,

thanks for responding. I maybe have described a bit unclear, I apologize for it. I know Compilot II (which I have used with my previous right and left HA) is not part of my new CI (Marvel M90) and HA (Phonak Marvel Link). I even know Compilot II is not work with my new CI and HA. What I would like to say is: to check if my TaoTronics BT adapter works fine I have unpaired my Compilot from TaoTronics BT adapter and paired it again. Then I see, that my TaoTronics BT adapter works fine, I can pair it with other devices.

My issue is I can’t pair my new CI and HA with the TaoTronics Bluetooth Transmitter. Only on the first day when I got my new Phonak Marvel Link I could pair my CI and HA with TaoTronics BT adapter, now I can’t either pair nor connect it with TaoTronics BT adapter. This is really annoying me.

Sounds like you took the right approach by trying to start fresh. Might try again being diligent about unpairing and disconnecting from all devices and having any other devices turned off. I must admit though if it were me I would likely spring for a TV Connector. They really are a slick device. I’ve seen them for as low as $150 and if you could find a way to buy one from Costco, they have them for $100. Good luck and keep us posted.