MyPhonak app advice

Hi. Just got lumity L90 life aids and learnt of the disappointing ‘feature’ where any notifications sound on the iphone disconnects the aids from the app. Sometimes they reconnect…slowly…or normally the app has to be restarted. Obviously all manual settings disappear. There are lots of complaints on the app store. I wondered whether anyone has any info as to when /if this is going to be sorted. Cheers

1 Like

I am not familiar with the apple phone but on my android I have the option within the Bluetooth screen to turn off either streaming, telephone or both. I disable streaming (but not telephone) which solves the notification problem.

1 Like

Thanks for your advice. Unfortunately, my iPhone doesn’t let me do that…unless someone knows differently.

my frustration as well. I’m searching everywhere for solution. New Naida L-90’s yesterday.

1 Like

I just flip the little switch on the side of my iPhone 14 Pro Max to red in order to turn off notification sounds. Problem solved.

I have an Apple Watch so all the notifications go there anyways and I don’t need notification sounds on my iPhone.


1 Like

I have sound off for my notifications apart from FaceTime and Text messages as they are super annoying.

My MyPhonak App works fine this way.

Thats really strange. Could it be a setting on the iphone? The app stays connected through thick and thin, for me (android but it should work similarly).

Thanks. I eventually discovered this. I use an apple watch also. It’s not ideal though. It never happened with Resound and Oticon. Another problem I have is if I leave my phone in my lounge and walk into the kitchen, I get the dreaded turn off noise, connection is lost and all manual settings disappear. Pretty rubbish really!

What do you mean by all manual settings disappear?

Do you have “stay connected” activated in the app? Only them the HAs sound a signal to notify when BT-signal is lost.
You may want to deactivate that.

Thanks for your interest. I just tried turning off ‘stay connected’ # I didn’t get the chimes…but it still disconnected :frowning_face:

New aids, so unfortunately they are still not configured correctly by my audiologist. I therefore have to turn down screeching manually on the ‘auto’ setting. When connection is lost, settings are lost.

I never encounter this issue when I adjust my HAs (Phonak Naida L90-UPs) using the manual volume toggle but I have observed this issue with the volume resetting when using the app.

I almost always adjust the volume manually now so I had my HIS unlink the manual volume so I could do each ear separately. I believe this capability may be new to the Lumity models. Not sure how much this helps as you will still need to go in to get it set up but might be good to have for the future.