KS10 suddenly not charging?

I have a pair of KS10s, which worked flawlessly since August 2021. I forgot to charge my HAs last night, plugged both into the case this morning and only the right aid has charged. The left aid resolutely remains…dead.

I’ve had it in to charge, carefully cleaned the contacts, tried both slots in the charger (works fine with the other aid). Still nothing. No lights, no response to trying to switch it on.

Before I reach out to Costco, anything else I can try?

try to put the left hearing aid in the right slot. It is possible that the charger is dead


He has tried both slots of the charger and it’s still dead.


You could try, a wee trick I use to restart Li-on batteries that refuse to recharge @garethjwells, the battery is usually depleted beyond a certain level…… This involves placing the battery or aid in your case, to just touching the charger terminals, whilst the charger is switched on, pull it away, and repeat several times (very quickly), you are only touching the charge terminals for a split second, do this 6 or 8 times, then see if it charges as normal, if not repeat the process, I have kickstarted several Li-on batteries like this, when I assumed they were kaput…. But, unfortunately not all. Tis worth a try. Cheers Kev :wink:


Something else worth trying is holding the hearing aid toggle down for 10-15 seconds while the aid is in the charger.

Good luck


re: “Something else worth trying is holding the hearing aid toggle down for 10-15 seconds while the aid is in the charger”

What is a toggle?

1 Like

The rocker switch. Hold it down on the bottom for 30 seconds, then place the aid back in the charger.

1 Like

In the end a hard reset sorted the problem (I found this out from emailing the guy who runs the Costco HA clinic). So 15 seconds on power off then straight onto charge woke up the HA. +1 to Costco for practical help within 20 minutes of my plaintive email!


OK, Thanks. That’s what the little manual book says for “rebooting” on p. 49.

I had the same problem a few days ago. Right aid would not respond in any way. Tried holding the rocker switch down for 15 seconds - no joy. Placing it back in charger did not bring it back to life, but on reading the manual (chapter 15) maybe I didnt wait long enough.

I had been having intermittent charging problems with the aids over the last month. They would occassionally just partially charge. I had been waiting to see the charge level tick up before leaving them for the night, but still they would not be fully charged in the morning.

Ironically, when I took them back to Costco, the failed aid starting charging. But Costco agreed to send them back to Phonak for electronics replacement.

1 Like

Thank You,this tip saved the day

Man… I cannot believe that worked. Superb tip! Thanks!

It took a few tries but, on probably the third or fourth go and after literally jamming in into the charger and immediately pulling it out at least a half dozen times each go, I finally have a red blinking light on a KS10.0 that has been dead for a couple of days!

1 Like

Welcome to the forum @user676… I am glad this tip was useful, it sometimes works, and sparks the Li-on battery back into excepting a charge, hopefully all is now well, and you are good to go… :grin: Cheers Kev :wink:

Yup. 99% charged and going through the extended period of balancing that generally happens between 99% and fully charged when these units hiccup.

1 Like

I had the same issue last night. Inserted right hearing aid into charging, no light. I tried both sides repeated and no light so I went to bed. Same thing this AM. I tried pairing aids without any luck and still no light in right hearing aid. Called Costco and left a message. I did the insert/pull out trick (8-10 inserts) and no luck. I then did the hard reboot tip and held the button down about 30 seconds and no luck. Costco tells you to push down hard on the charge station cups to seat them and I had tried that without any luck. After the hard reboot I placed the aid into the charge port, pressed the aid button again and saw a red light go on and off. I then pulled it out and placed it in left side and the green light came on and was now blinking. Left it there about a minute, placed it back into the right charge port and it began charging. I was able to resolve the problem and we are back to normal. Thanks to all of the above suggestions as we are now good to go! :+1:t2:


If you have any more trouble, see if you can get Costco to update the firmware. See my description at Costco apparently fixed my KS10 charge problem - #2 by FredO
It has now been over two months and the charging is working flawlessly.

Also if Costco feel they can’t help, you could do this yourself, just need the Noahlink wireless and target.