Echo on phone calls with KS10

So far I am really loving my new KS10 aids! My hearing exam was very thorough and the fitting went well. One small issue - when Phone calls come in through the aids the sound at my end is crystal clear, but the person at the other end says that my voice has an echo. Is there any adjustment that will minimize that effect or is it simply a function of using the mics on the aids? My old Phonaks used the Compilot II, kind of a pain but great sound at both ends.

This person believes there is a setting to help with how the caller hears you. Hopefully your Audi can find the setting.

To get rid of echo this is what i did in phonak target.

Turn off sound recover. Then re-run feedback test, after test make sure "used estimated " box is check for both, you will have to recalculate for each check box.

Thanks. I don’t have the target software but I have an appointment with the AuD in 3 weeks so I’ll ask het to try that.