ComPilot not pairing with iMac

I have a Phonak ComPilot that I use with Phonak Ambra SP BTE HA’s.

I have been able to pair it with the TVLink, iPad, iPod and Cell Phone. But my iMac Intel refuses to link with it. It finds it as a headset device and then tries to link with it to no avail (failure 5 times out of 5).

Has anyone been successful in linking their ComPilot with a Mac computer?

For some reason Mac products don’t seem to like pairing in the Bluetooth mode. I just use my patch cord that came with my Streamer and plug it into the back of the Mac and then into the Streamer. It’s a simple fix and it never drops out like the Bluetooth seems to do on the Mac’s if you can even get it to pair.

Actually Seb, I was just able to solve the problem here is what I did:

Disconnect all BT devices that are paired to the computer, turn the computer’s BT off. Then log out and log in again. Turn BT on and try pairing with the ComPilot again. With this procedure I was able to connect the ComPilot with my computer. Once the pairing is done, you can then connect the other BT devices.

One other thing I found was that I had to upgrade the device status on my computer from being simply a Stereo audio headset to being the sole sound output device for the computer so that I can hear sound from any application running on the computer through my Hearing Aids.

Once working, it really works very well! :slight_smile:

I did that also but I had 2 problems: 1. the Bluetooth would cut in and out, 2. when I shut the computer down I would lose the pairing. I just found that using the patch cord was an easier and less frustrating solution.

I Just learned by experience the same thing as you. The Mac just doesn’t seem to play nicely with the ComPilot.

Very frustrating! And yet the ComPilot works well with the iPad and iPod which are made by the same company. Go figure!

As posted in the other thread, I had no issues whatsoever pairing my ComPilot with my iMac. I have a modern iMac and I run OSX 10.7.4.

Gramps, suggest you do a software update and see if that helps.

We also have a modern IMac and run OSX 10.7.4 and I can’t get it to pair with my Streamer and stay paired or continuously drop out. That is why I always use the patch cord.

I tried this, but my MacBook Pro does not see the ComPilot and thus can’t connect. Any thoughts?

— Updated —

I tried this, but my MacBook Pro does not see the ComPilot and thus can’t connect. Any thoughts?

Did you place the ComPilot into pairing mode by pressing and holding the Connect button and the volume up (+) button until the audio indicator starts flashing blue?

Sorry to be so late posting, but just got my HA in November. There was no trouble pairing the ComPilot with the TV Link S, iPhone 5 and WiFi only iPad Air, but not with my 2012 Mac Mini. Finally this was accomplished when I turned BT off on the iPad Air, but kept it on the iPhone. Turned on the ComPilot without the loop attached and the Mac Mini found the “Phonak ComPilot”…it paired.

One thing I have noticed is that the ComPilot says it can pair with up to 8 devices (and can be in actual connection with 2) but my experience is that I need to clear out the past pairings after about 3 devices if I want to add another.
Overall I find the Bluetooth capability of the ComPilot rather frustrating (quite apart from the need for a neck-loop - BLAH) for reasons such as this. Also I have had the ‘voice’ turned off but there are still some annoying ‘beeps’ at times as well as a background ‘hiss’.

i have no problem pairing with my 2006 macpro but only for using it as a mic, not as a headset. cant figure that one out.

My Compilot II pairs just fine with my Macbook Pro - running El Capitan. The only thing is that it is necessary to click reconnect in the toolbar bluetooth first up. There can sometimes be a conflict with too many devices trying to talk to the Compilot. In those situations one will have to be disconnected.