ComPilot 1 loud buzzing and audio cuts out when using bluetooth



I’m still rocking my Phonak Nathos Micro W aids, and I’ve got an original ComPilot 1. I have the ComPilot paired to my phone (Xperia XA2), my laptop (Thinkpad W540 using Intel Wireless 7260 series card), and my work computer.
For my work computer I’m using a Sennheiser BTD800, previously I had some nondescript Asus USB Bluetooth dongle that they gave me after finding it in a box of junk, but it caused the machine to bluescreen every time the ComPilot threw a sulk - a driver issue with the cheap junk bluetooth dongle for sure when I checked out the resulting memory dump from the bluescreen in WinDbg, so we ordered a BTD800 and it seems to have sorted that out… fingers crossed! :slight_smile:

I’ve been having weird issues when using my ComPilot with my phone where the audio I stream keeps cutting out on both sides, but the voice prompts are still totally fine. When this happens, I can press the button on it to “pause” the audio, then I press it again to resume, but when the audio is supposed to resume it makes the most almighty digital buzzing noise at full blast for a few moments, but then stops, and starts playing the audio again before promptly cutting out again after a few moments.
Both aids get the audio cutting out at the same time, and given both the voice prompts and the built in test audio sound fine, I think the neckloop is probably OK as the aids can pick up the audio from that no problems, but I’m suspecting the Bluetooth chip inside it is doing something funky.
Occasionally it’ll have what I perceive as signal/range issues - my phone in my pocket won’t be enough to reach the ComPilot around my neck, but this usually clears up if I restart the ComPilot for some reason. If I still had access to a spectrum analyser I could probably check the signal levels coming out of the phone are up to scratch - perhaps this is an issue, but without the test gear I can’t confirm it, however my pebble (smart watch) seems to work fine with my phone without constantly disconnecting.

3.5mm/DAI inputs are both good, as is the test audio, I can’t get either of these to play up in the same way as the bluetooth has been doing. No cutouts, and no obnoxious full volume buzzing whilst it’s sulking.

It’s been a pain before - when I first got it, it would emit absolutely no audio other than the built in test sound and the voice prompts from whatever device I tried with, but I was able to rectify that by trying to reset it with Target - but it really didn’t want to be reset, it took a few hours to get it to play ball.

I’m going to try and reset it later today (I hope it goes well unlike last time - I have a 4 hour conference call tomorrow at work that I’m not looking forward to, more so because it’s at 5 in the morning!) but if that doesn’t fix it, I was wondering if anybody else has experienced similar issues with an original ComPilot before, and if so, did you have to send it back for repair/replacement or did you have any luck fixing it yourself?

Thanks in advance :slight_smile:



You might try putting your Compilot 1 in a dryer overnight.



How long have you had it?



@Raudrive Good shout, I should have thought of moisture, especially since I never bothered with the silicone case for it, when maybe I should have. Sadly it doesn’t fit in my drying pot as it’s ever so slightly too big, but we have an ultrasonic cleaner in the workshop at work for cleaning corrosion from water damaged boards before we rework them, and I should be able to open it up, remove the battery, and put just the circuit board in. My only concern is the microphones and how they’d react to being flooded with the cleaning solution - but the guys in the workshop think we should be able to safely desolder those before it goes in, and then reattach them afterwards. Not for the faint of heart, but I’ve done enough repairs on things before to feel confident enough not to break it more, although the first time I took a soldering iron to my laptop I can assure you I was definitely worried! :slight_smile:

@Zebras I’ve had it since August 2016 - my previous workplace bought it for me so I could hook it up to my desk phone. I suspect it’s out of warranty by now, certainly the battery has degraded and doesn’t last all day anymore, but that doesn’t bother me so much since I keep a USB charger at my desk.



You might try putting the Compilot in a plastic bag of rice. Take it apart like you mentioned then put everything in the bag of rice. Try to leave it in the bag 2-3 days. This has done well with my cell phones in the past.

1 Like


I popped it open - whilst I can’t see anything vaguely resembling the usual tell-tale signs of liquid damage (well, I can’t check under the bluetooth chip cos it’s a BGA and the “pins” are underneath, and that’s the one I suspect is bad), weirdly there’s an exclamation mark marked on the PCB right where the bluetooth antenna is, although I can’t see any evidence of the board being reworked as they might do to one that fails testing.

Sadly still not quite small enough to fit in the drying pot (literally a millimetre too big now, annoying!) but I’ve got some zip-loc bags that both the desiccant capsule and the board from the ComPilot should fit in, so I’ll try that for a couple of days and see what happens! :crossed_fingers:

1 Like


This may be totally LEFT field, but I get an almighty buzzing as well as dropped signals using my Phonak Marvel aids - which stream without a device to my Android phone.

Could there be some form of interference coming from a different device, phone, even cell service around where you work? Is there a device with a dead rechargeable battery? I ask cuz it seems that may well have been the cause of my own aids buzzing. My mom’s cordless handset rechargeable battery was dying and the connection was getting worse and worse when on the phone with me.

For the conference call, see if there is a pair of headphones you can use. I have Sennheiser Momentum headphones for Android, which work great - but they’ve been discontinued!

Would be really curious to know what your final solution is. That ! is indeed an attention-getter. I’d even call the Compilot Tech Support line and tell then that’s what you’re seeing on one of the boards in the device. Could it be a marker to indicate “no component here”? Very strange.



tldr; the workaround for me is to be more careful which paired devices I keep Bluetooth enabled on

Overthinking this as usual, I was able to setup a capture using an Ubertooth One and my phone - looking at what was going over the air, I think the signal and noise levels were within what I’d expect, although I noticed some clock anomalies, these could well be down to clock drift on the underpowered laptop I was capturing it from, especially since it was under heavy load. There wasn’t really much there to look at because the actual Bluetooth payloads are all encrypted and I’m not sure I can bother with trying to decrypt those, also I value my sanity more than trying to dig deep into the BT stack, not a rabbit hole I fancy going down tonight. :slight_smile:
Somewhat defeated by the encryption, I enabled HCI logging on my phone as I figured this might give some better clues - the HCI log is a super super handy Bluetooth logging function left in for developer use that shows what the phone is doing from a perspective of what services are accessing the BT stack and I was able to… well, sort of replicate the issue whilst logging it, but annoyingly without the obnoxious buzzing this time. I’m sure it’ll return when I’m not looking for it!

It looks like my issue could be related to my laptop trying to connect to the A2DP service on the ComPilot, and when this happens, the log on my phone shows an EVENT_TYPE_AUDIO_STATE_CHANGED, followed by EVENT_TYPE_CONNECTION_STATE_CHANGED and finally a DISCONNECT as the laptop grabs the A2DP service. It looks like my laptop is then incredibly greedy and unlike my phone it never releases it’s connection to the service - this shows in the Bluetooth menus as the device being connected for Call Audio only, rather than Call Audio, Media Audio. A forced reconnect on the phone will get the A2DP service back, but only once the laptop has had it’s Bluetooth disabled - no combination of button presses on the ComPilot seemed to release it from the ComPilot’s side, although I could have sworn I could switch audio devices before, but maybe I’m misremembering.

I’m not really sure how to make the laptop release the audio device when it’s finished using it, but for now it looks like the workaround for me is to be more careful which paired devices I keep Bluetooth enabled on, I had it running fine all morning with just my phone, and in the afternoon again fine with just my laptop.

I wonder if your also have multiple connected devices when you get the buzzing with your Marvels @1Bluejay ?



In fact, I only got that annoying buzzing & crackling when streaming on my Samsung S9 cell phone! I’m paired and stream with my laptop and TV (via the Phonak TV streaming device, which I have hooked up to the laptop and the TV). That’s what made me wonder about a phone-specific static problem.

I’m on T-Mobile phone service in the U.S., and during summer, when the MOBS descend on my lovely village, the reception - in general - and number of dropped calls gets way worse.

You’re not over-thinking this at all! I’d send that BT stack code to Phonak Tech Support and see if someone there can make head or tails of it. You deserve a working solution!

Question: Could the ComPilot be the issue? Try swapping in a new one. Also: try pairing your ComPilot with a totally different laptop and see if that device also refuses to “let go” of the Call Audio. It sure sounds like you’re close to troubleshooting the core issue.

Very intriguing problem to muddle through!