Bluetooth pairing difficulties


I wear both a cochlear implant on the Left and and a Resound HA on the Right. I woke this morning to find that my Resound hearing aid was no longer connecting to my iphone. I was previously using BT connectivity to both my cochlear on the Left and Resound HA on the right without any issues.

I go to: General settings -> accessibility -> MFi Hearing Devices to attempt to re-establish my link.

However, when I attempted to reconnect Resound HA to iphone the option to select device to pair never comes up (it only shows the cochlear L). I tried doing the “forget this device” option for the cochlear and following this both hearing devices will show up with the option to pair a device and I was able to pair to each individually so I know that both devices are still capable of pairing. However, the problem is I can no longer pair to both at the same time any longer.

There were no updates to the phone overnight or any other changes. I have spent over two hours today trying to re-establish normalcy and have tried turn off/on, reboot iphone etc without success. I’m a little frustrated as I need both sides to understand people on the phone. Any suggestions? What’s next?



When I called ReSound awhile ago while having connection issues–the App kept losing an ear and sometimes not pairing at all, part of the protocol of resetting the network connection and re-pairing the devices was to open the Smart 3d App and TURN OFF “optimize MFI connection” (which my audiologist had turned on). Maybe check that that’s off?



Interestingly that was already turned off.

Just tried the reset network settings as well to no avail.

Am really baffled because this was never an issue before.



If you haven’t already done so I suggest you re-boot the iPhone. It has helped me to do so on occasions. c!



You say you are using bluetooth to connect to both devices, but then you refer to mfi settings. They aren’t the same. Is there a bluetooth device on the phone in addition to the MFI device? If so, try deleting both of them and see if that will let you re-pair. Maybe you will need to get the HA reset by the audiologist.



Well Bluetooth has to be “on” but you use the MFi (made for iPhone) to establish the pairing.

No other Bluetooth devices are paired with the phone.

Trying to get ahold of audiologist but no luck so far. Problematic getting ahold of anyone as I can’t use the phone without both devices streaming the phone call.

Really don’t understand it, was never an issue before.



Try pairing the devices with another phone to see if the problem is with the devices or with your phone. If you can’t talk to the audiologist over the phone, then go in person or use email.




I went to see both my cochlear audiologist at an academic center and my local audiologist who managed by hearing aids prior to being implanted 1.5 years ago. Nobody can figure out why it will no longer pair binaurally.

Academic audiologist spoke to both Resound and Cochlear who both passed the ball to each other with Cochlear stating that my current Enzo 5 squared isn’t even compatible with allowing pairing of phone to both hearing devices.

Subsequently the same day I saw community audiologist who spoke to Resound and got the same answer from them that I would have to upgrade to the Enzo 3D line as my current aid doesn’t support that feature.

Well how has it been working for the last 18 months with no difficulty whatsoever??? I am so frustrated, now I’m supposed to shell out 2500-4000 dollars to resume a feature I previously had…



Since Apple updated AirPlay the iPhone has had weak connections to the MFI hearing aids. Apple has been tweaking AirPlay since last year and the results are foobar for MFI hearing aids.

My Oticon’s lose the connection overnight. The solution is to open and close the battery door. Another sometimes fix is to play Apple Music app to make the connection.

I often see this message



YE GODS! Avenable, you have my utmost empathy for this incredibly frustrating reality you are working through. It’s yet another example of companies that sell PRODUCT and not SOLUTION - especially anything critical like one’s ability to hear on a phone.

In the interim, could you use either an older technology - like a streaming necklace or clip-on device? The other idea is to get a pair of headphones that are iPhone compatible and - granted it is a CLUDGE! - wear them on phone calls?

I have a pair of Sennheiser headphones that I bought at Amazon which are compatible with Android devices. The headphones have an ON/OFF switch and volume control on the cord (located up near my chin area). In the OLD days, when I had Oticon Opn miniRITE aids, there was NO device to stream with Android. So I bought the headphones, and was able to get audio in both ears.

I sure hope there is some kind of Black Magic that restores what you had working for 18 months before this odd issue arose. It does seem as if the problem is likely on Apple’s side. That is far more likely to have the idiotic, endless upgrades that have now destroyed your ability to use the iPhone.

Also ask if your aids would stream to an Android phone? In the WORSE case, you may want to jump to the other side of the fence and start all over with Android instead of Apple. BEST OF LUCK to you! Keep us posted.

(FYI: I have a similar situation going on with my Phonak aids: unable to pair both the Marvels AND my older Audeo B-Direct aids to my Samsung Galaxy at the same time. But at least ONE pair of aids pairs up to enable streaming phone calls.)



Do you have your Audio Routing for Call and Media set to Automatic? Don’t you shut your hearing aids and phone off at night? Mine reconnects every morning. Turn on the phone first and the HA’s second.



I never turn my iPhone or hearing aids off. The MFI thing worked perfectly, except of course not with the Apple Watch, until the latest iteration of IOS. Now it’s a mess.

It always helps to play something from Music first, wait for the screen illustrated above, and cross my fingers.

Apple is not paying attention to MFI and will eventually lose our to the new Android devices. Unfortunate for we who are invested in MFI.



The Apple Watch doesn’t have MFI at all. I do connect my OPN1s to the watch by way of the connect clip



I have to admit that is one of my pet peeves. I turn my computer, phone, and now hearing aids totally off when I am sleeping. I guess to balance things out a little for the power company, I do turn my CPAP on during sleep.

But, my thinking is that these devices need a rest, just like I do. And, perhaps a bit beyond that, it is not about saving electrical power. It is about my power over these devices. I like to remind these things, that I am the one with the power, and they are not. That said one of my irritations with the iPhone is that if you turn it off, and then plug it in to charge, it turns itself back on again. How devious of Apple. But, they underestimate the resistance of those who are not Apple slaves. I plug it into the charger first, and then turn the darn thing off!



Considering how expensive these things are, when you figure out how much of their long-term battery lifespan that you’re going to burn by having them on for no good reason while you’re sleeping, unless you’re on call for some reason, it does pay to turn them off and to turn off Wi-Fi, BT, and cellular data when you don’t absolutely need them (unless you’re on Instagram and Facebook all day!). We have a home landline and a computer or two is almost always on somewhere - and I do all transactions by e-mail, not texting, since it’s more conducive to archiving and searching, etc. I also found with a couple of early versions of Microsoft’s idea of an Always Connected PC that Microsoft did not have its power management act together and while you thought the device was just idling on the lowest power standby, it had decided to connect to the Internet and got stuck in some endless power-consuming fiasco. So after finding the Li-ion batteries on a couple of $1,000++ devices completely drained a number of times (not good for long-term Li-ion battery life), I said to heck with Connected Standby, I’m turning stuff that I’m not going to use for a good while off. Li-ion batteries even in an OFF device will sometimes drain as much as a few percent per month. So even old devices that I’m keeping as a potential backup, I have a regular every few month schedule of checking what’s going on with the battery and making sure it hasn’t self-drained (I lengthen or shorten the checking schedule based on my experience with the device in storage).

Don’t know about Apple, but I have also had the experience with app developers going over to the Dark Side on Android. Back around 2011, I really liked the battery monitoring app Battery Widget+ by Elvison-it was probably the most highly rated battery app at the time. But as time and updates rolled by, the developer decided to introduce ads, requested all sorts of unnecessary permissions, and the app got a bit out of hand. When I recently revived my 2011 Galaxy Nexus as a podcast player (again, why burn battery on a $1,000 phone for that when an over-the-hill old Android phone in your pocket works just as well?), I discovered, “Whoa!? Who turned on the Wi-FI when I wasn’t looking?!!” Turns out one of the permissions I had granted Battery Widget+ during an update was total control of Wi-Fi behavior. So hopefully given all the positive press, you can probably trust your iPhone a lot more while you’re sleeping but at least with an Android phone, you might want to check what’s been happening to your permissions with your updates and what your phone is doing from time to time when you leave it alone. Oh, yeah, I checked. Battery Widget+ is long-gone from the Google Play Store, too.



I was only describing my habits. My wife’s are totally different. She believes in leaving her Android phone, tablet, and laptop turned on all the time. They stay that way until the battery is dead, and then she complains profusely that the battery is no good! With the phone that she loses regularly she banks on it having enough charge to be able to call it to find it!

1 Like


I can understand turning of your hearing aids, but there is no reason to turn off your computer or your phone. In particular, the computer does things while you’re not using it, such as updating, virus / malware checks and disk defragmenting. They don’t need a rest.



Until the world is entirely running on renewable energy, there is quite an environmental cost of just consuming electricity in case your computer wants to do something. Quite a cost just to leaving a power adapter plugged in (even though it’s not running or charging anything). Yeah, power adapters can have an Energy Star rating or whatever they give adapters but the sum total of billions of them is a lot of power not doing anything but idling (so I have mine on a switchable power strip or unplug them when not using them). Most modern computers are powerful enough to do what they have to do while you’re using them without you noticing - and most really modern computers use SSD’s, which are trimmed but not defragmented (would cause unnecessary wear if done and have little or no effect on performance-trimming takes no time of consequence).

There is a famous story of keylogging done at Kinko’s (a nationwide copy/computer center bought by FedEx) several decades ago that was discovered by a guy who left his laptop on at home while he sat down to watch a movie, noticed in the dark that his laptop screen had come on by itself and the mouse cursor was now moving across the screen all on its own, inspecting his file system, looking for good stuff. So in ways besides battery drain, it pays to pay attention to what goes on with your computer besides stuff caused by your very own keystrokes!



It is hard to get an accurate estimate but world consumption of electrical energy by computing devices is probably in the 15-20% range. It is expected to grow rapidly as the internet of things (which are never turned off) grows.

1 Like