Audibel AI (Starkey) & Thrive App & Remote Microphone+ Android Issues

Hello everyone,

New forum user here, I found this community because it seems to be the only place to get answers on niche questions related to hearing loss/aids and the tools we use.

I have a pair of Audibel AI hearing aids, which is under the Starkey umbrella, and I have recently purchased the Remote Mic+ as I work from home and want to be able to stream the zoom meetings from my laptop directly to my hearing aids (it was uncomfortable always putting on a headset over my ITC HA.

I have a google Pixel 6 pro with Android 13, and while I can get the zoom streaming to work, unfortunately there are certain interactions with my phone that drops the streaming - forcing me to go back into the Thrive app and restart it. This includes:

  • Locking the screen by turning off display with the “off” button on the side
  • Interacting with the lock screen after the display idles off (idling display off DOES NOT drop streaming)
  • Opening the settings app/menu
  • Opening any app in general - after I start streaming in Thrive app, I can exit to home screen just fine, but the moment I open ANY app it stops streaming.

I can’t figure out what it is, but it seems like most interactions with the phone interrupt streaming, which is incredibly frustrating as I do find myself interacting with the phone during zoom meetings.

Additionally, I see this interference with general HA operation, not just the Remote Mic+. If I try to use the Thrive “auto streaming” feature, where it automatically selects the preferred memory/program while streaming (ex: when on Phone, use Stream Boost, otherwise switch back) I’ve noticed that interacting with the phone continually triggers the memory setting to change. The result is noticeable static noise shifts as it auto-adjusts back and forth just because I’m scrolling on my phone.

There seems to be some Android issue running in the background, or some permission issue, or something software related interfering with the HA operation. Has any Andriod user experienced this or has a solution? My audiologist has no clue - he says I should just switch to iPhone because it simply has better compatibility and accessibility support in general. I have NOT tried a factory reset yet which I’m leaning towards finally doing.



Just tested another thing that causes the stream to drop:

When the display idles off, and streaming continues, it drops when I get an email notification. WHAAT.

Wow not good at all, very frustrating I’m sure, it does seem to be an android settings issue by the sounds of it, like try turning all notifications off to see if that helps,is there a setting in Apps to stop App interaction?

I disabled notifications ACROSS the board but no change.

Interestingly, when I put the phone in Do Not Disturb mode the problem goes away and I can interact as much as I want! Ok I’m on to something, going to figure out what DnD mode does behind the scenes to try to pinpoint the culprit. I have so many apps that I might just need a factory reset anyway.

Clarification: with Do No Disturb i can open apps now, but streaming continues to drop with lock screen interaction and manually shutting off display.

Oof. How frustrating! I hope you can figure it out and share the miracle fix! What if “lockscreen interaction” is somehow requiring you to either enter a password or hit a button to UNlock the screen?

Or … considering Android 13 is so essential for optimal HA streaming … is there anything else your aids are paired + connected to that’s interfering with a seamless connection? Or for that matter, any other device paired + connected to the phone that’s overriding some functionality?

Is your phone going to sleep somehow, and maybe that’s dropping the connection?

Myriad avenues to explore, maybe even multi-factorial.

Great Looks like your getting somewhere, what settings do you have under “lock screen” could be something there, locking the screen shouldn’t stop the streaming, maybe sleeping apps function? Look under device care/battery to see what settings you can try.

Yeah I was thinking just that, could be worth looking into.

Ok so with Do Not Disturb mode, the following actions drop streaming:

  • Shutting display off manually with side button.
  • After display idles off (doesn’t drop stream), activating the screen to prompt the lockscreen.
  • After display idles off, getting an outlook email notification

I went into Battery settings and disabled “Adaptive Battery”, which optimizes performance by reducing background activity. No impact.

I went into the Thrive App and gave it all permissions, and gave it unrestricted battery usage to ensure that it was permitted to run in the background. No impact.

At this point, besides attempting a factory reset, I can only think its one thing - which I haven’t mentioned yet as it just occurred to me. While this is a personal cell phone, I have also elect to use it as my work phone and so my company’s IT requires that I install an enterprise mobility management software called MobileIron. It’s like a firewall/VPN/security app that always runs in the background, and has special protocols for “work” apps vs non work apps. So email/calendar/file sharing/Zoom/etc anything related to work is subject to whatever MobileIron requires. The other thing that MobileIron does is it forces me to have a lockscreen, so in my eyes I’m essentially handing over background control of my phone to it. Maybe it’s this MobileIron app.

The only way to test it would be to factory reset and troubleshoot BEFORE installing it again as my IT dept would require it (and it would be the only way for me to get work email back on my phone).

Hoping someone has a fix I’m unaware of! Going to hold out for a bit until I begrudgingly do a factory reset.

Yeah that’s probably it I’ve never heard of MobileIron, but it does sound like it could be interfering, can you not uninstall MobileIron without having to do a factory reset, unfortunately I can’t think of anything else at this point.

That’s something I can try.

One thing to clarify- bluetooth connectivity to my phone media never falters, I always maintain connection and can stream phone calls, youtube videos, etc. It’s specifically anything I stream via the Mic+ (ex: Zoom from laptop) that drops with this phone interaction bug.

So if it is MobileIron, it’s only causing a problem with the Mic+, not normal hearing aid operation (aside from the weird auto stream behavior).

Very peculiar and frustrating. Hoping a factory reset will do it but will hold out for a bit.

Tried the Audibel ARK AI.
I remember the static if I scrolled, touched the screen.
Audi said it’s an Android thing.
I’d tell you to tell to your Audi but if they’re anything like mine they’ll have no clue.

Ok, thanks for the info - glad I have confirmation on it being an Android thing with scrolling as it drives me crazy. It essentially means I disable auto streaming feature which isn’t preferable as StreamBoost is excellent when you need it. I also use touch to enable Edge mode and that’s very handy.

Hope Android and/or Audible comes up with a fix.

Still holding out of factory reset with the Mic+ calls dropping, maybe someone will drop by with some info.