SurfLink Mobile White screen error

I need any support, My SurfLink screen is suddenly turned white. the device functions are working, I can touch, unlock screen, click on the streamer, but without seeing any thing, just from my memory.

I tries the advice of clicking the power button for 30 seconds, then after 10 seconds, power on, I repeated these steps for a 2 days, but not success.

As I’m in Egypt, and check and maintenance is done only in USA, which means that the hearing professional center here will send the device to USA to check this bug, this will consume hug time, and will charge me all the expenses of charging.
attached the photo of the screen

If the screen is LCD it could be the sun that is doing this. I seems to be burning the screen. I am just guessing here.

Best guess, Turn unit off then press and hold power till brightness adjustment shows and adjust from there. On some units if the brightness is turned down all the way you will see nothing on the screen.

Yes that sounds even better.

Thank you all for your reply.
but unfortunatell still not helping
this is not related of Sun effect. and the screen is not LCD but it’s TFT, see this image


Another thing, the Idea of changing the brightness setting is good idea, although I didn’t see any thing, but I tried to click on the screens and imagine the follow as I didn’t see any thing, I success to reach it, tried to change this setting, but it’s not changed any thing.
this image may give you impression how is the problem.

Mine just started doing this today. I was streaming audio at my work desk and went to turn it off. It was locked up and so I pressed the on/off button for 30 or so seconds. Now it just turns on white. I can see it sync to my phone after power up. No screen.

Sounds like a possible hardware failure. I think you need to consult your provider.

Does the Starkey app still show it is connected?

Hi KenP,

I just look at the blue tooth icon on my phone and see that it has synced. The only thing I sync my phone with is the Surflink Mobile.

It does seem like a hardware malfunction. If it is turned off for a while I can turn it on and see the menus for long enough to get everything streaming, then the screen whites out. I’ve also found that I can navigate the blank screen from memory.

The Surflink works, the touch screen works, the LCD screen does not work.

Thanks,
Dave

1 Like

Sounding more like a heat related problem like a capacitor failing.

Opened it up and re-seated the display ribbon cable. There were no electrolytic caps, not even small surface mount. I’m guessing any larger filter caps will be tantalum, which are problematic when they age (short), or large value ceramic, which are fragile.

I’m working with the intermittent Surflink at the moment. It works for a while, locks up, has no display, works…

I’m figuring out how to press the screen to navigate through the menus.

I’ve gotten pretty good at using the Surflink ‘blind’ pressing the keys from memory.

I left my Surflink in the car overnight. At 13 degrees F, the screen worked great.

I tried to adjust the brightness up and down, all that yielded was a brighter and darker white screen.

Was this issue ever fixed? This just happened to me. Until I read this, however, I was unaware that the surflink was actually working, and that if I could remember the screens I could still use it. Good to know!! However, I’d much prefer for the screen to actually work.
If it worked at 13 degrees, perhaps putting it in the refrigerator would get it to work?
I’ll try it and let you know.
Thanks

I sent it to Starkey HQ via their partner, it has been fixed totally, like a refurbishing device.
it was the best solution to me instead of buying a new one.

Thanks. My device is no longer under warranty, and it would cost me several hundred dollars to get it fixed. Your refrigerator trick worked for a short time, though, so I’ll keep it in the fridge and if I ever really need it, I will be able to use it at least for a few minutes.
Thanks!
CJ

Mine too wasn’t under warranty. It costed me only $200.

If I really needed it, I would pay for it, but truth is I haven’t even turned it on for months. The way I used to use it the most (watching movies on my phone without bothering other people) can just as easily be done with regular earphones if necessary, and I don’t use it often enough to warrant the expense. But thanks, in any case, for the information.
CJ

It’s been almost six months, so I thought I would come back and do an update. I just recently contacted Starkey to see if they can give me any hints to solve this problem without having to replace the whole device.
In the meantime, I’ve found that if I put the device in the freezer, I get several hours of clear-screen time before the screen goes blank again. (The refrigerator was only giving me about 15 minutes, which was sometimes not even enough to get the surflink to pair with my phone. The other problem is that I seem to need to pair it each time. It doesn’t remember the pairing [or rather, it does remember the pairing but won’t connect, so I have to painstakingly delete the pairing on both the phone and the device and then reboot both, and then pair again. THEN it works just fine.])
In any case, Thanks! Radio_davio for giving me the idea to put it in the freezer.
Regards
CJ Rhoads