Surflink Mobile 2 constantly rebooting


#1

Surflink Mobile 2 just started in a continuous reboot sequence. Can’t shut it off or do anything with it. Doesn’t charge, won’t connect to PC to run updater. Any ideas how to break this cycle? Or, is it toast?


#2

Have you tried holding the power button down for 30 seconds, or more?

Is it still under warranty?


#3

Out of warranty. Tried power button-no luck. Since it does not have a replaceable battery, thought I would “crack” the case to see if I could locate and pull battery that way. As soon as I “cracked” the case on the power button end, it started working correctly. Am unable to reclose the case on that end. Suspect something internal has swelled and was creating the problem, but I’m not going to pull the rest of the was apart since it is now working. Don’t anticipate ever getting it in water, so will leave it as is. Hopefully it will last until I can convince the VA to get me a new set up.
Thanks for your reply.


#4

Hi Dale,

I’ve had my old one apart several times. Peeling back the sticker on the back (warm it up and do it slowly if you want to stick it back), you’ll find two screws. Once the screws are removed, the top pulls away and the bottom has two tabs near each corner. Sort of a clam shell kind of thing.

What do you use your Mobile for?

I have seen batteries for the original Surflink on eBay. I’m pretty sure these will work for Surflink 2 (only not stay charged as long.

You can also find cables that allow you to charge and stream the Surflink Mobiles, Google “Surflink Charge and Stream” and they come right up.

Good luck,
db