Some tip after OPN new firmware update

I had my OPN’s updated with the new firmware last night. I ran into some issue with the Android version of the Oticon ON app that took a while for me to resolve so I thought I’d make a post here to share, to save somebody time in case they run into the same issue as I did after they have a firmware update.

Basically after the firmware update, for some reason my right OPN can connect to the ON app, but the left one can’t. I uninstalled and reinstalled the app but it didn’t help. I was able to connect to the right OPN but not the left one still. Tried many different things like new batteries, restart the phone, reboot the OPNs several times, etc. The baffling part is that it could connect to one HA, just not the other.

Finally I went into the Bluetooth setting and unpaired the 2 OPN device icons on my Bluetooth paired list. This finally seems to do the trick. Hope this tip helps save somebody a lot of aggravation that I went through. It wasn’t an obvious thing for me to do at the time.

^^^ Ye GODS. I thought this ON app was a no-brainer! I doubt I would’ve been able to trouble-shoot this all the way through as you have done. Thanks for the info - good to refer back to. But I still hope I can bypass that app and just stumble along with my index finger, the button on my aids and … LUCK.

Question: how did you know you needed the firmware update? Are you notified by anyone to do this from time to time?

I heard about it here on this forum. I then asked my audi and she asked Oticon and they didn’t have it available for her until only recently.

As to whether I really needed this firmware update to fix up any particular issue I have or not, I’ve noticed random reboots on my OPNs that I hope this new firmware update will fix, but other than that I probably don’t have any other reasons for needing the update except to have the latest version which is supposed to be better.

Also, Um Bongo (a poster on this forum who’s a dispenser and had fitted several patients with the OPNs) mentioned in one of the threads that this is a “massive” firmware update (although no specifics were given), so I figured I would want to get the update anyway to save a lot of aggravations in case I happen to run into any issue that this update is supposed to have resolved.

Just had mine adjusted and now the left aid will no longer pair. Buyhear said they need to do a firmware update and will send me a demo set of OPNs for now. I tried all these steps you listed and no luck.

Just want some clarification here. Are you saying that the left HA no longer pairs and connect with your Android phone in the Android Oticon On app? Or are you saying it no longer pairs with the right HA (which is a more serious issue).

Also just to clarify, in my situation the issue of the left HA not connected to the Android phone via the ON app only happened AFTER I had the firmware update. Previous adjustments didn’t affect it.

Anyway, it seems like unpairing and re-pairing the HA to the ON app worked to fix my issue. Unpairing here means you have to go the the Bluetooth setting in your Android setting, select the 2 icons representing the left and right HAs, and select “Unpair” to remove them from the Bluetooth paired devices list. Then you gotta scan and repair them again via the On app.

I have an iPhone. I unpaired them from the phone, but now only one aid at a time will pair to the phone. So I can use both aids, but I can only stream calls and media to one aid. Apparently it’s a known issue and the firmware update is supposed to fix it. Kind of annoying bc after my last adjustment they are sounding better. I had a noisy Christmas Eve party today in poor acoustics and made out pretty good. Not perfect, but my expectations are more tempered now.

I see. Hopefully the firmware upgrade will fix your issue.

One little annoying thing is that after my firmware update, when I switch in between program modes, there’s a short feedback screech on my right HA (the one for the worse ear) for a split second, but it goes away immediately. But still annoying enough for me. If you encounter such an issue, I’d like to hear about to compare notes. This never happened to me before the firmware upgrade.

That is the feed back control kicking in when it encounters feedback. You might try a different dome size or go with a mold.

Yeah, I know, but what I’m saying is that it didn’t happen before the firmware update and now it does. Changing yet to another dome size or a mold to mess around just because of a firmware update causing an minor issue is a little drastic to me. I’m pretty sure I already have the right size dome or I would have had feedback issue before the firmware update, too.

I think I’ll just have my audi rerun the feedback control setup again next time I see her. I hope that whatever got shifted a little due to the firmware updated will be remedied by rerunning the feedback control. It’ll be easy enough to verify anyway.

^^^ I hope your aud-gal will report this blip to Oticon. Now that I know of the upgrade available, it’s on my list of things to ask for when I get in to see my aud-guy next week.

Having lived with an occasionally squeaky hard plastic mold on my Oticon Agil Pros for many years, I can SO empathize. Any kind of “nails-on-chalkboard” screech (however brief!) are just irksome. That is actually half the reason I’m pursuing BTE aids (or RIEs if you will) and the softer domes for better seal. You will hopefully fix this with a re-calibration of the feedback mgt? Good luck!

Seems like the autophone being turned on is what triggered the issue. The firmware update should address this.

^^^ How did you deduce that it was the Autophone mode being enabled that triggered the issue? Volusiano had Autophone enabled a while back, and it seemed to me that it was more a function of the firmware upgrade causing the latest issues with feedback. I’d really like to know what’s causing it, cuz I’m due to return to my aud-guy next week and: 1.) have him enable Autophone (just want to see if it works with ALL phones) and 2.) ask for that same firmware upgrade … as I’ve been in trial with these Opns for 60 days now. (and geez, is my aud-guy a SAINT when it comes to trials.)

I have the exact question for Abarsanti as 1Bluejay does.

  1. Why do you think AutoPhone is the cause of the short feedback when changing program? I had Autophone enabled already BEFORE the firmware update and I didn’t have that feedback issue until AFTER the firmware update.

  2. Also would like to know why you think the firmware update should address this issue? It was after the firmware update that the issue surfaced for me. So in my case the firmware update didn’t address the issue, nor did it exist before the firmware update.

At my last adjustment, I requested that the autophone feature be turned on along with some other tweaks. After the adjustment, I started having pairing issues with my iPhone. I could only connect 1 aid and thus streaming only came in to 1 ear. I went through a bunch of steps to try to unpair and re-pair the aids, but nothing worked. Finally, I was told that the aids needed to have the firmware updated to the most recent version to correct the pairing issue. I then asked the fitter to try turning off the autophone and see if that would allow both aids to again be paired with my iPhone. As soon as the autophone feature was turned off, the aids now both pair back to my iPhone. The fitter thinks that the new firmware update specifically addresses some pairing issues with iPhone so they are still going to update the firmware for me and hopefully then the autophone feature can be turned back on without any pairing issues.

OK, I see. But it seems like we’re talking about different things here.

1Bluejay and I were talking about the short feedback screech I experienced after the new firmware update.

You’re talking about your pairing issue you experienced with your iPhone due to enabling Autophone that you hope will be fixed by the new firmware update.

Two completely different things.

Yes, 2 different things. I have not experienced any feedback issues with the OPNs.

Well, adding my own 2-cents’ worth today! I got in a week EARLY to see my aud-guy today - hallelujia! So I was able to get a bunch of stuff taken care of. First off, to my surprise, the AutoPhone was already ENABLED! I guess I have not had to use a phone (telecoil?) that triggered it yet, cuz I had NO idea it was even set for ON. Now that I know that, we’ll see if it’s ever triggered.

On top of that, I decided to have a dedicated phone program set up once again. I’d done this over a month ago, and could not hear any better in that program than default Program 1 on the phone - BUT! That was when I had too-loose Widex tulip domes on my aids. With the present Widex power domes (size L in left ear, M in right), I hear quite well on all phones. However, after my aud-guy set up a program with more GAIN in the left ear (and muted the volume in the right ear for that program), I found that I could hear even better on the phone! NOTE: My test call is always to call Anthem insurance. Y’never get a human being there, anyway, just hours of robo-recording - so it’s even better than dialing the weather station in terms of non-stop monotonic VOICE to test out your aids. OK, this is good. I’ll try using Program 3 for the phone now.

The minute my aud-guy paired up my aids to the Genie sw, a prompt popped up in the corner of his screen saying “Firmware upgrade now available” - so, to my delight, that was also done today! I’d already told my aud-guy that I first learned HERE about that upgrade, but it appears that he also gets notices from Oticon.

Right now, with both AutoPhone enabled and the firmware upgrade done, I have NO ISSUES! Now did I just jinx that? I’ll find out when I watch TV tonight, cuz I also had him remove my old TV program - apparently he’d thought I needed to have one dedicated to the streamer when in fact, the TV streamer automatically kicks in once your aids are paired with it.

YEAH. LIFE IS GOOD! :slight_smile:

Great to hear. For the autophone, I had it activated for about a week before we deactivated it. I had to put the phone ear piece literally on the aid to activate it. It worked for my business phone as well as my iPhone and CaptionCall phone. You hear a chime when it turns on.

The Autophone will override whatever mode you’re in and automatically take you to the OPN phone mode when/if it detects the magnet on the phone handset or headset that you put over the HA. So if you have both a special dedicated phone program and the Autophone coexisting together, as long as you use something that doesn’t trigger the Autophone then it’s OK and you’ll get your dedicated signal. But if you uses something that triggers Autophone but you want to use the dedicated special phone program, you won’t be able to. I may be stating the obvious here and you already know this potential conflict.

It’d be interesting to see how you like the Autophone (if you can ever find something that triggers it) compared to your dedicated phone program. Did your audi tell you what he did to set up the dedicated phone program for you? I’m curious to know how it’s set up differently compared to the normal default program.

Glad to get confirmation from others that Autophone works for them like it works for me, too. Too bad it messed up your iPhone pairing. Hopefully the new firmware update will fix it for you.