Questions about Phonak apps

Made for iPhone (MFi) hearing aids offer a little more control of things, but Phonak does not use MFi to my knowledge. Even with a MFi hearing aid, I am not sure they could do what you ask, although I don’t believe they use the hearing aid microphones, and always use the microphone on the phone.

I think a made for iPhone hearing aid would solve OP’s issue if I’m correct that issue is using the hearing aid microphones for dictation. I don’t think an iPhone would “care” if hearing aids were connected or not when doing dictation.

Yes you are correct in that the hearing aid microphones are not nearly as good at picking up dictation as is the phone’s microphone. If it weren’t so infuriating it would be comical how the text is miscommunicated when I try and send one while the HAs are connected to the phone.

But getting different HAs is out of the question at this point. So I’ll have to live with this limitation for the next 5 years or so. Too bad because it makes the Bluetooth functionality all but useless for me when at work. And I have little reason to use it at home.

Sorry it turned out this way. I’m going to take this an opportunity to remind people that if hearing aids and phones behaving in certain ways is key to you, investigate thoroughly before purchasing and verify before your trial period ends. This stuff is not intuitive and very few providers are really knowledgeable about how they work.

3 Likes

I have a recollection of seeing a post here about one user defeating the hearing aid microphone feature on a Marvel or KS9 when streaming. There are so many posts about it, I don’t recall where it was.

1 Like

Thanks for that. I cannot find any way to accomplish this. Maybe in the software that the Audi uses.

I did just realize on my iPhone XR when I’m getting ready to dictate a text I can touch the upper right part of the screen and drag down the options and disable Bluetooth. Then when I’m done touch and drag again and reenable it.

Problem with that is the HAs don’t seem to re-pair. Unless I go into Bluetooth options and manually disconnect there then reconnect. Too bad. If only they would auto connect again that would be a very viable workaround. I will keep playing with it.

The Marvel 2.0 firmware update for your M70’s will allow connections with more than one device without the need to un-pair and re-pair. Your audiologist can update your M70’s to the 2.0 firmware.

1 Like

Good to know. Thanks. Looks like I need to visit my Audi.

The 2.0 firmware update for your M70’s will also add a bunch of new features and controls to the myPhonak app! You’ll love it!

1 Like

I just found out something about the app/HA interaction that others may find useful. A while ago I reported that when I changed a program on the MyPhonak app to the Restaurant program, as soon as the phone shut off it would revert to Autosense. Others reported it did not work this way for them, that the program setting was “sticky”. The Phonak support rep said the same thing.

Talking to the Phonak support rep, I finally figured out what the problem was. Since I had the BT set up to stream both audio and phone calls to the HA, the phone was making a “click” when it turned off or turned on. This switched the HA over to the streaming audio program, and then back to Autosense.

So now I have gone into the BT setup on the phone, and switched off audio streaming to the HA (leaving phone call streaming turned on so I can answer phone calls). This way I can use the phone without interrupting TV listening or any custom programs I have set up. If I want to stream music from the phone to the HA, I can go to the BT settings for the HA and switch audio streaming back on.

1 Like

Haggis,
That’s very interesting indeed.
Mine behaves the way I would expect and the way others have reported.
I’m wondering if there is some kind of difference with the make/model of phone or the provider.

My phone is an Android Google Pixel 3 XL.
My provider is Google Fi.

What are you using?

Samsung Galaxy Note 10+, Android 9.0, T-Mobile.

Are you implying that you don’t have to turn off streaming audio to get the program change to stay? Does your phone play sounds (app opening click, button click, keyboard tapping sounds) through your HA’s?

One of our differences is that I’m running the latest Android 10 instead of Android 9. Although I’m confident that wouldn’t make a difference in Marvel 2.0 streaming behavior.

No, I do not have to turn off streaming audio to get the program change to stay. When I’m streaming audio I can also hear background noises. Streaming audio isn’t noise cancelling like a noise cancelling headphone would be.

Gary,
I know you know this but for newcomers I think It should be pointed out that using the remote function you can essentially shut off the microphones while streaming music which does provide some “noise cancelling” effect. I do this quite often when I’m working out in the gym and want to remove outside noise from other’s conversations or equipment banging, etc. It doesn’t do as much noise cancellation as my Bose Headphones, but it idoes cut down the “outside” noise considerably.

1 Like

Sorry, Gary, I don’t understand this. Streaming audio activates its own program. Sure, you can go into the app while streaming, change whatever it’ll let you change (like volume I guess). But you shouldn’t be able to change programs “and have it stay” because as soon as you exit you’d be streaming audio again.

I’m not understanding you either. OK. If I decide to open my Primephonic app, I can click on any piece of music I want and it will begin to stream to my Marvels. If I look in myPhonak app I can see that the program currently being used is “Bluetooth streaming + mic 1”.

I can choose to stop streaming my choice of music in the Primephonic app and streaming stops. The “Bluetooth streaming + mic 1” app no longer exists in my list of apps.

I can also choose a different program in the myPhonak app and the streaming also stops. Again the “Bluetooth streaming + mic 1” app no longer exists in my list of apps.

The Android operating system will continue to stream my music no matter what other Android apps I decide to use on my Android phone. Streaming continues until I either stop the musical selection in Primephonic or until I stop or restart the Android OS. This is the way music streaming has always worked with any Bluetooth device I’ve ever used.

This the behavior that I would expect to have happen.

Am I missing something?

All that makes sense. What I was referring to was:

I tried to select the “restaurant” program via MyPhonak app in a restaurant. The audio changed. As soon as the phone shut off, the audio changed back. When I turned on the phone again, it was on “Autosense 3.0”.

I could not get the HA’s to stay on the “Restaurant” program that I selected in the MyPhonak app.

To get it to work, I didn’t “turn off streaming audio” in the sense of stopping an audio program going. What I said was:

This way, none of the clicks of the phone switching on and off go to the HA. So now when I select a program (like “Restaurant”) on the MyPhonak app, the phone doesn’t try to stream the click of the phone shutting off to the HA, so the HA doesn’t switch to the streaming audio program to play the click, so the HA doesn’t swtich off the Restaurant program.

Aha! My apologies for being dense! :confused:
My Marvels are in their charging case.
I’ll give this a go tomorrow when I put the Marvels back in again.
I think you will actually have to create a new restaurant program and save it in order for it to not go away. That’s what I remember from watching one of Dr. Cliff’s videos.
I think the restaurant program you are trying to do something with is actually part of the AutoSense OS 3.0 and you can do things with it but it will go away as soon as you leave it.
Does that make any sense?

1 Like

Well, it doesn’t go away any more after I shut off the audio streaming in the Bluetooth setup.

Perhaps there’s another way to shut off phone sounds so they don’t start to stream when the phone turns on or off. But short of that, streaming audio from the phone will switch the Marvels off the restaurant program.

But so your comment made me think. So I was playing around with it, and I set it to my audi-created custom speech in noise program (with the down button on my marvel). Made the phone click, and the program switched to BT Streaming. But then after a couple of seconds, instead of switching back to Autosense the way it did when I was on the Restaurant program, it switched back to the special Speech in Noise program that I had set.

So somehow that Restaurant program isn’t as sticky as my custom Speech in Noise program.

Dr. Cliff’s comment about a program going away without saving was about it disappearing from the app completely. I think. But I’ll try a custom program this way.

OK, tried it. Strangely, when I switch to my first custom program “John’s Test”, it makes a single chime like I switched to the first audi program with my down button, my custom Speech in Noise. But the app says I’m on my “John’s Test”. Then when I make the phone make a click, it switches to the BT Streaming program for a couple of seconds, and then switches back, but goes to the custom audi Speech in Noise.

So the “extra” programs Restaurant and Music both revert to Autosense after momentary switches to BT Streaming from phone sounds, but a custom saved program reverts to my first audi custom program after momentary switches to BT Streaming.

I think this is a clear bug. If you can corroborate it when you get a chance, I’d appreciate it.

To get the phone to make a sound, I just clicked into the My Phonak custom settings (bottom right settings icon) for a moment, and used the phones “back” virtual button to switch back to the main screen, which makes the click. If you want to reproduce it, make sure you have everything turned on under “System sounds and vibration” in your Android settings. Maybe you just need the first one, “Touch sound”, but I have all of them under that heading turned on.

1 Like

Reviving this important thread. It helped me understand why the program chosen in my iPhone (SE with 15.6.1) did not “stick”; closing the phone made the HA revert to automatic. I was thinking of throwing the Phonaks away. It was enough to disable the sound at closing in the phone!