Problem with bluetooth on Phonak P90 hearing aids

I just got brand new Phonak P90 hearing aids from the V.A. and the bluetooth works the opposite of what I expected. My previous B90s with the ComPilot would suppress the microphone when connected via bluetooth. That is the action I would expect. It was wonderful. Now note, the B90s did not do bluetooth. The ComPilot converted the bluetooth to telecoil input and telecoil input suppresses the microphone so one could, in the old days of telecoils, hear the phone and suppress the noise of the kids yelling in the background.

My new 2-day-old P0s don’t do that. The microphone input is a LOT louder when the bluetooth is active. Phonak was no help and would not even tell me if that was what is supposed to happen or not. When I called the VA, they said I would have to come in and see the audiologist to get an answer. Unfortunately, I will be out of town so I can’t see her until June 22nd. :disappointed: so I’m hoping to find if others are experiencing this issue. I need to decide whether to take the P90s or the backup B90s on my trip or even to return the P90s and ask them for a different type of hearing aid because the P90s don’t work as well.

When using the phone bluetooth or the TV one while also using a treadmill, I found the treadmill to be so loud as to partially drown out the sound from bluetooth. Moreover, if I turned off the bluetooth, the treadmill sound was significantly lower.

I then tried a test. I turned on bluetooth with my phone and played a song on it. I then started the treadmill and noticed the volume in my ears. Then I paused the song I was playing. The bluetooth remained active even though no sound was coming from the phone. That allowed me to more accurately pay attention to the treadmill which stayed just as loud. Then I stopped the song completely which caused the phone to disconnect and restore the microphone as the only input. It was lower in volume! Similarly, the TV did the same. That means the P90s are not only not suppressing microphone sound but enhancing it - an absolutely useless feature.

Now the question. Has anyone ever encountered this situation?

The audiolgist can change the amount of sounds you get from the microphone while streaming. It MIGHT even be possible from the app, but I do not know.

You have great aids. I owned B90 aids and Marvel aids. Used the Compilot 2 with the B90 aids. They were very nice but I learned more about the M90 aids like your P90 aids and fell in love with them. The Bluetooth issues you describe are totally adjustable. Some by the fitter and some by you.

When you are steaming anything try changing the volume on the hearing aids using the toggle on the aids. You will find it changes equally the ambient sound versus the Bluetooth streaming sound back and forth. Seems I remember the app on your phone changes only the Bluetooth volume but not sure.

Don’t give up on those aids. They just need to be set up like you like.

Yes, your audiologist can change its behavior to exactly what you want.

Meanwhile, You can turn the microphones off entirely yourself whilst streaming… just use myPhonak. Whilst in the Bluetooth streaming program ( you can see this at the top), you can then just touch the loudspeaker at the bottom left to turn the microphones off completely and just have the music.

Thanks for the replies. I haven’t even had a chance to download the app but when looking at information on it on the net (after searching for info on my problem with no luck), the instructions were very poor and the pictures were worse.

I’ll have to get the app.

As to the audiologist fixing it - well, why wouldn’t that be the default - lowered vs raised sound from the mikes?

Ah! The simplicity of the B90s was wonderful! On the other hand, even though the ComPilot was already paired to the TV, every time I turned on the TV, the only way to get them to connect would be to wait until the TV said they were paired and prompted me to connect, I would then have to shut off the ComPilot, wait until the red light stopped blinking and was completely off, then tell the TV to connect THEN turn the ComPilot back on. If I didn’t do that all in the proper sequence and wait for each action, the TV would say “failed to connect”. At least with the P90s, it almost always connects on the first try without any of that.

I hate using cellphone apps. Having retired as a computer and network security and privacy consultant, it is terrible what we surrender in the way of privacy to Google for the right to pay so much for their software. My guess is that even Phonak will want to steal my personal information.

1 Like

KS10s, but apparently very similar app and device - When I play music (via Amazon Music), open the app, and tap the icon in the lower right corner I get a slide bar to adjust balance between Surrounding and Audio. Is this what you are looking for?

Fred F

1 Like

If you don’t want to use the app:
As @Raudrive has already explained: Use the toogle switch of the HA.
The only downside: the ambient sound volume can’t be turned off completely.
But the HA can also be programmed so that the microphones are always completely off when streaming. However, the Audi has to do that for you at the next session.
I have chosen this solution, when streaming I do not want to have disturbing ambient noise.

@ffraley, Yes, that’s what I want. Thanks.

@sterei, actually, I don’t want to completely shut off the microphone. It would hurt too much - especially when she-who-must-be-obeyed finds out and she shoves the hearing aids fully into my ear. :grinning:

I do want to know what is happening around me. I will try that.

I just got a message from the V.A. I’ll see what they have to say.

1 Like

A couple of things. The VA audiologist said they need to adjust the hearing aids to fix the problem.

I tried the app. I can’t see any way to lower the microphone volume while keeping the bluetooth volume the same.

As to using the P90 buttons, that lowers both the bluetooth and the microphone volume equally so that’s no good.

When streaming and displaying the Bluetooth program clicking on the icon in bottom right allows you to adjust the balance between the stream and the microphones.

I have the tv connector and l only can increase or decrease the Bluetooth volume. However increasing the Bluetooth volume also increase the HA Mike volume so l have to turn off the HA microphone using the app. With the tv connector for example there is no option for comfort or clarity. I hope Phonak will fix this. The thing l don’t like about the tv connector is that the hearing aid chimes every time l change the tv channel.

That’s new to me. Never heard that before.
We have two tv connectors, KS9 and I used to have Phonak Marvel aids. Neither did that chime at channel change.

Is this what you want to do? You may have to go back and forth to get it just right. For me, it doesn’t show up unless I am actually streaming when I open it

I don’t get the chimes either. Two possibilities-

  1. Possibly a setting the Audi can change ( I doubt it though)
  2. TVs by different manufacturers and models work differently. Can quite see that changing channels might interrupt the audio stream from the TV. The TV connector can detect this and stop streaming and cause a chime. It might also cause a chime immediately after when the stream starts again?

Thankfully my TV does not do this. I only get one chime at all when the TV turns off. The connector is powered up all the time and just goes into idle mode when there is no signal. YMMV

Mine behave the same as Hooby’s, no chimes. Also think that the TV causes the chimes.
Is also new to me that the volume changes simultaneously for both, the streaming and mics.
Wonder what the audi can do about it.

Note: I changed my forum name

I don’t see that screen in my app under Remote Control. I’ll check it when I connect to my TV.

For each program there is a little icon at the bottom right of the screen that looks like three little horizontal sliders. It will bring up quite different things for each program that you are currently using.

In the case of the TV connector program it brings up the balance screen as @ffraley showed above where you can change the volume of the ambient sounds picked up by the microphones.

It is worth looking at what that icon gives you for Autosense and Music programs etc. if you make changes you like you can save them as a new program of your own. The idea is that when you next go to the Audiologist they will make these changes you prefer permanent for you.

1 Like

I had found those buttons the first time I looked at the app. In fact, I had saved my own settings as a test but there was no balance option showing when I did it.

Sure enough, when connected to the TV, a different choice came up for settings. That choice had the option to set the balance. It disappears when I am no longer connected.

While I was connected, it worked wonderfully. I saved the change to the balance but I’ll have to wait to see if the same selection name comes back (and hopefully with the changes) the next time I connect. Apparently, the app goes back to the default Autosense when you restart the program. Note, however, I had already removed my hearing aids and turned them off for the night so I’ll have to check again tomorrow.

That feature does allow me to properly inhibit the mike and will allow me to use the hearing aids on my trip albeit even if it is a little inconvenient to do something every time I want to see TV.

I have not yet tried to set the balance when the phone is connected to the hearing aids while calling someone.

Once you get the balance right for you and save it as a new program your Audi can make the changes permanent.

Also, the next version (5) of myPhonak is supposed to fix the problem of it resetting when you close the app. It is supposed to come out this Spring … so anytime soon with luck

I solved the noisy treadmill problem while using the My technician added a mute function to my
P 90’s by holding down the back button on either hearing aid. The t.v. sound comes through clearly and the background noise does not. It is not a program, just a hold until they mute. Great for naps too!
Jane Adler