Phonak introduces Marvel platform and Audéo M hearing aids

phonak

#668

Randeye - Hope you find a mold you’re comfortable with. I will say an acrylic mold will pretty much last the life of a hearing aid (maybe longer) where a silcone mold will age faster. Both though are the way to go with a serious hearing loss. So are you still in the pre trial testing stage and moved from the Resound Quantro to the Phonak Marvels? If so what was your reason to make the change? I’d really like to hear how you compare the Phonal Marvels to the Resound Quantro after you’ve had time to test both. And I do like the look of your Resound Quantro molds since the receiver is deep in the ear canal while the outer ear just show clear acrylic. Cool

Also let us know what price quotes you received for Resound vs Phonak. I assume both brands are pretty competitive price wise but then both are fairly new on the market. Thanks


#669

So I switched to closed domes. The music streaming has been upgraded from a 70s transistor radio sound to an 80s walkman sound, which isn’t that bad really, but not as good as my old Siemens were.

But the domes don’t stay put, they slide out constantly. So now I have to decide if I want custom molds just to get good streaming. I was surprised to find that the Marvel open domes stayed put, and I kind of liked not having the molds anymore.

Before I got my first aids 3 years ago, I never listened to music on my phone. Whenever I get a new phone I promptly lose the headphones. Not deliberately mind you, they just get lost. So listening to music through my aids was kind of a nice “extra,” but not a requirement. I did enjoy using it to tune out the noise at work sometimes.


#670

Yes, started with the Resound as they was to be “first” to market support for direct streaming to android (not delivered)

So, Did not happen with in my trial period. Updated my phone from a note to pixel 3 xl to ensure would have current android OS support for streaming. My AUD was told sometime in the spring with maybe a firmware update to HA’s and maybe phone OS with update to 3D app.

So now have Phonak Marvels THAT provides direct streaming and is the “FIRST” for MFA…

For me the Marvels sound better/fuller with the Autosense OS 3.0 and not needing to change to different programs. The Phonak remote app is not as nice to use as the Resound’s. Needing to search/reconnect every time for it to work. So Phonak remote app is a beta in work on bluetooth handshake/timing. Maybe with the February firmware update my iPhone XS will work (mic issues for phone calls)

Google pricing vary and is about what I payed…

  • Resound Quatro 9 61 rechargeable are around $4300.00 and up
  • Phonak Marvels Audeo M90-R are around $4600.00 and up

Local AUD at Hospital is charging over 6.4k


#671

so do you have an iPhone XS or an android? or both? I am between the Quattro’s and marvels, greatly value connectivity to my iPhone - seems Marvels may not be the best option for me (we’ll see what happens in Feb). However, at the end of the day streaming is secondary to hearing well and reliably. the Quattro’s so far are very good, except currently an issue with hearing my soft speaking wife in quiet environments… Currently in my trial period for Quattro’s and considering trialing the Marvels. My most important use is speech in loud noise (like an operating room with people wearing face masks)


#672

I strongly recommend you trial the Marvels if you are able to do so. I have been very pleased with the speech in loud noise capabilities and the hands free phone and music streaming from my iPhone are outstanding. Yes there are problems is you have the XS or XS Max but supposedly that will be solved with the firmware update next month. I have the iPhone 7 plus and have not had any connectivity problems.


#673

I have iPhone XS, unfortunately. I also rely on the Roger system (currently use a Resound multi-mic with Roger X receiver)

So I would need to wait until the telecoil is released so that I could get Roger support via a Compilot, correct? to bridge me until the direct connect is activated in Fall 2019.


#674

Hi mjstew33,

I have both.

  • iPhone XS (current mic issues).
    — So picked up a iPhone XR as primary waiting for XS fix. It works !
  • Pixel 3 XL (right HA’s get searching spinning wheel maybe 30% no connection so remote app is not usable (yep just when you need it), So back to using the XR…

switching between iPhone XR and iPad Pro 11" is not instant, work and time needed.

Had the multi mic with the Resound, but finding Marvels are just ok with out. Waiting for the fall release of t-coil rechargeable and firmware update for Marvels to support Roger/Select. No shoe/X receiver is needed as roger receiver is built in to the Marvel hardware.


#675

The t coil is due to be released in February right? The software update is in the fall. Just want to be clear on that.

If I got the Marvel in Feb, I would have to use MyLink t coil to connect to Roger until the software update in the fall. does that sound right?


#676

Thanks for update. Kind of amazing how long it’s taking HA manufacturers to work out bugs with Android. Then as you say run into the issue with Phonak Marvels and not connecting to multiple BT devices when needed. Seems HA retailers jack up the prices on new HA brands (beyond the norm) and then drop prices as time goes by. Hope to hear later if you did buy the Phonak Marvels or plan to test some other brand.


#677

Signed up to AudiologyOnline (free) and some courses on Phonak Marvels and software.

Don’t know about MyLink as new to Phonak HA’s at the Marvel level.

Time line shows, Audeo M-RT fall 2019


#678

Any update from the IOS 12.1.3 and the 2018 versions of the iPhone X(s)/® users?


#679

Yes post #640 above


#680

I posted last week about one of my M90s having to go back to Phonak after only four days.

The audi office messaged me yesterday that it was back, and so I went and picked it up today, on my way out of town for a week.

When the front desk assistant told me on my way out that they had actually just sent a new aid rather than fixing the old one, the lightbulb should have gone on, but didn’t. So it was only later on once I got the chance to really mess with it that I realized–it isn’t paired with my other one! Can’t connect to both at the same time via Bluetooth, and they are operating completely independently. It’s like wearing two different ear buds. :slight_smile:

I have an appointment in a week, but I do wonder if the touted remote support abilities of the M90 could fix this. (I’ve emailed to ask, but I don’t think the office has much experience yet, though I did offer to be a guinea pig)

It’s not the end of the world–it is kind of funny.


#681

Did you try un-pairing the old HA and then re-pairing again?


#682

Yes, did the full unpairing. The new aid is not even listed in Bluetooth as “Phonak Hearing Aid” – it’s listed with what looks like a model or serial number. In the Phonak Remote app, the new aid appears again with the serial number, and the old one appears as “R-Phonak Hearing Aid” (R=right), but then the Remote app keeps trying to find the “other” aid before finally just letting me connect to it as a single aid.

I imagine there is something in the Target software that has to be done to a) properly name the new one as “L-Phonak Hearing Aid” and b) establish a pair/connection between the two aids.


#683

When pairing my M-R 90 HA I will see only the “R-Phonak hearing aid” listed in “Available media devices”. This is normal. The Left hearing aid then communicates directly with the Right hearing aid to enable stereo listening. The Left hearing aid is not part of the pairing process.

You can see other Phonak listings when pairing, but you shouldn’t pair with anything other than the “R-Phonak hearing aid”.


#684

I know, but it doesn’t work. They don’t communicate with each other. It has nothing to do with Bluetooth. If I hit the volume on one, it doesn’t talk to the other one. And, as I said, in the Phonak Remote app, it connects to the right one, but then says that it is unable to find another aid paired with that aid. With the new aid, it doesn’t even say that if I choose to set up the connection to that one instead.

Before the old aid broke, I had it all set up and it all worked exactly like you said. But I am sure that there is a connection between the aids missing.


#685

Ouch! Sounds like something is certainly awry. I understand that there is a phone number where you can talk with Phonak USA directly. I’ve not needed it, but it looks like you could use it. I can’t find it in my included User Guide.

Does anyone here on the forum know the number?


#686

Here’s something else to try. I’ve found that after playing around with my Marvels, they seem to get confused and are sometimes out of sync and not working properly. The only way I’ve been able to get them back in sync again is to put them back in their charger for a few minutes. When I take them out of the charger they again work normally.


#687

seen this number posted for Phonak connection issues 800-777-7333