Phonak introduces Marvel platform and Audéo M hearing aids

phonak

#689

Yes, I don’t think there’s anything I can do, and maybe not even the national Phonak support line. Definitely would think that it’s in the hands of my audiologist.

Has anyone used the MyPhonak support app? Through which supposedly the aids can get some amount of remote assistance? I haven’t ever had access to the app, so I need an “invite” to even start poking around in it, but I’m curious as to whether the capability to do Target software-type stuff and push it to the aids remotely is a possibility.

(I can definitely make it through until my next appointment if this can’t get fixed remotely, but I’m a techie and am always ready and willing to see if available technology can wrestle any problem to the ground sooner rather than later!)


#690

My understanding is that remote support won’t be available until February…


#691

Sounding like the office staff handed you the new HA just pulled out of the box. Maybe did not setup/paired with the right in the target software to you prescription… call the Phonak connection issues 800-777-7333 line and they maybe able to confirm a visit to you AuD is needed or better yet have a fix :slight_smile:


#692

also hearing around 8th


#693

Thanks. I did send an e-mail to the AuD office this evening, and may call the help line if AuD doesn’t think they can help, but I am guessing there is nothing to be done until I get back. Even with them unsync’ed to each other it’s still better than the past week with an M-90 in one ear and my six-year old Naida in the other. :smile:


#694

Got my laptop sound finely to work/pair with my M-90’s. Laptop has older BT stack 4.0 and not connecting/pairing. Pickup a Sennheiser BTD 800 USB Network Adapter (504579) on Amazon. The usb nub is listed under Bluetooth connections on Windows 10. Plug in and Hold button on end of nub starts flushing red for pairing, then turns blue once it pairs (Right HA was powered on just before placing usb nub in pairing mode). This is great as now not needing go thru lengthy process with Ipad.


#695

No, it’s available now and I’ve used it several times with my Audi as we are both testing and getting familiar with the process. It actually works quite well. Yes, you do need an invite from your Audi to play.


#696

I have used the remote app to get a setting changed on the aids. I have the TV connector which gives great quality sound.

The problem I had was that the default setting automatically connected, so whenever the TV was switched on it would stream into the aids. Because the range is good this would happen if I was in another room. The audiologist connected through the remote app and toggled the setting to manual.

Now I can just cycle through the programme using the button on the aids to start streaming. It was always possible to change the TV streaming through the other Phonak app, but this took some time as it had to reconnect each time it was opened. Not sure what other capabilities the remote access facility has but this was very helpful to me and the problem was sorted quickly.

They are fantastic hearing aids and now just waiting for the iPhone XS issue to get fixed in February.


#697

I did hear back from the AuD, saying that they don’t have the remote software yet. She mentioned that they would contact Phonak about getting it, but I doubt it will all happen before I get back to town late next week.

One of the down sides of being an early adopter!


#698

Interesting as Target 6.0 has it as the standard. Do they do much Phonak sales? My Audi had the SW back in Nov when I was fitted with mine.


#699

Can the Audi only manage your hearing aids realtime, or can you request changes which the Audi can send to you and then you have to upload it on your hearing aids? Similar to how Resound works?


#700

From the OP/Original Poster;


#701

So you can send feedback anytime, also without an appointment and without real-time. Hopefully it will also be possible to receive updated settings any time, without the need to setup a specific time for a real-time fitting session.


#702

I don’t think it said that. I think it just said that remote settings are possible. It may depend upon how much you are looking for your audiologist to be at your beck and call anytime you might need a different setting, and on the other hand, how much time he/she is willing to devote to remote settings/videocalls.


#703

If that’s case, I think Resound’s way is better.


#704

The Phonak medium power domes for the Marvels did not seal and
the large caused soreness/pressure. So moving back to custom shells.
Today got my new custom shell’s at my AuD. Phonak has done a good job and I got a great fit !!
Had tried the Resound Quattro 9’s but after 3 tries they could not get the custom shells to a good fit and provide android streaming. Now just need the Apple iPhone XS fix to be complete.


#705

I have the phonak cshell hard acrylic custom molds. For me, it was so much better than the domes, but I have severe/profound loss. The cshell’s are very comfortable for my sensitive ear canals, where the domes just annoyed me all day long.


#706

I just got my SlimTip Silicon Soft Solid custom molds a few hours ago. I had the power domes for a few weeks and they kept sliding in and out and put a lot of pressure against my ear drum which was really annoying. This is the first set of custom molds my audi has ordered directly from Phonak, but she was impressed. Took able a 10 days to get them done.

My hearing loss is severe and I’ve had to have much larger ear molds in the past with very little venting. These have much larger vents than with less occlusion and I’m getting tons of power out of them which is great news for me. My ears are sore and it’ll take a few days to get used to them, but it’s a big improvement so far.


#707

Regarding the Bluetooth issues: I’m straight Android with a Galaxy Note 8 and a Galaxy Tab and I have similar issues as expressed by the iPhone group. I have not found a way to switch between those devices without having to re-pair, (not just re-connect). My phone is BT 5.0 and the tablet is BT 4.0 and I’m wondering if that has more to do with it.

Switching from the phone to the tablet fails the connection 100% of the time and then forces a Marvel power/off & re-pairing process to get them to work. Once working, if I try to switch back to the phone they start to connect and then Android displays a “Would you like to pair?” message. It’s like the phone is saying: I know you paired with these things before, but something is messed up and you need to accept pairing again. I can choose Yes and they connect and start working. It’s really strange. I get similar behavior with my Cisco desk phone and it blows out the memory on the Marvels, (if that’s what the issue is). I’ve been wondering if the Marvels are not keeping the pairing keys and managing them properly when re-connecting to multiple devices. Maybe some devices don’t care and just let it connect anyway since it’s in the pairing list, while other devices throw the brakes on and require a re-confirmation of pairing or like the iPhone just flat reject it.

Today I finally broke down and ordered the new Pixel 3 XL since others have been having good experience with them. I’d really, really love to be able to pair with my phone, PC and desk phone and switch reliably.

Any what’s up with the Marvel’s only pairing with 2 TV Connectors at a time? Who in the world is paying 6 grand for a new set of hearing aids and only owns 2 TVs? I have 3, but also want to use a TV Connector at work and keep one in my travel bag to plug into other places on the road. Memory is so cheap, so why not track the last 10?

Gotta end positive: Loving the sound, streaming, voice quality, etc. Feeling positive about the future if they will invest in more firmware updates and some major updates to the Remote App, I think they’ll have a killer package.


#708

When you get your Pixel 3 XL you’ll be able to see what I’m seeing as the problem with pairing and re-pairing. On my Pixel 3 XL, when I ask for for my R-Phonak hearing aid that is currently “Active” to “Disconnect”, I can see that it actually does “Disconnect” for about 15 seconds. And then to my utter amazement, it automatically “Reconnects” again without my doing anything! I try “Disconnecting” again and 15 seconds later it again automatically “Reconnects” again! I don’t have any other Bluetooth device that exhibits that behavior. I’ve never seen any other Bluetooth device work that way. It’s totally contrary to the way that Bluetooth Classic is supposed to work. That is exactly the problem with connecting to another device with the Marvel. Since it automatically reconnects itself every time you disconnect, and with Bluetooth Classic you can only be connected to one device at a time, the absolute ONLY way you can connect the Marvels to another device is to actually un-pair from the device you are leaving and re-pair with the device you’re going to. The problem we have is with the way Bluetooth is programmed for the Marvels. Until Marvel’s “auto-reconnect” problem is fixed to work the way every other Bluetooth Classic device works, you will have the Marvel’s un-pair and re-pair problem. Period.

I have a great experience with my Pixel 3 XL simply because I don’t have a pressing need to connect to any of my other computers or tablets. I definitely can connect to any of my other devices by going through the time consuming song-and-dance of un-pair from the old device and re-pair with the new device. I sincerely hope that Phonak can get the message that they are doing something totally nonstandard with Bluetooth Classic that is thoroughly irritating their users.

I’ll end with something positive too. I absolutely love my Marvels and I’m not giving them up. I too am positive that Phonak will update their implementation of Bluetooth Classic to work correctly and that they will update the Remote App to work the way it should.