Oticon OPN 1 & iPhone X audio issue

oticon

#1

I’ve had my OPN 1 aids for about 6 weeks now. Love the Bluetooth capability and in particular the ability to stream phone calls. That is the only streaming I currently choose to do. I’d prefer to not stream media. My issue is this. I have the mfi settings to “always stream phone audio” and to “never stream media audio”. Whenever I take call the audio streams with no issue to the HAs. After the call, media audio now streams to the HAs as well even though the settings say “never”. Why won’t the mfi settings work? What am I doing wrong? My IOS version is 12.1.2. Thanks.


#2

Hm, I’m on iOS 12.1.4 on my iPhone 7 plus and when I have things set up like you said, the media always plays on the iPhone speaker and the calls always play on the OPN. The only things is that in my test, I didn’t receive any call, I could only make outgoing calls because it’s just a test.


#3

Thanks for the quick response. Just to be sure, I did the update to 12.1.4. checked my mfi settings to be sure that the settings were showing the audio routing as calls always to the HAs and media, never.
Played a video on Instagram as a test and the audio routed to the HAs.
I would think the next step would be to unpaired the OPN 1’s and do the pair again. Not sure what else to do.


#4

Well, that didn’t work. Media audio wants to constantly route to the OPNs regardless of the settings. The only time they don’t is when I’m using my Apple AirPods. I’m stumped and frustrated.


#5

Figured it out! On the iPhone control screen there is a setting under the Music icon to select the device. It was showing the Bluetooth device in addition to the iPhone speaker and the Bluetooth device was selected overriding the mfi settings.


#6

OK. Another possibility I could think of is that it may be software dependent. I was trying out the Apple iTunes software which is iPhone compliant so most likely will behave better in accordance to the Apple iPhone settings. But maybe non Apple softwares may not be as compliant and not follow the iOS audio routing settings as well.

But hey, if that other fix works for you now then that’s OK, too. It may end up being an issue with many layers to it.


#7

I agree completely with your assessment. I won’t know for sure if this “workaround” will work in real usage until I give it a day of switching between calls, my AirPods and my Bose Confort headphones to see if I have to manually re-select the proper device.
Thanks for your insight.


#8

After this morning I wouldn’t call it a fix. It’s still a workaround.
Powered off the OPN’s over night and when I Powered then up this morning the iPhone defaulted to streaming media through the HA’s. Using the above workaround I made the switch but it’s obviously still ignoring the mfi audio routing settings.


#9

Just for the heck of it, have you tried the test on iTunes just to see if that complies better for you? if yes, then it’s the other app for you that’s not complying. It’s not the iPhone’s fault or the HA’s fault.


#10

Actually everything was working fine until I got a cellphone call. The call rerouted fine to the HA’s but after the call the HA’s stayed connected to “all” audio. Including media audio which should have been rerouted to the iPhone speaker pursuant to the mfi settings. Using the iPhone Control Screen > Music Icon setting I could set it manually back to the iPhone speaker with the workaround.
For music I mainly use a SirrusXM app and my Apple AirPods. I wear the AirPods over the mini grip tips which give me great fidelity. Fortunately the AirPods are small enough to fit over.