Oticon Dynamo - I cannot hear own voice in some situations

I have a pair of Oticon Dynamo SP8 (after a pair of Oticon Chili SP9) with hard acrylic earmolds with 0,8 mm vents and thick walls tubes. All of these hearing aids have same problem - they muffle or fully reduce to zero my own voice in the next situations:

  1. I speak very loudly or cry.
  2. I talk with other people when TV works in the same room.
  3. I speak when any power air flows next to me - vacuum cleaner, kitchen cooker hood, and when cycling.

No any audi can resolve this problem. I have own programmer and Genie software, and I can see that no any adjustments for this situation present in Genie software. Oticon agency in Russia suggested it may be because of a built-in wind noise canceller which cannot be turned off.

Is this situation (with my voice vanished) desperate?

1 Like

This is likely a compression issue. Post a screenshot of the gain and mpo settings.

I have new idea - what if this a “Floating Linear Gain” issue? Maybe it too reducing sounds in loud environments in additional to compression? But it cannot be turned off too… Screenshots of gain and compression are here:

Just as I suspected. The compression is very heavy in the low frequencies. If you add more low frequency gain in the moderate and loud settings from 250 - 1.5K this will certainly make things better for hearing your own voice.

Thank you for your answer! I will try it today. But I doubt that the reason is compression. These screenshots was made in Exact profile. I tried Balanced profile with less prescribed compression, and my voice suppression was more aggressive in Balanced profile. Here is a screenshots from Balanced profile:

That’s good to know, but keep the ratios getting closer to 1.0. Let me know how it works.

I tried to add more low frequency gain (+1 in moderate and +2 in loud levels from 250 to 1500), and my hearing aids become too loud even in calm situations. So I returned settings back. I tried DSE linear (with overall compression =1) - it was too soft or muffled for me. Maybe Genie represcribe different rationales in wrong way. My audiogram is here (audiogram in profile cannot add breaks lower than 4 kHz)

Now I can see why linear compression is not for me - see speech range and my audiogram on the next screenshots. I was convinced that Genie represribes different rationales in wrong way.

It sounds like you are attempting to guess where you should actually set the gain. Let me give you the correct way to solve this problem regardless of which fitting formula you decide works best for you.

There is a section in the software called In-Situ AudiometryIn-Situ

Use this tool to actually measure your own thresholds to apply the right amount of gain to your hearing aids. Treat this as you would a hearing test. Measure down to the absolute lowest sound you can hear with each frequency and then apply the measurement and it will adjust your hearing aids. This should be a great starting point from which you can build.

Thank you, but I always know about in-situ feature. I measured my hearing with it, and it slightly differs from my normal audiogram. I have very good sounds in my hearing aids, including my voice, in normal environments. But in some environments I can hear voices from other people as normal, but my voice reduced yet. I raise my voice loudness “automatically”, and other people point me to this. And, for example, if I turn on vacuum cleaner or electric meat grinder, I cannot hear own voice. I think it is a noise reduction issue.

Based on your previous descriptions of when this is an issue, you might be right. Try reducing the noise reduction settings and at the same time lower the gain for loud sounds in the low frequencies(this is going to increase the compression ratio, so don’t do too much of this), and also lower the MPO settings from 125 to 1K to prevent too much volume when things get loud.

I switched off noise reduction feature in P1 and added a “comfort in noise” program. Gain and MPO still the same as prescribed. Tomorrow we’ll get the results.

1 Like

My voice sound still weakens in noise even with noise reduction feature switched off! Less voice reduction in Exact profile and maximal in Calm profile. So it is a non-switchable “feature”. I have to endure it. Disappointed in Oticon. Hope than next Velox hearing aids will be more smart. Question to all Opn user - do you feel your own voice muffled in very noisy situations?

I wear Dynamo’s also. In noisy situations, my voice also sounds muffled.

As I can see, this problem cannot be solved from our side. No any switch or slider in Genie for this problem. We must to write directly to Oticon about this problem.

I don’t know if your own voice being ‘weakened’ or muffled is an Oticon issue. I still feel there is a solution. I have a set of dynamo’s. Post your last gain settings so that I can duplicate the issue and see if there is a fix for it.

I have had the same issue with Oticon Chili SP9, so I think it is an Oticon issue.

Very odd.
I previously had Oticon Chili, SP7 with the same issue.
That was one of the reasons for trying the Dynamo. I was hoping with the newer features, this problem could be resolved.
Guess not.

I’m waiting for next Oticon superpower model based on Velox platform. If it will have this issue too - it will be real disaster. Phonak muffles all sounds, Widex and Signia stopped producing superpower hearing aids. Resound rumored low quality with quickly failed aids. Starkey does not sell in Russia. So I have not any other choice.

the Signia has the Motion SP with 675s that you could try! (might look at this one for my mom if she drops)