Oticon Agil Programming - No Detection

I have everything that is required to self-program Oticon Agil’s

What is stopping me in the process is that if i use an older version of genie (2011.1), it will tell me that the aids were last modified with a newer version and won’t let me go any further. So I am assuming that they are detected. When I upgrade to 2011.2 it won’t detect the aids at all. I installed a new battery and carefully connected the cables, even upgraded hi-pro drivers and assigned the hi-pro to COM3.

When I go to the help section, it says that with the more upper end oticon’s, the aids might not be detected if the volume wheel is turned down or if is on standby. Not sure here?

Kinda stuck right now…

Try cleaning the contacts were the shoe fits on the HA, it could be corroded which would keep it from recognizing the HA.

I haven’t had this problem, I’m using 2011.2. Some thoughts: if you’re using flex-strips make sure the black dot is facing up and pushed in all the way to the HA body. Also, make sure the Oticon number 3 cable is plugged in correctly to the flex strips. The HiPro should have a green power light on and when you select detect the PC Com light as well as the left & right lights flash on & off. If those lights don’t come on during detection then you may have a problem with the HiPro. Good luck.

Thanks for helping!

Still no luck. The Hi-Pro does have a green power light on and when I select the detect button, the PC Com light comes on and the left and right lights flash on and off as well. I tried again to install 2011.2. When I did this I again got a Detection Error: “A newer Genie version was used to fit the instrument. Please cancel the fitting and upgrade Genie.” I clicked the small arrow in the bottom right-hand corner and upgraded Genie. After restarting the computer and going through the process again, there is absolutely no detection.

Could it be that the previous programmer has placed a password protection on the aids?

Is the Genie patching itself properly: do you get any information that the install is sticking? Some of the on-line updates don’t work as your anti-virus may be sand-boxing some of the components.

Looks like you aren’t getting the properly patched version on your system and it won’t recognise. I’d be tempted to roll-back to an older version of genie and let it do a full update to a later build, to see if the patch is incorporated.

Or it could be something daft like a model code field that’s missing, post install.

Be sure to install Genie as stand-alone. Your programming setup should look similar to this with Oticon number 3 cables connected to flex strips or boot (for non-mini) :


Works great.