KS10 connects to bluetooth radio randomly

My partner bought a radio with bluetooth.
This is giving me a lot of grief as my KS10 connects to it ramdomly and gives me a big shock when suddenly I get music blasting in my ear. He is tech savvy and says it’s an issue of the HA looking for the radio and not vice versa and there isn’t a way of telling the radio not to connect to the HA. Costco claim it is the opposite, said they called Phonak, but told me to delete all pairings in Target anyway. Of course now I can’t get it to connect to the stupid app!!

I think that this must happen if either my phone or tablet is out of battery and therefore the KS10 can look for a second device to connect to.
Has anyone had this problem? Is there a way of stopping the HA from connecting to bluetooth devices without my permission?

Bluetooth requires “pairing”. If you did not pair the radio in your bluetooth settings you should not be hearing the radio. Just make sure the radio does not show in your bluetooth settings and if it does then “forget” or remove it.

I did not pair the radio. The HA connected to it automomously. it does not show in the blue tooth settings. I have done delete pairings and it connected again this morning as I expected it would.

Look for the radio’s manual online using the model number if you haven’t got a booklet and search for ‘forget Bluetooth connection’. That’s what you want to do: delete the radio’s pairing with your aids. While you’re at it try to find out what puts the radio into pairing mode so you can stop the two devices pairing in the future. If they are not both in pairing mode at the same time, they can’t pair and therefore will never connect. I doubt that the radio is in pairing mode all the time. It would be an unnecessary drain on power and a magnet for unwanted connections.

My husband studied electronics and works in IT; he says the radio bluetooth is open and the HA is connecting to it. And that he can’t turn off the bluetooth as he listens to it via bluetooth headphones while working at home.

The ‘forget the pairing’ suggestions are a waste of time as far as I can see since the devices have connected without me ever doing anything. I have nothing that I know of that means I can tell either device ‘do not connect with a KS10’.

@dawn

But you have to put the KS10 in pairing mode to actually connect!

It won’t connect unless you did that in the first place when your husband first got the radio.

Otherwise you’ll connect to all phones that have Bluetooth on as you walk when you’re outside.

KS10 can connect to two devices. Connect to two of your devices and it won’t connect to the radio.

I never paired it, and what is more, I did the ‘delete pairing’ thing at night, and the next morning it connected to the radio almost as soon as I put it in my ear.

Is the Bluetooth on phones usually open like this radio? I think not.

Could you please let us know the make and model of the BT radio? We can try to get the manual online.
I’m sure there is a pairing-procedure. And there should also a delete-pairings-procedure.
Btw. the phonaks are in pairing mode for a couple of minutes after switch-on.
Maby you did the pairing them unknowingly…
Your fitter can delete all pairings with his fitting SW.

1 Like

As I said in the previous post, I already deleted all pairings in the software myself (which consists of clicking one button, not a list of pairings). But it connected again the next morning.
The radio is an Imperial Dabman i250. The manual is online.
page 77 is the bluetooth section.

@dawn

As I sad in previous post, if you connect to two of your devices, it won’t connect to the radio as the KS10 can only connect to two devices.

It can remember 8 pairings, so she would have to pair/connect with 8 other devices before it forgot about the radio.

1 Like

Your general tone is as if you were talking to paid support. You’re not. And if you were talking to paid support I don’t think your attitude would help you there either.

I suspect you deleted the pairing between your phone and your aids. Nothing to do with the radio. If you’re going to stop the aids and the radio from talking to each other it’s going to have to happen at the radio (although as has been mentioned already your audiologist should be able to do it at the aids).

@d_Wooluf

I meant it can connect to two devices at once. It can’t connect to eight devices at once.

My Marvels can connect to two but only one at once.

No, but it remembers 6 others so when either of those 2 connections gets dropped, the radio comes back.

That makes sense but if she stays connected to two devices then that wouldn’t happen?

:slight_smile:

“I said ‘Don’t turn off that… aaargh!’”

I looked at the manual out of curiosity. I’d say your best chance is to do a factory reset (7.1.18.). Try not to turn on “Bluetooth mode”. It’s not clear to me from the manual how you actually do that, but try not to.

I have Target and deleted pairings in Target as suggested by the audiologist, who has no further suggestions when I told her it connected again. I didnt understand the manual either. I apologise if I have seemed abrupt.

No worries. I can see that it would drive you nuts. Did you try the factory reset?

I have studied the manual and must admit it is not entirely clear.
There are two possibilities:

  1. the radio is in pairing mode only in the Bluetooth menu
  2. the radio is constantly searching for devices in pairing mode and pairs itself with them. This would be very unusual and also not practical. Anyone walking by could connect their BT headphones and listen in.

I would proceed as follows:

  • turn off the radio.
  • delete HA-parings again in Target.
  • then switch off the HAs.
  • Then perform a factory reset on the radio. This should delete existing parings.
  • then switch off the radio.
  • then switch on the HA and wait 5 min. (The HAs are in pairing mode approx. 2min after switching on).
  • then switch on the radio again.

→ then the music should not be transmitted to the HA.

If it works like this:
Pair the radio again with your husband’s headset.
Never enter the Bluetooth menu of the radio during the first 5 minutes after turning on the HA.

In the 2nd case mentioned above, the radio would always have to be turned off for 5 minutes when the HAs are turned on. That would be very inconvenient then.

Hope this helps.
Let us know how it went.

2 Likes