Jabra EP 20, Galaxy S23+, full hands free vs. hearing only

I thought you might have knowledge of settings that might help the OP.

His Jabra 20 aids and S23 phone are not doing well with LE audio.

I typically don’t even keep my aids paired to my phone. Just keep them paired to computers. Have no experience with his aids either. My only advice: “When all else fails, read the instructions.” :slight_smile:

1 Like

On my iPhone, to disable hands free calling, triple press the power button. This will bring up the hearing aid control panel. Select “Mic Input” to “OFF” and your phone’s mics will be used to pick up your voice for phone calls. Hope this is also the way the Galaxy works.

I don’t know who is referenced here. I am OP. I use app and phone settings. Trying all sorts of combos, pairings, restarts, etc. The “instructions” are of no help. They don’t address the question at all.

The suggestion of pairing directly with the phone and not through the app is worth a try. Assuming it will let me do that.

Thanks but it doesn’t work that way on the Galaxy. I think the difference is the iPhone doesn’t have LEAudio or whatever the right term is.

Well some progress! Convoluted process, but worked on first try. We’ll see if it holds.

Unpaired, killed the app, paired with the phone’s settings. It still used the mic in the aids, but my wife said the sound quality was good this time and I had the LE Audio switch in the device settings. I then started the app and it asked to pair, so it wasn’t seeing that they were paired with the phone. I went ahead and paired with the app procedure. In phone connection settings, it still showed as if I was only paired using the phone settings. So far, both the app and fully hands free are working! :crossed_fingers:


‘Fully hands free’ - does that mean you can answer/decline or end an incoming call without touching the phone?

Excuse my tech ignorance but could you give a little more detail about “paired with the phone’s setting”? I’m using a Galaxy s24 and I’m not having any luck getting phone calls over the HAs. I’m sure I’m missing something but it sure is maddening.

I’ve not moved on to tapping to answer. Just trying to get calls using the H/A mics at this point. By “fully”, I meant both talking and listening via the aids.

1 Like

Maybe using the HA mics sounds wonderful (and in a quiet room, it is) but if there is much background noise at all, it gets hard for those on the other end to hear you pretty quickly. I wish I had the choice to choose the iphone mics, as the noise canceling is much better. I either give up the phone sound piped to my ears (which I do now with my mom, who refuses to check out HAs) or torture my other end with whatever noise is around me.


As you can read here, I’ve been around the block. My positive results with that procedure above did not hold. I went back to pairing via the app.

After that re-pairing procedure, I had a successful call with my wife who said the sound quality was good through the aid’s mics. I later made a call and the other person said she had difficulty hearing me - bad connection. I went back to pairing with the app and had a good call again. It may just be inconsistent, or I’m getting through initial roughness. We’ll see how it goes in another day or so.

So, you can pair the aids using the Jabra app. Assuming the aids are not paired, follow the app’s instructions.

The alternative is to pair the aids to the phone using the phone’s bluetooth connection settings. You put the aids in pairing mode by opening and closing the battery doors so they restart. They should then show as available in the connection settings. Choose the aids when they appear and they should connect. But, when I’ve done that, they aren’t connected to the app, so you have to go through the pairing with app in order to use it.

Any clearer?

Edit: There is also “Tap to Connect” in the “Hearing Aid Support” settings. I thought that was to set up answering the phone, but it is just another way to do pairing directly to the phone.

I’ll get my wife to call me when she is free and see about answering by pressing a button on one of the aids. Instructions I saw didn’t specify forward or back. Maybe either when the phone is ringing. TBD

My understanding is that you can use the iPhone mics on calls. That is in the instructions. Jury is out about doing that with Android. Here the instructions provided earlier:

Have you tried removing the app and just pair the phone and aids only? Do not load the app.
Then make your call and see how that goes.

I haven’t removed it completely. Just killed it so it wasn’t running. I need to get my wife’s phone when she can part with it for an hour. I can call it and leave a voice mail then listen to it. I’ll try uninstalling.

Ultimately though, I will need the app. I use it regularly. I had ReSound Prezas before this with basically the same app.

1 Like

Thanks a lot for the info. I see the same thing. Sometimes the call is clear and the next call is terrible. Jabra can surely do better than this or do they expect everyone to buy Apple?

I that is the way it is going to be, I’ll be returning them. Definitely a deal killer. It would mean losing calls in my aids altogether if it turns out to be so unreliable.

For MFI HAs, perhaps. Not phonaks.


Well, I don’t claim to understand anything about these pro 20 hearing aids or my s24 but I’ve been having all sorts of connectivity problems and I’ve tried about every combination. Yesterday, I decided to unpair everything like my truck, etc. Then I repaired my ha, turned on bt and le audio. I can now stream, get phone calls through my ha and even have hands free calling. This might revert back but so far it has worked for two days.


Sorry, I assumed you had the Jabra/ReSounds we’ve been talking about.

My buddy has Phonaks and uses hands free trouble free without taking the phone out of his pocket. Even when we are out and around, some noise around or not.

You had your aids paired to your truck? What else? Mine are only paired with my phone.