iOS beta 11.4.1 update that seems to solve MFi "searching" issues


#21

I forgot to add that the Apple accessibility rep said the MFi problem is not yet understood. Depends on whom you speak to, I guess.


#22

Here’s my feedback after 2 days on iPhone X with 12 beta:

No “hunting” problems with streaming, but today I did hear the “ticking” problem, which sounds to me like momentary drop-outs in the stream. I still have a Phone Clip+ that I’m returning this week, so I was able to verify that it streams smoothly to the aids from the same phone, in the same room where I heard ticking with MFi. Went right back to MFi and heard ticking again. So apparently it isn’t a problem with the aids (ReSound LiNX 3D), but with MFi in the iPhone. Right now, a couple of hours later, no ticking through MFi either.

The iPhone ReSound Smart 3D app has been much better than the Android version, at least in these 2 days. I force-quit it once, whereas on Android it was unusual to NOT have to force-stop it if there was any disruption in the connection to the aids. And the iPhone app connects to the aids faster. Need more time to be sure though.


#23

I have the opposite problem - calls go to my hearing aids instead of the car. However, I believe there is a setting that will change the “default” action. But I don’t want to change this because when I am not in the car I prefer calls go directly to the hearing aids. Can’t have it both ways I guess! Oh - I have the “ticking” problem also. Sometimes bad, sometimes not so bad. But almost always happens…enough to be very irritating!


#24

Try turning off Play Ringtones in the MFi Hearing Devices section of Settings.


#25

beta 11.4.5 is out. Beta iOS 12 is supposed to now have the audio handling path improvements in it.


#26

This sounds like encouraging news and the way forward. I don’t see these 11.4.x betas on the beta site, though.


#27

How do you know it’s out? I don’t see it on the beta site. I see nothing but 12.


#28

as near as I can figure out, Apple has dedicated beta testing channels. That is, if you sign up for iOS 11.4.xx the updates will come straight to your phone. That;s what mine did - I had 4.1 on it, and the 4. whatever came up in automatic updates notification.

I think the get on the 11.4 up date list, you’ll have to email Apple, to get the link. Use the email address above.

And I have not heard that the fix that is in 4.1 - 4.xx is rolled into 12 yet, but some people have reported that their MFi communication works better with 12.


#29

Just installed Beta 12. First impression: problems solved. Will have to test more but this is what I was expecting when I got the hearing aids.


#30

FYI–I bought a new iPhone 7 late in June. I have a pair of OPN 1’s. I’ve had a minor bit of irregularity with static and occasional sound loss on one side or the other for very short intervals. I don’t recall the same problem on my old iPhone 5. Today, with no forewarning or inquiry on my part, the system was upgraded from 11.4 to 11.4.1. I’d be delighted if the static(or clicks) and occasional drop outs disappear.


#31

I made a leap to iOS beta 12 and 12.3 seems to have fixed it also. If you go to 12.3, I suggest re- pairing after iOS install.


#32

Try re-pairing your aids after a shut down / restart.


#33

I have the same hardware and the feel the same way. I’ve found that many of the clicking sounds are caused by other nearby bluetooth devices. Try to minimize the number of devices your phone is paired with. I realize they are all things we MUST have though… :rofl:


#34

I’ll second that pairing thing. The phone hunts for the BT devices to pair with.

I am using iOS 12.4 and it works a little better. If you give an incoming call two rings, it will generally pair up better. I have found that, if the pairing with the aids doesn’t work, quickly switch to speaker then back to aids. .4 is quicker, for sure but it seems to eat up battery power.


#35

This post was flagged by the community and is temporarily hidden.


#36

I’m on ios12,5 now. it doesn’t work any better than 12.4 but better than 11.4. I found that if a connectivity issue happens, go to my aid app and the app will reconnect both aids. So the lost connection issue is still in the os…