iOS beta 11.4.1 update that seems to solve MFi "searching" issues


#1

I have an iPhone 7 and Resound Enzo aids. for some time now, all the way back to iOS 10, and made worse by iOS 11, I have had problems with the aids acting up when either incoming or outgoing call was made. The aids would show they are sending the audio to the aids, but then would switch to speaker, but no sound, then switch back to the aids, but not sound for maybe five seconds, then, most of the time, only connect with one aid or the other. I tried forcing the phone to always pair with the aids, but that did not fix the problem.

I have been reporting this to Apple since 11 came out. As usual it was a round about of blaming the aids, then the Resound app (the problem still happens with the built in aids control app). I got an email from them yesterday saying they believe they have fixed the problem with an iOS update that is still in beta. I have been using the beta for about 12 hours now, and it seems to have fixed it - at least, the time to answer and send the audio to the aids has been reduced quite a bit. So if you want to try it, here is the link. You will have to sign up for the beta program to do it.

Thank you for your email. We believe that the issue you are reporting has been addressed in the current version of iOS 11.4.1, which is available through our Public Beta program https://beta.apple.com/.

If you would like to try the new version, please Sign Up. Once you have signed up, you can go to the iOS tab and follow the instruction in the Get Started section to enroll your iOS device.

Apple Accessibility

For more information on Accessibility at Apple, please visit:


https://support.apple.com/accessibility


#2

Thanks for sharing this. The issue has been maddening. Glad there may be a fix in sight!


#3

One question for you. . .

You mention, “reporting this to Apple since 11 came out.” When you have issues like this, where do you go to leave your feedback? I’d like to provide the input when needed, too, to help our small community have a larger voice!

Chris


#4

Dang if it hasn’t kept working. I expected it to screw up after a bunch of calls, but so far so good. The more people that try it the better. It works with no problems with the Resound aid control app.

Apple is not happy with abusers of this email, so, if you need to report something, make certain you have your problem fully defined down the the exact circumstances. IOW, “my iPhone doesn’t work with my aids!” won’t cut it. They need to know everything from how old the batteries are in your aids, to the model of the aids and year purchased, to the environment you were in when the problem happened (maybe MFi interference?)

accessibility@apple.com

To try the iOS update you must as I said, join the beta “club” and part of joining that is a log reporter. It’s already on the phone, but usually it is disabled. That just keeps track of the behavior of your phone and BT connectivity, not content.


#5

Thanks for the update.

I have been a regular pain in the neck to Apple regarding MFi issues. For me, the ‘clicking sound’ has been the main source of problems, but I am familiar with the ‘searching’ issue you describe.

It is important to keep calling and emailing Apple. As you mentioned, the script usually involves directing you towards the HA manufacturer, who in turn refers you to your audiologist… just keep persisting: they (Apple) have a problem and should be held accountable.

Repeating the email that Apple monitors:
accessibility@apple.com

It is important to provide detail to them. Example:
Device: Signia Pure 312 7Nx
Firmware: 6.1.8.0
iOS: 11.4.1 on iPhone 7
iOS: 11.3.1 on iPad Pro Mini

Regarding fixes:
I noticed difference in connectivity behavior when I went to Beta 11.4, I was having some unpredictable connections when I didn’t ask for them (music started streaming on its own). This seems to have settled down in 11.4.1.

iOS 12:
<No personal experience yet, I do not have a paid developer license>
However, someone at Apple has confirmed there are fixes aimed at the ‘clicking sound’ phenomenon. Internally, they referred to it as ‘ticking’.

Frustratingly, still no public acknowledgement from Apple that any issues exist with MFi HAs.

Happy Hearing!

Also, about contacting Apple:
I reach out to them continuously.
Everyone experiencing these problems should call them; make them open ticket #s, it documents a known problem with Class 1 medical devices (which incorporate patented communications algorithms that Apple owns). These data points matter.


#6

So if I understand correctly, iOS beta 11.4.1 is ok with MFi hearing aids at present, from your experience? I’m planning to buy an iPhone this week, to take advantage of MFi streaming, and also because the ReSound Smart 3D app is said to work well on iPhone (unlike the Android app which I have to force-stop way too often…and I just got Oreo upgrade which makes force-stop harder to get to). I just chatted with Apple support about what version comes with a new iPhone X. The conclusion is that it comes with 11.4, but upgrading to 11.4.1 can be part of my “personal setup session” before I leave the Apple Store. I could upgrade it myself, but I’d rather leave the store with a phone that works for the reason I’m buying it.

Oh, and thanks to you and @azureblue and others for suffering through 11.4, travails that I’ll benefit from.


#7

So far, .4 seems to have solved the problem. The connection response time seems to be quicker, so maybe that was the root of the problem - iOS couldn’t connect with the aids quickly enough, so it switched to speaker then, since it was supposed to be connecting to the aids then was commanded to connect to the aids. At least that is what seemed to be the issue.

yeah, let the Apple store do the transfer. Having the beta won’t affect any future upgrades - I think Apple will go straight from .4 to iOS 12.

You’re welcome. Glad to share. And really glad Apple finally fixed this.


#8

How do I ask for that? 11.4.4? 11.4 beta 4?


#9

My bad - I meant iOS 11.4.1. Low on coffee. You will have to ask for it, and be ready to describe why you want iOS 11.4.1,. Apple traditionally does not do beta updates at their stores, due to the fact that (duh) betas may still have bugs in them. But this one seems to be bug free - I have not had any issues so far. The store may do a nod and wink where they will say they do not do beta upgrades, but route your phone to the link then hand you the phone to push the button. If they won’t then you can back your phone up to iCloud at the store (they should do it in the sales set up process), then you do the upgrade at the store - it’s a short download and upgrade process.

PS, if anyone does the upgrade and it works, please let Apple know, through the email address accessibility@apple.com


#10

I’m also happy to report that the beta 11.4.1 seems to solve the “hunting” issue when connecting to a call. In 11.4, my phone would try to pass the call off to my hearing aids, then move back to the phone after a few seconds, then move back to the aids. It drove me crazy and also those folks calling me (who could hear me at all times, but I couldn’t really hear them during the hunting phases).

I have let Apple know through the accessibility email. Still having the ticking issue at times.

Chris


#11

I’ve not really seen an improvement–in fact things have become so bad (after an earlier update) that I no longer even try to connect my MiFi aids to my iPhone X. I have the iPhone, Apple Watch 3, and a 2013 Volvo S60 all with latest available software/firmware, and outside of the car, an incoming call would variously connect/disconnect to my aids, or iPhone, but I missed a lot of the early part of the call due to the “searching”. While in the car instead of an incoming call connecting to my car, it would route through the iPhone or aids or watch… I got tired of the hassle–let Apple, Resound, and Volvo know of the issue, but…back to doing things the old-fashioned way until they get their stuff together better.


#12

the bluetooth that connects to your car phone is not the same as MFi. The same thing would happen with any data device that has multiple data connection paths. You should go into you car software and tell it not to connect phone conversations. Or tell your phone to not connect via MFi before you get in the car.


#13

I asked about this a while back, and a couple of people said that the Bluetooth car connection overrides the MFi connection i.e. when you’re connected to both, calls will go to the car, not the hearing aids.


#14

Whoops - the problem came back - here is what I reported to Apple:

4.1. was working great until ————
I was scrolling through Reddit, where as you probably know they imbed videos. Some will auto play others won’t. Some, when they come on screen, take over the MFi feed to the aids, then let it go when scrolled off screen. And sometimes, it takes a few seconds for Fito return to normal. That is, turn off the audio from video / misc feed to the aids. I’m not sure if I am explaining it clearly, but aids will handle both an audio feed and continue to use the aids’ built in microphones at the same time, but they are turned down and half when the happens.

Anyway, the aids were working great with the beta update - much quicker switching and both L/R working when calls come in or go out. Until I scrolled past those videos, the the “hunting” and the phone’s switching from Mfi to speaker and back, problem, returned. Dang. I THINK I may have fixed that by restarting the phone. And staying off of sites that have that type of videos imbedded. Jalopnik is another site that has them, too with the same issues.

And Apple’s response:

From your description this sounds like the same issue you had reported earlier in Re: Mfi and hearing aid comm issues; Follow-up: 690882130 Here was our reply from that thread:
After further investigation it seems this isn’t an iOS or hearing aid issue. Our engineering group have determined that there is an audio channel open on the link even though the video is muted when this happens. In fact one engineer was able to reproduce this with a Bluetooth headset paired to a Windows OS system in any supported browser.

So it is a problem with the video itself. The solution would be to disable audio or autoplay on vids and make it manual.


#15

Apple Store was less than helpful, and 11.4.1 beta doesn’t seem to be available anymore. I installed 12 beta.


#16

From Apple:

Thank you for your feedback. For now please continue to use the 11.4.1 beta and do not install the iOS 12 beta. 12 beta has been released but does not contain the Bluetooth improvements found in 11.4.1.

Sorry to hear the Apple store wouldn’t do it. Try emailing Apple and ask them where 4.1. is now…


#17

The Apple Store here didn’t even find out about the 11.4 MFi problems until last week, and the remedy they offer is to wait until Apple comes out with a fix. The Apple accessibility line, the people who are supposed to help us, are well aware of the 11.4 problem, but have been instructed to merely point callers to the public beta page, and not offer any additional assistance. Fortunately I’m technical, so I was able to install the ioS 12 beta from there. It appears to stream ok in the short time I’ve had it. Only glitch I’ve seen, and this may be a “feature”, is that the hearing aids go into streaming mode when some app store search results are displayed.


#18

Most Apple stores do not support Betas unless it is an unusual situation. They do not want to be the bad guy if the beta has a bug in it and it screws up your phone. A wise policy. They should have contacted Apple while you were there, and asked about the reliability of 11.4.1 . iOS 12 does not have the fix in it that 11.4.1 has. Maybe the next beta of 12 will, but until then, 11.4.1 is supposed to address the problem… You can always downgrade (revert) and install 11.4.1


I’ll ask Apple for the direct link to 11.4.1, too.

#19

The people at the store said the phones come with .0 releases. One said 11.0, another said 10.0. I got involved in moving stuff from my Android, and didn’t check what was installed until I got home. In any event I want the phone now. My HA trial ends in a week and I’m 99.99% sure of buying them, but I want some time with iPhone before then.

Like I said above, it was Apple support that told me the store would install 11.4.1 beta. A lot of misinformation comes out of Apple.

That would be great if you can find public access to 11.4.1 beta. Meanwhile, so far I’m fine on the 12 beta, admittedly with very little use as of yet.


#20

I moved out of Android - that wasn’t as easy as they made it out to be. :slight_smile:
This from Apple:

Hello,
Thank you for your email. Currently iOS 11.4.1 beta is not available. Should this change we will let you know.

Apple Accessibility

For more information on Accessibility at Apple, please visit:


https://support.apple.com/accessibility

So my guess is that 11.4.2 is in the works…