How to find Fitting Software to Program Your Hearing Aids [DIY]

#56

On my laptop, I’ve got hundreds of files in the Phonak Target folder. I didn’t know where to start.

0 Likes

#57

I’ll give it a go tonight and see if I’m successful at putting it onto a memory stick and then I’ll get my money back from eBay.

0 Likes

#58

That 's after installation. Before installation it’s just the one install file.

1 Like

#59

Ah okay. That’s good to know. I’ll give it a go tonight. Thank you. :slight_smile:

0 Likes

#60

Hi, sorry to ask but I’ve been searching for days and I can’t find a link to the latest version of Phonak Target. Is anybody able to help?

I’ve bought a ComPilot and TV Link to use with my Nathos S+ micro W hearing aids and for some reason it’s not grouping with these.

I’ve connected the ComPilot to my iPhone which says it’s streaming bluetooth to the device and I have a solid blue light on the Compilot so I know it’s picking something up but there’s no sound over the hearing aids. I’ve bought a new neckloop and tried resetting the device but to no avail.

In the past I’ve tried an EasyCall which works (but the distance is very limited!) so I know my hearing aids should be picking something up.

As a last resort I thought I’d try connecting the ComPilot to Phonk Target and try to reset it that way.

Sorry to be a pain, any links and advice would be great.

Cheers.

0 Likes

#63

Did you buy them second hand? As they should work out the box but won’t work out the box if it’s been linked to other hearing aids.

0 Likes

#65

Hi Zebras, I got them second hand from the US. I’ve managed to solve the issue by using Phonak Target to reset the device and remove all previous pairings.

Thanks everyone for the help and advice.

1 Like

#67

Nice, easy to follow updated post. Now all I have to do is get my laptop out. Thanks.

0 Likes

#68

Hi Meng, I’m looking for Phonak Target software for a long time, finally found here, but the link is expired, could you send me a copy of the software? maybe thru dropbox link, one drive or some other way? Would appreciate your help.

0 Likes

#69

Sorry, I can’t uploaded any files to dropbox from China, pls see your private information of this forum.

1 Like

#70

Thank you Meng for your help. Got the Link.
Thanks PVC

0 Likes

#72

Please help me track down a web site that has the newest version of Starkey’s Inspire X software. I’m proficient in reprogramming, having done it both on my Phonak and my previous pair of STarkey Halo.

Yesterday they set me up with new Starkey Halo 2 i2400 HAs. THe audiologist programmed and did initial set up with Starkey Inspire X 2017 software. The Halo 2s are much better in many respects compared to the Halos. Smaller, much higher fidelity, etc. But they need to be tweaked a bit.

Connected fine via the Trulink USB and my 2016 software, but then it popped up saying I needed the 2017 software. HELP!! I can’t find it anywhere.

Anyone point me where I can get the 2017 version of Starkey’s inspire X software?

1 Like

#73

Isn’t there an update option within the software that will upgrade the older version to a newer version?

0 Likes

#74

it does not indicate anywhere in the version I have an update option.

0 Likes

#75

Look in your sys-Tray for Inspire Updater.

No updates because I was on 2017.0, stepping out, BBL

0 Likes

#76

the version I had installed seemed to have disable the updater. I uninstalled my version of starkey x 2016.1, installed the version you had listed, now it is updating. Let’s hope the VA did not put a lock code on the HAs. :confused:
BTW, the link is somewhat broken in that the path is incorrect; the exe file is no longer available, pops up with an error.[Broken link, starkey Inspire software download]

(https://starkeypro.com/public/starkeysoftwaredownload/Inspire/Domestic/Starkey%20Setup%2015.0.419.0.exe)

I instead went here to download. working link starkey inspire download

1 Like

#78

If you build it, they will come… (╯°□°)╯︵ ┻━┻

0 Likes

#79

Phonak Target 5.2 link is broken
Can somebody hep ?

0 Likes

#80

Can anyone confirm if Phonak Target 5.2 works on Windows 10? I’m on Windows 7 at the moment but want to upgrade.

0 Likes

#81

Yes, everything works on Windows 10.

2 Likes