Help with ComPilot 2

Hi there. I’ve got a used Compilot 2 for my son to use with the TV, tablet etc but am having problems.
If I put it into demo mode I can hear the test sounds no problem through the hearing aid. However as soon as I switch to a Bluetooth source, the hearing aid beeps like it’s back to ‘ready’, and despite the audio light being solid blue I can’t hear anything streamed. I’ve tried a couple of different tablets, my phone, the TV and nothing from any of them. Also tried plugging an audio cable into the bottom but can’t hear that. It’s like the loop stops working as soon as it is out of demo mode.
I’ve been all through the manual to try and figure it out. Has anyone had similar issues setting it up before?
Many thanks in advance

Welcome to the forum.
Which aids do you have? They need to match your streaming device.
Most people use the TV Link or the TV Connector pending on the aids.

If it’s used it might still be linked to the old owners HAs.

Seems you may need to pair(Identify) it to the HAs in the Phonak Target software. Can you confirm that the volume and program changes work ok. Compilot2 is for Venture and Belong platform. Phonak marvel can’t use the Compilot2.
Older model Quest uses Compilot.