Connecting Phonak Marvel TV adapter

I have had Phonak Marvel M70 aids since 1 April this year. They were supplied with the Phonak TV adapter which I find very helpful. I can connect it to my TV set or directly to the cable box via the optical connector.

But for streaming programs from the internet, which my wife and I do quite a bit, I use an Apple TV device, 3rd generation. With the Phonak TV adapter connected to the TV set I get no sound when streaming. However, the Apple TV device has an optical output so I can just connect the Phonak adapter to it and it works well.

But swapping the connector from one device to the other is a bit of a hassle and I would like to find some way around it. Does anyone have any ideas?

In your TV’s settings under sound. Find Digital Audio TV. There you need to set it to PCM.
Good luck.

Thanks for responding. I’ll see if I can implement your suggestion, but there is a further detail I forgot to mention (my bad) which probably means this won’t work.

I route the signal from the Apple TV to my stereo receiver so I can get the sound through the stereo. The receiver is then connected to the TV via HDMI. So there is no sound from the TV speakers when streaming.

Did I explain that clearly?

Thanks again.

Yes, give it a try.
Hope it works for you.

My TV doesn’t seem to offer that setting. But it’s a pretty old set, at least 10 years.

Ok, I thought you were not getting sound in your aids.
You want sound in your aids and coming out of the TV.
Sound right?

Actually, when streaming I would like to have sound coming to the hearing aids and through the stereo speakers, and not from the TV speakers. But if I could get sound to the aids while streaming by connecting the Phonak device just to the TV that would be fine. I can always mute the TV sound to the room.

Amazon sells a toslink (digital audio) combiner. It can take three inputs and provides one output. This may work for you if I understand your problem

1 Like

Thanks, that looks like it could be the solution.

Most AVRs in the past several years will not downmix a digital audio signal to analog. If you are lucky enough to have a digital out from your AVR use that to connect to the TV Link. If not then you will have to connect each source to AVR with analog cable along with however it was connected (hdmi, etc). Then connect TV Link with analog cable to one of the analog output jacks on AVR. You will have to select ‘analog’ for audio signal on AVR (as opposed to auto, or digital). It’s a pain but once set up not too bad.

That just has tv do the audio decoding as opposed to the AVR. I don’t think that really is going to resolve the OPs issue.

Thanks, barkeater, but my receiver, an eight-year-old Denon AVR-2312CI, does not have a digital audio out port. It doesn’t even have an analog audio out port that will work with the Phonak TV adapter.

I think the device linked to by jtberthoty above is the solution I seek.

I have been using this device for a few days now, and it does indeed solve my problem. Thanks very much for your research and for alerting me to it.

Glad to hear that it works for you.

1 Like