Bluetooth not working after installing Phonak Roger Select iN

I now have my Roger Select iN along with my Roger Easy Pen. I think I have been a to transfer my Roger receiver from the Select iN to my Paradise hearing aids. Since doing that, I cannot connect my HAs to my iPhone bluetooth nor can I get myPhonak to pair with my hearing aids. Before I did the receiver transfer my HAs bluetooth worked fine with my iPhone and myPhonak. Any help will be GREATLY appreciated. I am at my wits end (it’s happened before :wink:)

Try booting your phone.

1 Like

I have tried booting my Phone, deleting and re-installing myPhonak and putting my HAs in the charger all to know avail.

I really have no idea, but this is what I would try. Other option is to seek help from somebody like an audiologist. First: Are you hearing aids working with the Roger devices? Doesn’t really change anything, but would be good to know. Do you have Target and self program? If so, I’d take a look around at programs and make sure there’s separate programs for Roger and streaming. If nothing obvious shows up, I’d try uninstalling the Roger receivers and see if ability to pair with phone returned. If so, I’d try reinstalling the receivers and see if problem recurred. Sometimes just doing things over again helps. If not of this helps, I’d definitely seek help. Also, VERY reasonable to seek help from professional now.

Thanks for the advice. I was able to solve the problem myself. BTW, my Select iN works great.

1 Like